Troubleshooting Scenarios
Troubleshooting Scenarios
The following topic can help you troubleshoot issues that you may have with the Integrity Mobile module:
Unable to Connect to the APM Server
Description
The following error appeared when attempting to enter APM server URL:
Could not connect to the APM Server. Please check the URL as this could be caused by an invalid address or the server is down.
Cause
This may occur if the URL is invalid or the server is down.
Solution
- Verify the APM Server URL.
- Connect to the application server via device's web browser.
Login Page in Offline Mode Does Not Contain the Password Box
Description
When you logging in an offline mode, login page appears only with USERNAME/SSO ID textbox.
Cause
This may occur if you have lost connection with the APM server.
Solution
- Login in an offline mode providing your Username/SSO ID, and then enter your six-digit offline PIN.
- Verify your WIFI connectivity.
Unable to Transfer Data When Attempting to Check Out an Inspection
Description
The following error appeared when attempting to check out an inspection:
Integrity Mobile is experiencing a connectivity issue with the APM server and is unable to transfer data.
Cause
This may occur if there is a connectivity issue with the APM server.
Solution
- In case of spotty WIFI connectivity, return to an area with good connectivity.
- Logout and log in back in an offline mode to continue to edit inspection that you have already been checked out while online.
Uploading an Inspection Fails
Description
A failure occurs when uploading an inspection in the My Inspections page and the following error message appeared:
Sync Errors.
Cause
This may occur due to the field validation error.
Solution
Unable to Access a Previously Checked Out Inspection
Description
A previously checked out inspection can not access on the inspector's device to upload or delete.
Cause
This may occur if an inspection is locked on the APM server. It can only be accessed in a read-only state on the APM server when it is checked out. You can only upload or delete the inspection.
Solution
- Log in as a Superuser or a User with the Inspection Administrator resource role.
- Navigate to the Inspection management overview page.
- Access the Open Inspections section.
- Select the checked out inspection which you want to revoke.
- Select Revoke.