Troubleshooting Scenarios

Troubleshooting Scenarios

The following topic can help you troubleshoot issues that you may have with the Rounds Designer module:

Dashboard Tile Count Does Not Appear or Takes Longer Time to Load the Count in the RCM/FMEA Overview Screen

Description

In the Applications menu, navigate to the STRATEGY section, and then select Reliability Centered Maintenance. The dashboard tile count takes longer time to load, or it does not appear in the module overview page.

Cause

This issue may occur if any of the database indexes are missing.

Solution

Perform the following step:

Run the following script for the RCM/FMEA equipment, recommendation, and the RCM/FMEA recommendation families. This improves the loading performance of the Reliability Centered Maintenance page.

CREATE NONCLUSTERED INDEX [<N_MI_RCMEQPMT_ID_NK>]
ON [dbo].[MI_RCMEQPMT] ([MI_RCMEQPMT_EQUIP_ID_C])
INCLUDE ([ENTY_KEY])
CREATE NONCLUSTERED INDEX [<N_MI_REC_ANALY_KEY_FK>]
ON [dbo].[MI_REC] ([MI_REC_ANALY_KEY_NBR])
INCLUDE ([ENTY_KEY])
CREATE NONCLUSTERED INDEX [<N_MI_RECRCM_ACTIO_TYPE_FK>]
ON [dbo].[MI_RECRCM] ([MI_RECRCM_ACTIO_TYPE_C])
INCLUDE ([ENTY_KEY])
These indexes have been added to the baseline product, in version 4.4. This step is applicable to Version 4.x and earlier versions.
Note: Run the script directly in the database.

RCM Data Loader Gives an Error After Loading the RCM Data

Description

The following error appeared when loading the RCM/FMEA data loader:

2021-11-02 10:19:44.0206|Batch [0015]|ERROR| RCM FMEA Recommendation '<Recommendation name …> ' was processed more than once due to ambiguity in reference column information.

2021-11-02 10:19:44.0215|Batch [0015]|DEBUG| Finished processing Batch [0015]

Or

2019-11-25 11:47:47.635412|Batch [0001]| Error - RCM FMEA Failure Mode ‘<Failure Mode name…>' was processed more than once due to ambiguity in reference column information.

2019-11-25 11:47:49.104147|Batch [0001]| Debug - Finished processing Batch [0001]

Cause

The dataloader file contains duplicate names in the Failure Effect, Failure Modes, Recommendations, and Secondary Action sheet as there is no option to differentiate the duplicate names in the datasheet.

Solution

Perform one of the following options:
  1. Do not have same Failure effect or Failure mode or Recommendation or Secondary action names.
  2. If you cannot implement the first option, then the column Related Asset ID must be added in the Failure Mode, Failure Effect, Recommendations, and Secondary action sheet.

Unable to Promote RCM Analysis to Asset Strategy Management (ASM)

Description

Navigate to RCM analysis and then select Promote to ASM.

The following error appeared when promoting an RCM analysis to ASM:

20398861,6/18/2021 12:13:22 PM,CoreNex, This object does not exist., "This object does not exist. at Meridium.Core.Catalog.Manager.CatalogManager.RetrieveFolder(String sessionId, String path, Int32 childLevels) in C:\Builds\84\APM\4500x-Code\src\Current\Source\apm-infra\src\Meridium.Core\Catalog\Manager\CatalogManager.cs:line 860 at Meridium.Core.Catalog.Manager.CatalogManager.RetrieveCatalogItem(String sessionId, String path) in C:\Builds\84\APM\4500x-Code\src\Current\Source\apm-infra\src\Meridium.Core\Catalog\Manager\CatalogManager.cs:line 1777 at Meridium.Api.Core.Controllers.CatalogContract.RetrieveCatalogItem(String sessionId, String path)",20065838

Cause

All risk assessment in RCM analysis for Failure Effect and Recommendation is done using Default risk matrix (the risk matrix marked checked as Default). This issue may occur if there is change in the Default risk matrix.

Solution

Perform the following steps:
  1. In the Applications menu, navigate toTools > Operations Manager > Risk Matrix. If the current default risk matrix differs from the one returned in the following query for that analysis, then you will not be able to promote to ASM. The risk assessment should be same as mentioned in the query to mitigate an action in ASM.
  2. Run the following query for the analysis to know which Risk Matrix is being used when promoting to ASM:
    SELECT [MI_RCMFMODE].[MI_RCMFMODE_NAME_C] "Failure Mode Name"
    , [MI_RCMFMODE].[MI_RCMFMODE_REL_ASSET_ID_C] "Mode Name Asset ID"
    , [MI_RECRCM].[MI_REC_ID] "Recommendation ID"
    , MI_ENTITIES.ENTY_ID "Recommendation Asset"
    , [MI_RISKASSE].[MI_RISKASSE_RM_NAME_C] "Risk Matrix Name"
    FROM [MI_RCMANALY]
    JOIN_SUCC [MI_RCMFUNCN]
    JOIN_SUCC [MI_RCMFFAIL]
    JOIN_SUCC [MI_RCMFMODE]
    JOIN_SUCC [MI_RCMFEFFT]
    JOIN_SUCC [MI_RECRCM] LEFT
    JOIN_SUCC [MI_RISKASSE] ON {MIR_MITRISK} ON {MIR_HRCMREC} ON {MIR_HRCMFEF} ON {MIR_HRCMFMD} ON {MIR_HRCMFFL} ON {MIR_HRCMFNC}
    JOIN {MI Has Recommendations} ON [MI_RECRCM].ENTY_KEY = {MI Has Recommendations}.SUCC_ENTY_KEY
    JOIN MI_ENTITIES ON MI_ENTITIES.ENTY_KEY = {MI Has Recommendations}.PRED_ENTY_KEY
    WHERE [MI_RCMANALY].ENTY_KEY = (? :n :id=AnalysisKey)
    
  3. If the current risk matrix is marked as Default, then change the risk matrix to the previous matrix and then mark as Default.