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Chapter 1. Proficy Authentication

About Proficy Authentication

Proficy Authentication (UAA) provides identity-based security for Proficy based applications and APlIs.
It supports open standards for authentication and authorization, including Oauth2. You can configure
Proficy Authentication from Configuration Hub.

When a user is created or deleted in a product that uses Proficy Authentication, the associated user

account is created or deleted in the Proficy Authentication instance, respectively.

Several Proficy products use Proficy Authentication, including Historian, Plant Applications, and
Operations Hub. To use Proficy Authentication, you must install one of these products. Each product
can install an independent instance of Proficy Authentication, or it can reuse an existing instance of
Proficy Authentication which was previously installed by another Proficy product. When more than one
product uses the same instance of Proficy Authentication, this is called a shared or common Proficy
Authentication.

Shared Proficy Authentication (UAA) means that if you have a Proficy product installed that uses Proficy
Authentication, additional Proficy products installed after that initial product can also share that existing,

already configured Proficy Authentication architecture.

Proficy Authentication can additionally be configured to use an external identity provider. This includes
identity providers which use Lightweight Directory Access Protocol (LDAP) or Security Assertion Markup
Language (SAML). When you integrate Proficy Authentication with an external identity provider, you

can provide the users and groups from that identity provider with access to Proficy products and their
features.

Set up Proficy Authentication

This topic describes how to set up Proficy Authentication in Configuration Hub.
The following steps describe how to set up Proficy Authentication in Configuration Hub. Setting up

authentication provides access to all the products (Historian, iFIX) registered with Configuration Hub. You
use the same Proficy Authentication server to authenticate.

i
1. Double-click desktop icon to launch the Configuration Hub application.
2. Select Setup Authentication.
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Configuration Hub Login @

Authentication Source not configured Click setup below to configure

Setup Authentication

The Configuration Hub Administrator Credentials screen appears.
3. Enter the details for logging in to the Configuration Hub application.

Field Description

Client ID The client ID provided during installing Configu-
ration Hub. Example: confi ghubadmi n

Client Secret The client secret provided during installing Con-
figuration Hub.

Configuration Hub Administrator Credentials X

confighubadmin

MNOTE: Use the credentials created during the install process.

4. Select Verify.
If the credentials are correct, the Register with Proficy Authentication screen appears.

5. Provide these details to configure the Proficy Authentication application.
These fields are populated automatically if you opted for installing Proficy Authentication along
with Configuration Hub. You have the option to edit and update the details.
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Field

Description

Server Name (Fully Qualified Name)

The host name of the machine where Proficy
Authentication is installed.

Enter a fully qualified domain name. For exam-

ple, deskt op- sahf g5f . | ogon. ds. ge. com

Refer to step 6 to establish a trust with this
server connection.

Server Port

The port number to communicate with the host
machine. The default port where UAA is in-
stalled is 443.

The server connection is automatically tested
on entering the port. You can also select Test
to test the connection.

Use Configuration Hub Administration creden-
tials for Proficy Authentication

Select this check box to populate the same lo-
gin credentails you entered for Configuration

Hub Admin account.

If you want to use unique login credentials for
Proficy Authentication, clear the check box and
enter CLIENT ID and CLIENT SECRET.

Proficy Authentication Client ID

The administrator client identifier that has per-
mission (authority) to log in to Proficy Authenti-
cation.

Proficy Authentication Client Secret

The administrator client secret to log in to Profi-
cy Authentication.




Proficy Authentication | 1 - Proficy Authentication | 7

Register with Proficy Authentication bd
SERVER MAME (FULLY QUALIFIED NAME)

sachinauthguardiamymO1.htclab.ge.com

SERVER PORT

443

Test Server Connection

Proficy Authentication Credentials

+ | Use Configuration Hub Administration credentials for Proficy Authentication

CLIENT ID

CLIENT SECRET

MOTE: Use the credentials created during the install process.

Register

6. Select Not trusted to establish a trust connection between Configuration Hub and Proficy
Authentication.
The Certificate Details screen appears.
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Certificate Details

Attribute Name Root Certificate

Subject CH=5ACHINAUTHGUARD Root CA 202112241544, OU=0perations Hub Site,
0=GE Customer

Thumbprint OBEBESFDALT2CIDCFTABCARF12T085EF1338119C

Serial Number IFETECCITI2CHAG9

Issuer CH=SACHINAUTHGUARD Root CA 202112241544, OU=0perations Hub Site,
0=GE Customer

Valid From 2021-12-24 00:00:00 GMT

Valid To 2026-12-23 00:00:00 GMT

Don't Trust m

7. Select Trust.

The trusted certificate(s) are added to the windows store on the machine where Configuration Hub
is installed.
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Register with Proficy Authentication pe
SERVER MAME (FULLY QUALIFIED MAME)
sachinauthguardianvm01.htclab.ge.com @ Sl

SERVER PORT

443

Test Server Connection

Proficy Authentication Credentials

| Lse Configuration Hub Administration credentials for Proficy Authentication

CLIEMT ID

CLIENT SECRET

NOTE: Use the credentials created during the install process.

Register

8. Select Register.
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Register with Proficy Authentication x

A default user ch_admin is created with password same as
FProficy Authentication secret, please use this to continue to login

Ok

9. Select Ok.
The Configuration Hub Login screen appears.

Configuration Hub is set up as a client for Proficy Authentication. The following default user is created to

log in to the Configuration Hub application.

User ID Password

ch_admin The client secret you entered for Proficy Authenti-

cation.

Log in to Configuration Hub and perform operations related to Proficy Authentication.

Application Overview

Proficy Authentication provides identity-based security for Proficy based applications and APIs.

You can perform the following tasks in Proficy Authentication:
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« Configure UAA/LDAP/SAML identity providers

- Create new user accounts

- Create new group accounts and add users/other groups as members
« Perform UAA/LDAP/SAML group mapping

Displaying Data Columns

You can show or hide columns within the Proficy Authentication application.

o . . . . .

1. Select {:} for the respective data. The Column Chooser dialog appears with a list of available
columns.

2. Select the check box for the column you want to show. To hide a column, clear its check box.

3. Close the dialog to apply the changes.

Sorting Data

The sorting option appears when you select a data column.

* Select T to sort data in an ascending order.

« Select l to sort data in a descending order.

Filtering Data

The filtering option appears next to each data column.

1. Select for the data you want to filter. A screen appears with a list of existing data in that
column.
2. Select the check box for the data you want to filter. To undo filtering, you can Select All.

3. Select OK to apply.

Searching Data

Use the search option to seacrh for existing accounts in Proficy Authentication. You can also filter

account details using search keywords.
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Manage Identity Providers

Add LDAP Identity Provider

This topic describes how to add a LDAP account in Proficy Authentication.

Log in to Configuration Hub with user/client having write access for admin and clients.

You can add multiple LDAP connections.

1. Go to Proficy Authentication > Security > Identity Provider.

2. Select + and then select LDAP.

Security-Proficy Authentication

Identity Provider roups  Users

(:)\ Search

Identity Providers 1

DE

Okta Login Station saml

uaa uad

The LDAP Identity Provider screen appears.

3. Enter the following details:

Field Description
Name A unique name to help identify your LDAP con-
nection.
URL The URL of the LDAP server. The trailing slash

(/) must be included at the end of the URL.

You can use LDAP with or without secure au-
thentication in the following format:
° Insecure port:
| dap: //100. 100. 100. 2: 389/

o Secure port: | daps: //100. 100. 100. 2: 636/

You can also use a fully qualified domain name

instead of an IP address.
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Field Description

For a secure port, provide user credentials.

Bind User Distinguished Name Distinguished LDAP user name.

Describes the part of the hierarchy the user
belongs to on the active directory network.
CN=Common Name. DC=Domain Component.
OU= Organization Unit Name.

CN and DC are typically required, while OU is
optional.

Example: cN=John Sni t h, OU=Fact ory, DC=Conpa-
ny, DC=COM

Password The password to log in to the LDAP server if
you choose secure authentication.

Test Tests the connection to the LDAP server. If the
URL and login details are correct, you will re-

ceive a test successful message.

Skip SSL Verification This option appears only when you choose a
secure port for LDAP.

Select this check box if you want to skip estab-
lishing a secure connection between client and
server for exchanging LDAP data.

Clear the check box to allow SSL verification.
Refer to step 4.
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LDAP Identity Provider

Mame®

DSFREESORFORUM

LIRL*

Idap//10.181.215.2: 389

Bind User Distinguished Name *

CN=spouser] CN=Users, DC=pa,0DC=com

Password ®

LELELEXELES @
Test Cancel Save

4. If you choose to secure LDAP, select = for SSL verification.

A message appears when the security certificate is trusted and added to the store.

In case the certificate is not added automatically, the following message appears.

Close

Select Browse to navigate and choose the server certificate from your local system.

&

5. Optional: Select next to the lock icon to view the certificate.
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certAttributeMame  Root Certificate

certSubject CH = CWARIRSSVRZK19.pa.com

certThumbprint 4T 23FCE4421BBEALSR46CRFSAGSEERTZBSBOZATE

certSerialNumber  SEO0000002F TOODEEE5058 LAFDOOOO00000002

certissuer DC = com,pa CN = CWARIRSSVRZK1S.pa.com
-Eert'h"alidan‘l Jun 21 18:28:08 2021 GMT
certValidTe Jum 21 18:28:08 2022 GMT

Close

6. Select Save.

LDAP Identity Provider

Mame*®

CWARIRSSVR2K191

URL®
Idapsy [OWARIRSSVRZK19.pa.com:6 36/ 5 @

Bind User Distinguished Name ™

CN=sachin2,CH=Users,DC=htcophub,DC=internal

Password

Skip SSL Verification
Test Cancel

The LDAP identity provider is created.
Enable SAML
This topic describes how to configure SAML identity providers for Proficy Authentication.

You should enable SAML prior to adding SAML IDP accounts (on page 26) in Proficy Authentication.
To enable SAML, you will need to download the Proficy Authentication service provider's metadata file.
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1. Visit https: //enter FQDN of the machine where Proficy Authentication is installed/ uaa/san /netadata to
download the sani - sp. xni file.

2. To configure any SAML identity provider, gather information from the downloaded sani - sp. xni file.

3. Generate a metadata XML file from the configured identity providers, and use the file to add a
SAML IDP account (on page 26) in Proficy Authentication.

Refer to the following examples on how to set up SAML identity providers for Proficy Authentication:

« Configure Okta as SAML IDP (on page 16)
- Configure Azure AD as SAML IDP (on page 22)

Configure Okta as SAML IDP

This topic describes SAML configuration with Okta.

1. Create an account in Okta.

a. Visit https://developer.okta.com/.

b. Sign up for an Okta account using your email address.
2. Log in to your newly created Okta account.
3. Navigate to Applications > Applications.

okta

Dashboard hd

Directory w

Customizations g

Applications /‘
Applications

Self Service

Security hd

4. Select Create App Integration.


https://developer.okta.com/
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Developer Edition provides a limited number of apps.

Deactivate unused apv check out our plans page. Contact us to find a plan that is right for your organization.

Create App Integration Browse App Catalog Assign Users to App More -

Search
STATUS @ Okta Admin Console
ACTIVE 0
INACTIVE o @ Okta Browser Plugin

Okta Dashboard

The Create a new app Integration screen appears.
5. Select SAML 2.0, then select Next.

Create a new app integration

Sign-in method ODC - OpenlD Connect

Token-based OAuth 2.0 authentication for Single Sign-On (S50) through API
Learn More (2 B l ’
endpoints. Recommended if you intend to build a custom app integration with

the Okta Sign-ln Widget.

© samL20
XML-based open standard for $30. Use if the |dentity Provider for your

application only supports SAML.

SWA - Secure Web Authentication
Okta-specific S50 methed. Use if your application doesn't support QIDC or
SAML.

API Services
Interact with Okta APls using the scoped OAuth 2.0 aceess tokens for

machine-to-machine authentication.

The Create SAML Integration screen appears.
6. Under General Settings, provide a name and logo for your application, then select Next.
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o General Settings

1 General Settings

App name Multiverse Paradigm
App logo (optional) A E
App visibility Do not display application icon to users

7. Under Configure SAML, fill out these details:

Single sign on URL Use the dowloaded Proficy Authentication
metadata file (on page 15) sani -sp. xni 1o
get the URL for this field. It should look some-
thing like this:

O O
<md:AssertionConsumerService

i ttps:/ /ghldz593e.logon.ds.ge.com/uaa/saml/SS0/alias/ophubSamiSp"
r i ML:2 indi ITTP-POST" isDefault="true"

<md:AssertionConsumerService
Location="https:/ /ghldz593e.logon.ds.ge.com/ uaa/oauth/token/alias/ophubSamiSp"
Binding="ur i ML:2 indi I" index="1"/>

Audience URI (SP Entity ID) Refer to sam - sp. xni to get the logout URL. It

should look something like this:

<?xml version="1.0" encoding="UTF-8"?>

- <md:EntityDescriptor entityID="https://ghldz593e.logon.ds.ge.com/uaa/saml|/metadata”
ID="https___ghldz593e.logon.ds.ge.com_uaa_saml_metadata"
xmins:md="urn:oasi: SAML:2, ">

Enable Single Logout a. Select Show Advanced Settings.
b. Select the check box for Allow applica-

tion to initiate Single Logout.
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c. Enter Single Logout URL. Refer to san -
sp. xm to get the logout URL. It should
look something like this:

/Sit ogout/alias/
TTP-POST'/>

ogout/alias/

Attribute Statements (optional)

Add user attribute statements such as email,

first name, and last name as shown here:
Attribute Statements (optional)

Mame MNama format Valee

Add Anather

Group Attribute Statements (optional)

Add group attribute statements such as groupA
and groupB as shown here:

Group Attribute Statements (optional)

Mame Mame format Fitter

-~

N

. I
Note:
The setting option mentioned in this topic is the minimum requirement for setting up
the SAML identity provider. Refer to the Okta documentation for information on using
additional settings.
J

8. Select Next.
9. Provide your feedback and select Finish.


https://help.okta.com/en-us/Content/index.htm
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3  Help Okta Support understand how you configured this application

Are you @ customer of partner? I'm an Okta customer adding an internal app
ﬂ I'm a software vendor. I'd like to integrate my app with
Okta

Onee you have a working SAML integration, submit it for Submit your app for review
Dlkta review te publish in the OIN.
Previous

Your application is created.
10. Under Sign On, select Identity Provider metadata.
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Multiverse Paradigm

| Active -

Once you have a working SAML integration, submit it for Okta review to publish in the OAN.

v

General Sign On Import Assignments

| - | View Logs Meonitor Imports

Settings Edit

Sign on methods

The sign-on method determines how a user signs into and manages their credentials for an
application. Some sign-on methods require additional configuration in the 3™ party application.

Application username is determined by the user profile mapping. Configure profile mapping

SAML 2.0

Default Relay State

SAML 2.0 is not configured until you complete the setup instructions.

View Setup Instructions

Identity Provider metadata is available if this application supports dynamic configuration.

Credentials Deatails

The metadata opens in a new tab.
11. Save the metadata as an .xml file.
Use the metadata xml file to configure a SAML identity provider (on page 26) in Proficy
Authentication.
12. Under Assignments, you can assign the app to groups and individual users.
If there are no users/groups, navigate to Directory > People to create and activate new users/

groups in Okta.
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Configure Azure AD as SAML IDP

This topic describes SAML configuration with Azure AD (Active Directory).

1. Visit https://azure.microsoft.com/en-us/free/ and create an account.

2. Add an enterprise application. For more information, refer to Microsoft Azure documentation. ops
Hub Dev is the example enterprise application used in the procedural steps (refer to the figure in
step 2).

3. Create at least one user and group.

The following steps include:

« Creating a SAML app in Azure (steps 1-5).
« Configuring Azure metadata xml in Proficy Authentication (steps 6-7).

1. Download Proficy Authentication sani - sp. xmi metadata file. Refer to Enable SAML (on page 15)
on how to download the file.
2. Sign in to the Azure portal, and upload sam - sp. xm .
a. From left menu, select Manage > Single sign-on.
b. Select Upload metadata file.

Ops Hub Dev | SAML-based Sign-on

B s :
—
—————— s
P apphcapae poow
2]
"
8
-
Astenty
D g o

3. Perform user and group attribute mapping in Azure.


https://azure.microsoft.com/en-us/free/
https://docs.microsoft.com/en-us/azure/active-directory/manage-apps/add-application-portal
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a. Under the User Attributes & Claims section, select Edit and add claims.

Attributes & Claims

givenname

surmame
emailaddress

name

Unique User Identifier
Group

uEer.givennamae
User.surmame

user.mail
user.userpnncipalname
useruserpnncipalname
user.groups

b. Select Add new claim and save entered details to set up claims.

] T
Attributes & Claims

Lk s

PR S D5 D D S, O O b Ty LT GrOups

BT [named-tommanemala s "

‘Wbt

L Qeoups [SecurityGroup]

Note:

in step 6a (on page 25).

Make a note of the claim name value (for example user. gr oups). You need to
provide this value in the Attribute Name field when adding a SAML identity provider

J
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c. Select Add a group claim and set up group claims.

Dashibosrd > o

Attributes & Claims

Fpidd Apphiilons

L-based Sign-on

Group Claims

Marage the group claims used by Azure AL to populate SAML tokens revsed to your app

=+ add new claim S5 Columns 57 Got feedback? D This page includies. previews avalable for your evaluation in the ‘Advanced aptions’ section.
i laim

Required clai Which groups sssacisted with the usar shaould ke retumad in the dsim?

Claim name Vahse O none

Unicgue User identifier (Namne |0 useruserprincpainame [namesd-formatamaidgress) o= (0 Al groups

(®) Security groups

Additional claims O wirectory roles

Claim name Valwe O croups assigned 1o the appication

s SHOUPE NSO Lbabius "7 source steibute
hittg/schernas.amiscap.ong/ws/2005/05 identity/claims/emailadd... usermail == | GreupiD

hitgs/jseheemas. 9 g usargivenname
http//schemas. /2005, en SR UERT]
htpryfschemasamisoap.org/ws/2008/08 identity/claims/sumame  usersumame

w Advanced cptions

4. Under the SAML Signing Certificate section, download the Federation Metadata XML file.

Atmty
R 0 s sgung conteme & o
a aspe & mughty AT I e
a . el U —————— L
RSt kg P 4083008 FUR08 AN
B Sretreg log o e o S— T
g Uptar e WAPLIEP 1] g g meCros A DN o B S .
Airent reeew PP — ]
I P i Wt BN ] I
u L up Cipl Ml Do
e T Fabied B DEwleiurs W Pz et b il with ASure AD
Logen iy, iftpry  csgen eCros oo Corv, il - . T
At AT s g W et el - BT T
£ =
5. Perform user group mapping in Azure.
JBp DOIICREGROUSL | Mernbers
B mate Y B gy ——
@ Cuarers
W Gt B e D W S o o b managed @ ha b o LT SO 10 S S S
AR W T Ty
I P
- . T oy i
& Cumn o T = Lk
& Pk 4 st e - —
o T r———— Las v (R
& g membnb e rlibrr——— \homb
e e Bl 1= f——

B icosomors

g ee—

ey reveren
B ksticm

Y AeR—.
finstiitstrg + b

B e e e
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6. Log in to Proficy Authentication and do the following:

a. Upload the Federation Metadata XML file downloaded from the Azure portal in step 4 (on
page 24).
For step-by-step instructions, refer to Add SAML Identity Provider (on page 26).

b. Add and map SAML groups.
For step-by-step instructions, refer to Map Groups (on page 39).

7. To test SAML authentication, visit Operations Hub login page, and select Sign In With Azure.

0
|@I GE Digital

e laal=]

elCcO

g ‘jh...___,

» You should login successfully. In Azure portal, you can access the logs to verify successful
logins:

5) e e Sign-in loge

a . e | Rant 34l b e Laad e e ol o R

o If login access is denied, then verify the group attribute name and group name from SAML
Azure (see troubleshooting below). Clear the cache and login again.

Troubleshooting: For troubleshooting, add SAML-tracer extension to Chrome.

1. Open SAML-tracer from your browser extensions.
2. Log in to Operations Hub to reproduce the SSO login issue.
3. In SAML-tracer, look for PosT messages, and select the Summary tab.


https://chrome.google.com/webstore/detail/saml-tracer/mpdajninpobndbfcldcmbpnnbhibjmch?hl=en
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In the following screenshot, incorrect SAML group attribute names were detected, and replaced

with the correct ones to fix the login issue.

B SAML-tracer
un i Povse (I Y XY = Exvont & oot
POST  hilps Mhogen microscfioning combSasis-6442-4155.9522.02ec6a5 3512 T o

POST
GET hiips Mogen ve comWle bim =3

——— s
A— —
i
GET N R | | —
gy
GET hitps i i ol Corpiqninfo jRon
GET hitps il Uk cN COrpiqnsonptidumoy_dalaistyies pon
e
HTTP  Parameders SAML Summary
schenps  microsoft com ident ity /claing /object identif Ler 18770504 - an A . 537 . . 0] &
Kenmgmm & Teeters
[ o

hilps Mbrcwaer events data mcrosof comiOneCollector/l DM corstnmbccnient hpe=apphtalonic-pon-sireamboient-d=N0_AUTHSchent version=105-\eb-J5-3 1. 11 Sapkey=69a

POST hiips Mogin microscfionkine comylomsi
— J

atiommethod/password

p /s 5 microsoft  comiws/ 200886/ Ldentity/claim /prousy B S
WEtp://ach 3¢ claims/d typrovider hetps /7 sts windows . net /DR F )5 - £282 - 4450 B2 - S2ecEal IE1T [E
» L http: // schenas . adcrosoft. con/ws/ 2088/ 06/ identity /authentic
= 5 e

Add SAML Identity Provider

This topic describes how to add multiple SAML accounts in Proficy Authentication.

Enable a SAML identity provider (on page 15). For example, Okta or Azure AD or any other IDP.

You can add multiple SAML connections.

1. Log in to Configuration Hub as an administrator.

2. Go to Proficy Authentication > Security > Identity Provider.

3. Select + then select SAML.

Security-Proficy Authentication

Identity Provider ) Groups  Users

Q, Search

Identity Providers T Type

Action

+ &

LDAP

Okta Login Station

uaa

The SAML Identity Provider screen appears.

4. Enter the following details:

SAML
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o ™
Note:
The XML file contains the metadata to interact with SAML enabled identity providers
(Azure, ADFS, or Okta). Refer to Configure Okta as SAML IDP (on page 16).

Field Description

Upload XML File Choose this option if you want to upload an
XML document.

Select Upload XML File to browse and locate
the XML document from your local system.
The uploaded data appears in a text box, and is

read-only.

Provide File Location Choose this option if you want to provide an ex-
ternal URL to the XML document.

Enter the URL in the text field, and select Load.
The data from the URL appears in a text box,
and is read-only.

Name Name of the SAML identity provider. You can
provide any name. For example, okt a_123 oOfr de-

nmo_mach_azure.

Attribute Name The attribute that contains the group member-
ship information about a user in a SAML asser-

tion.

Name ID SAML Name identifier and associated fields

that you want to use in a link test.

Enable SAML Link Select the check box.
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SAML Identity Provider

HOTE : All fields are mandatory

Upload XML File &) Provide File Location

hitps://dev- 380200232 .oktacom/appresk 2UUgkcSPL faabd?/sso/saml/meta

<#oml version="1.0" encoding="UTF-&" > <mdEntityDescripbor
entitylD="httpy/ /www.oktacomyexk2uughc SPUNI faa5d7T” =

i panli P TP T 1T [0 W Ve AN ] 1, * o1 a Y o W (o

NHamea"

okta_123

Artribute Name*

emai

iy

umapasisnames:icSAML: 1. 1:nameid-formatemaildddress o
| Enable SAML Link

Cancel Sawve

5. Select Save.
The SAML identity provider is created.
Enable Multi-Factor Authentication
This topic describes how to enable multi-factor authentication for users.
Install the Google Authenticator app on your mobile device.
Only administrators can enable multi-factor authentication (MFA) for users.

Note:

Enabling MFA also enables two-factor authentication for UAA and LDAP users as both the identity

providers have a common login entry point.

1. Log in to Configuration Hub as an administrator.
2. Go to Proficy Authentication > Security > Identity Provider.
The existing list of identity providers appear.
3. Select the uaa record for which you want to enable the multi-factor authentication.


https://play.google.com/store/apps/details?id=com.google.android.apps.authenticator2
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The option to enable MFA appears on the DETAILS panel under the MFA section.
4. Enable the toggle switch for MFA.
By default, MFA is disabled.

»  ADMINISTRATOR CREDENTIALS Ei‘

Client ID admin
v GENERAL
URL https://deskto...
»  MFA
Disabled _,_[\Fj
Authenticator Googl.. =~ v MFA
Enabled a
Authenticator Googl. -

The multi-factor authentication for uaa is enabled.
5. Select Authenticator.
Currently, Google authenticator is the only available authenticator.
6. Restart the GE Proficy Authentication Tontat Wb Server Service.
7. Activate multi-factor authentication for user logins.
You need to perform the following steps only for the first time for every user login.

a. Log in to Configuration Hub with UAA user credentials.

The MFA setup screen appears with a barcode.
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Setup Multitactor Authentication

1. Install Google Authenticator on your mobile device from the App Store
on your iPhone or Google Play on your Android.

2. Open Google Authenticator on your mobile device,

i

. Tap the "+" button.
4, Tap "Scan barcode”,

L

. Scan this barcode:

Can't scan barcode? See manual setup instructions.

=

b. Open the Google Authenticator app on your mobile device and scan the barcode.
The authentication app validates the user login and displays a 6-digit code. Barcode

scanning appears only for the first time validation for every user login.

c. On your browser, select Next on the MFA setup screen.
The code verification screen appears.

d. Enter the 6-digit code in the passcode field and select Verify
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I@ GE Digita

Enter your Google Authentication Code

Enter the 6-digit code displayed in Google Authenticator app:

Back

You are logged in successfully.

Multi-factor authentication is enabled for both UAA and LDAP users.

Modify LDAP Identity Provider

This topic describes how to modify the existing details for the LDAP account.

Add LDAP Identity Provider (on page 12)

1. Log in to Configuration Hub as an administrator.
2. Go to Proficy Authentication > Security > Identity Provider.
The existing list of identity providers appear.
3. Select the LDAP identity provider.
The existing information for the identity provider appears on the DETAILS panel.

4. To modify the GENERAL details, select [ to open a pop-up screen with the existing information.
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>

CWARIRS5VRZK1D

G\ T,

s GENERAL

URL®

CWARIRSSWVEZK1S

vy (CWARIRSSVRZK 19 pa.come 389

ientestuser,CN=Users, D =pa, ..

CWARIRSSWVRZKLS

LS

=rPPrinic pa Mame: _I':

5. If you modify any existing information, save the changes.

The general details are required to configure LDAP authentication.
6. To modify OTHER SEARCH CRITERIA details, place your cursor and enter the new value for the

respective criteria.

“ OTHER SEARCH CRITERIA

Group Base
User Base
User Filter
Group Filter

Max Filter

DC=pa,DC=co..,
DC=pa,DC=co..
icng (V)]
member={0}

10

Use these settings to enable the sub-directories in your search criteria.

Search Criteria

Example Value

Description

Group Base

OU=Sal es, OU=G oups, OU=En-

terpri se, DC=conpany, DC=com

Defines the starting point for the LDAP group
search in the active directory tree.
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Search Criteria Example Value Description

> CN is Common Name (required)

o DC is Domain Component (required)

> OU is Organization Unit Name (option-
al)

(g ™
Note:
If you use only bc=Ge, bc=com time-
out may occur due to slow system

response. Use the exact cuto avoid

timeout.
N J

User Base OU=Sal es, OU=User s, OU=En- Defines the starting point for the LDAP group
terpri se, DC=conpany, DC=com | user search in the active directory tree.

(L ™
Note:
If you use only bc=Ge, bC=com time-
out may occur due to slow system
response. Use the exact auto avoid

timeout.
N J

User Filter user Pri nci pal Nane={ 0} Allows the LDAP user (active directory user)
to login into Configuration Hub with their
email address.

User Filter cn={ 0} Allows the LDAP user (active directory user)
to login with their display name. This is field
is populated by default.

User Filter sAVAccount Nane={ 0} Allows the LDAP user (active directory user)
to login with their account name (Windows
login name). This is field is populated by de-
fault.

Group Filter member ={ 0} Retrieves the nenber & attribute values for
the specific user. This is field is populated by
default.
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Search Criteria Example Value Description

Max Filter 10 Defines the maximum depth for searching
the LDAP groups. The default value is 10.

For very large systems, set the value to 2 as

it may impact system performance.

Modify SAML Identity Provider

This topic describes how to modify the existing details for a SAML account.

Add SAML Identity Provider (on page 26)

1. Log in to Configuration Hub as an administrator.
2. Go to Proficy Authentication > Security > Identity Provider.
The existing list of identity providers appear.
3. Select the SAML identity provider you want to modify.
The existing information for the identity provider appears on the DETAILS panel.

4. Select EJH to display the details in a pop-up screen.

DETAILS =

Okta Login Station

Q, Search

> GENERAL @

» OTHER SAML PROPERTIES

The SAML Identity Provider screen appears.

5. You can modify the existing information and save the changes.
6. You can also modify items under OTHER SAML PROPERTIES section. Enter a new value to replace

the existing value.

Delete Identity Provider

This topic describes how to delete identity providers.
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Add SAML Identity Provider (on page 26)

1. Log in to Configuration Hub as an administrator.

2. Go to Proficy Authentication > Security > Identity Provider.
The existing list of identity providers appear.

3. Select the identity provider you want to delete.
Additional options appear under the ACTION column.

4. Select EEE then Delete.

Security-Proficy Authentication

ldentity Provider ) Groups  Users

Q Search + {c:,}

Identity Providers 1 Type

Okta Login Station

Map Groups

uaa uaa .M

A message appears to confirm the delete action.

5. Select Delete.

The identity provider record is deleted from the Proficy Authentication database.

Manage Groups

Overview of iFIX Groups in Proficy Authentication

Proficy Authentication provides access to the following security groups for iFIX access:
scada. fi x_shared_| FI X_PROFI CY_AUTH_ADM N, scada. fi x. shar ed. APPLI CATI ON_DESI GNER,

scada. fi x. shar ed. OPERATORS, scada. f i x. shar ed. SUPERVI SORS, and scada. proficy. adm n.

The following descriptions explain the access provided for iFIX groups in Proficy Authentication.

* scada. fi x_shar ed_I FI X_PROFI CY_AUTH_ADM N: This group allows access to all iFIX application

DE|

Ok

features. Any Proficy Authentication user who is a member of this group will have privileges similar

to a native iFIX ADMIN user (except the access to security areas). Proficy Authentication users who

want to directly log in to iFIX can use this group.

This group is not available by default when you upgrade from iFIX 6.1 or 6.5. You must manually

create this group with all the iFIX application features as needed.
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* scada. fi x. shar ed. APPLI CATI ON_DESI GNER: This group allows a user to access Configuration Hub and

provides use of iFIX features such as iFIX connection, database, and model management.

Important:
Be aware that the scada. fi x. shar ed. APPLI CATI ON_DESI GNER group is not available by default
when you upgrade from iFIX 6.1 or 6.5. You must manually create the group with the
required iFIX application features, or update your existing groups to include the following
iFIX application features (if you want users in these groups to have access to and use
Configuration Hub).

> Database Block Add-Delete

- Database Manager

> Database Reload

> Database Save

o Security Configuration

» System Configuration

To create a new group or modify an existing group, use the iFIX Security Configuration application.

* scada. fi x. shar ed. OPERATORS: This group provides run mode only access for a user in iFIX.

* scada. fi x. shar ed. SUPERVI SORS: This group provides access to WorkSpace run and configure mode,
as well as access to background task exit, iFIX system shut down, and iFIX system user login.

* scada. profi cy. adni n: This group allows the Proficy Authentication user access to the iFIX
Projects panel and to the Deploy operations from Configuration Hub. This group is for Proficy
Authentication only; this group is not linked to any iFIX group and has no permissions in iFIX.

Overview of Historian Groups in Proficy Authentication

Proficy Authentication provides access to the following security groups for Historian access:

hi storian_enterprise.adnin, historian_enterprise.user,historian_rest_api.admn,

hi storian_rest_api.read, historian_rest_api.wite, historian_visualization.admn,

hi storian_vi sualization.user,ih_archive_admns, ih_audited_witers,ih_collector_adnmins,ih_readers,

i h_security_adnins,ih_tag_adnins,ih_unaudited_| ogins,andih_unaudited witers.

The following descriptions explain the access provided for Historian groups in Proficy Authentication:

- historian_enterprise. adm n: Provides read/write access to Configuration Hub APlIs.
* historian_enterprise. user: Allows access to Configuration Hub APIs.

* hi storian_rest _api . adni n: Provides read/write access to public REST API.

* hi storian_rest_api.read: Provides read access to public REST API.
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* historian_rest_api.wite: Provides write access to public REST API.
* hi storian_visualization. adni n: Provides access to Trend Client and the Web Admin console.

* hi storian_visualization.user: Allows access to Trend Client.

*ih_archive_admns,ih_audited witers, i h_collector_admns,ih_readers,ih_security_adm ns,
i h_tag_adnins, i h_unaudited_l ogi ns, i h_unaudi ted_writers: Provides access to tables for the
Historian OLE DB provider.

Create Groups

This topic describes how to create new groups in Proficy Authentication.
Log in to Configuration Hub as an administrator.

For example, you can create a group for users who perform the same task on the same resource.
You can have a group of supervisors for each line such as, Super vi sors_Li neA, Supervi sors_Li neB,

Supervi sors_Li neC.

1. Go to Proficy Authentication > Security > Groups.

2. Select _I_

Security-Proficy Authentication %

Identity |=|::-.-u|e~| Users

Group Name |
clients.admin 0
clients_read 1
clients.secret 0

clients.write 1

The Add Group screen appears.

3. Enter the following details for the new group.

Field Description

Group Name A unique name of the group that does not
match with any existing Proficy Authentication

groups. For example, Super vi sors_Li neA
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Field Description

Description A brief description of the group.

Add Group

Group Name*

Supervisors_LineA

Description

Members to monitor Linedl

Cancel Add

4. Select Add.
The group is created successfully.

The newly created group is added to the list of groups on the Groups tab.

Modify Groups

This topic describes how to modify existing groups in Proficy Authentication.
Log in to Configuration Hub as an administrator.

You can modify a group to:

« Add/Remove Users in a Group (on page 42)
» Add/Remove Sub-Groups in a Group (on page 43)
» Map Groups (on page 39)

1. Go to Proficy Authentication > Security > Groups.
The existing list of Proficy Authentication groups appear.
2. Use any of these options to open a group.
> Double-click the group name you want to modify.
> For the group you want to modify, from its ACTION column, select EEl, then Edit.
The group opens in a new tab.
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el f1at8 2 [ TATETT Tl confighub.access-Proficy Authentication <

Group

confighub.access -

Member(Users) Mapping Member(Groups)

Q Search + {g}

User Name 1 Origir Email
ch_admin uaa ch_admin@test.org
kal_el uaa krypton@grail.com

phantom uaa devilwolf@gmail.com

3. You can modify the following:

Tab Description

Member (Users) Displays the list of users added to this group. Add/Remove
Users in a Group (on page 42).

Mapping Displays the list of mapped groups for this group. You can add/

remove mapped groups (on page 39).

Member (Groups) Displays the list of sub-groups added to this group. Add/Re-

move Sub-Groups in a Group (on page 43).

Map Groups

This topic describes how to perform group mapping.
Log in to Configuration Hub as an administrator.

You can map any of the following to a Proficy Authentication group. The users belonging to these groups

gain access to Proficy Authentication, and become a member of the target group.

» UAA groups
* LDAP
* SAML groups

1. Go to Proficy Authentication > Security > Groups.
The existing list of Proficy Authentication groups appear.
2. Double-click and open the group you want to map to UAA/LDAP/SAML groups.
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3. Select the Mapping tab.
4. Map UAA groups.

a. From the Identity Provider drop down list, select the UAA record.
The groups from the UAA record appear.

b. Select the check box for the groups you want to map to the Proficy Authentication group
selected in step 2.

c. Select - to move the selected items from Groups to Mapped Groups.

Group
confighub.access -
Member(Users)  Mapping  Member(Groups)

Identity Provider

uaa -
Groups Mapped Groups
O
v cloud_controller.admin scim.invite
clients.read uaa.resource
(_
clients.secret
uaa.admin =

clients.admin

The users belonging to the mapped UAA groups are now a member of the Proficy
Authentication group selected in step 2.

5. Map LDAP groups.

a. From the Identity Provider drop down list, select the LDAP record.
The groups from the LDAP server appear.

b. Select the check box for the groups you want to map to the Proficy Authentication group
selected in step 2.

c. Optional: To search for an LDAP group, enter the keyword in the LDAP Groups Search Filter

.-

field and select Y .

d. Select - to move the selected items from Groups to Mapped Groups.
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Member(Users)  Mapping Member(Groups)

Identity Provider

UAA LDAP

LDAP Groups Search Filter

(objectclass=*)

Groups

DM

CN=HelpLibraryUpdaters,CN=Users,DC=p...
CN=WSS5_ADMIN_WPG,CN=Users,DC=pa,...

CN=Administrators,CN=Builtin,DC=pa,DC...

CN=Guests,CN=Builtin,DC=pa,DC=com

CN=Print Operators,CN=Builtin,DC=pa,DC...
CN=Backup Operators,CN=Builtin, DC=pa,...

CN=Replicator,CN=Builtin,DC=pa,DC=com

Mapped Groups
DN

CN=5QLServer20055QLBrowserlUser$C...
CN=SQLServerMsASUserfCWARIRSSVRZ...
CN=WS5_WPG,CN=Users, DC=pa,DC=com

CMN=Users,CMN=Builtin,0C=pa,DC=com

The users belonging to the mapped LDAP groups are now a member of the Proficy

Authentication group selected in step 2.

6. Map SAML groups.

a. From the Identity Provider drop down list, select the SAML record.

b. To create SAML groups, enter the valid SAML group name in the Add SAML Group field and
select the plus icon.

Group

cloud_controlleradmin =

Member(Users) Mapping Member(Groups)

ldentity Provider

Okta Legin Station -

Add SAML Group

GIOUpS

Group Name |

c. Select the check box for the groups you want to map to the Proficy Authentication group

selected in step 2.
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d. Select - to move the selected items from Groups to Mapped Groups.
Group

cloud_controlleradmin -

Member(Users) Mapping Member(Groups)

Identity Provider
Okta Login Station -

Add SAML Group

+
Groups Mapped Groups
O Group MNar Group Mame
zl corp_group Secure_sys_group
v action_group «

cloud_group

If the mapped SAML groups are valid, then all their users become a member of the Proficy

Authentication group selected in step 2.

7. To unmap any of the mapped groups, select and move them back to Groups.

UAA/LDAP/SAML groups are successfully mapped.

Add/Remove Users in a Group

This topic describes how to add or remove users from a group.

Modify a group (on page 38) to add or remove users.

1. Select the Member (Users) tab.

2. Select _I_
The Map User screen appears.
3. Select the check box for the user account you want to add to the group.

To remove user from a group, clear the check box.
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Map User
Q. Search
User List 1
ch_admin
kal_el
mandrake_01
V| phantom

WOTE: Mapping supported for UAA users only.

4. Select Apply.

The users are added to (or removed from) the group.

Add/Remove Sub-Groups in a Group

This topic describes how to add or remove sub-groups from a group.

Modify a group (on page 38) to add or remove sub-groups.

1. Select the Member (Groups) tab.

2. Select _I_
The Group Membership screen appears.

3. Select the check box for the group/s you want to add as a sub-group.
To remove a sub-group from a group, clear the check box.
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Group Membership
Q Search

[ | GROUPNAME 1

clients.admin

clients.read
[+] clients.secret
clientswrite
v cloud_controller.admin
confighub.admin
Cancel Apply
! Important:

Do not select the check box for i gp. st udi oAdni n group for any users or groups. As this
group is for reserved purposes, make sure no user accounts or groups are assigned to this
group to avoid runtime errors.

4. Select Apply.

The groups are added (or removed) as sub-groups in the group.

The users added to the sub-groups are automatically associated to the main group.

Delete Group

This topic describes how to delete Proficy Authentication groups.

Log in to Configuration Hub as an administrator.

1. Go to Proficy Authentication > Security > Groups.
The existing list of groups appear.
2. Select the group you want to delete.
Additional options appear under the ACTION column.
3. Select EEE then Delete.
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Identity pIO'JidSElS

Q Search + &

Group Name T Members Action

clients.admin 0

clients.read

Edit

clients.secret 0
clients.write 1
cloud controller admin 0

A message appears to confirm the delete action. The message also informs if users are
associated to the group being deleted.

4. Select Delete.

The group account is deleted from the Proficy Authentication database.

Manage Users

Create Users

This topic describes how to create new users in Proficy Authentication.

Log in to Configuration Hub as an administrator.

1. Go to Proficy Authentication > Security > Users.

2. Select ‘l‘

Security-Proficy Authentication

Identity Provider Groups

Q. Search

User Name T Email Crigin Action
ch_admin ch_admin@test.org uaa
kal_el krypton@gmail.com uaa
mandrake_01 magician@gmail.com uaa

phantom devilwolf@gmail.com uaa
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The Add User screen appears.

3. Enter the following details for the new user account.

Field Description
User Name The user name to log in to Proficy Authentica-
tion.
Password The password to log in to Proficy Authentica-

tion.

Confirm Password

Enter the password again for confirmation.

Email

User's email address.

Add User

User Mame®

sys_admin
Password®

Email®

pacman@gmail.com

4. Select Add.

Add

The user is created and added to the list of user accounts on the Users tab.

The new user is associated to default Proficy Authentication groups. These default groups

cannot be deleted or modified: approval s. ne, cl oud_control | er. read, cl oud_control | er. write,
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cl oud_control |l er_service_perm ssions. read, oaut h. approval s, openi d, password. wite,profile,roles,

scim e, sci m userids, uaa. of fl i ne_t oken, uaa. user, user_attri butes.

Every user/client must possess the following three scopes to access the Security plug-in via Configuration
Hub. If these scopes are not added, then a warning message alerts the user to contact Admin.

Scope Description
uaa. adni n This scope indicates that this is a superuser.
clients.wite This scope resets the Security plug-in's admin

client secret.

password. write This admin scope enables to change the user
password.

(g ™
Note:
This scope is assigned to all the UAA/
LDAP/SAML users by default without the

need to assign manually.

Default ch_adni n has all the three scopes.

For user accounts originating from LDAP or SAML, refer to Add LDAP/SAML Users (on page 47).

Add LDAP/SAML Users

This topic describes how to add LDAP/SAML users to Proficy Authentication.
You must have an LDAP or SAML user account.

Only user accounts created in Proficy Authentication are immediately visible in the users list. LDAP or

SAML users must perform the following steps to create user accounts in Proficy Authentication.

Log in to Proficy Authentication with LDAP/SAML user credentials.
A shadow user is created in Proficy Authentication. and can be subsequently seen in the Proficy

Authentication users list.

The LDAP/SAML user account is added to the list of accounts on the Users screen.

Add/Remove Groups for a User

This topic describes how to modify group membership for existing user accounts.
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Create Users (on page 45)

1. Go to Proficy Authentication > Security > Users.
The existing list of user accounts appear.

2. Select the user account for which you want to modify group membership.
The existing information for the user appears on the DETAILS panel.

-
3. Select 4 next to the GROUP MEMBERSHIP section.

.

ch_admin

Q_ Search

» GEMERAL

» GROUP MEMBERSHIP @

uaa.admin

sSCIm.write

The Group Membership screen appears.

4. Select the check box for the groups you want to add the user as a member.

To remove a group, clear the check box.
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Group Membership

[ | GROUPNAME 1

clients.admin

w clients.read
clients.secret
w clientswrite
cloud _contraoller.admin
o confighub.access
Cancel Apply
! Important:

Do not select the check box fori gp. st udi oAdmi n group for any users or groups. As this
group is for reserved purposes, make sure no user accounts or groups are assigned to this

group to avoid runtime errors.

5. Select Apply.

The groups are added (or removed from) for the user.

(g
Note:
If a logged-in user attempts to remove his/her own scopes/groups, the remove operation may fail
and result in an error: Error whi | e assigning the group. In such instances, the user should log

out of the Configuration Hub application and log-in again. We recommend that logged-in users

should avoid removing their own scopes.
-

~

Reset User Password

This topic describes how to reset passwords for Proficy Authentication users.

Log in to Configuration Hub as an administrator.

1. Go to Proficy Authentication > Security > Users.

The existing list of user accounts appear.
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2. Select the user account for which you want to reset the password.
The option to reset password appears on the DETAILS panel under the PASSWORD section.

Security-Proficy Authentication

Identity Provider  Groups  Users phantarn
0, 5e

Q, Search + &

User Name 1 ma Origi Action » GEMERAL

ch_admin ch_admin@test.ong uaa S GROUPMEMBERSHIP &

kal_el kryptoni@gmail.com uaa )
~  PASSWORD

mandrake_01 magician@gmail.com uaa

Last Maodified 04/01/2022, 2.

phantom devibwolf@gmail com

Last Logon

ResetPassword

3. Select RESET.
The Password Reset screen appears.

4. Enter the new Password and Confirm Password for the user account.

Password Reset

User Name®

Password®

Confirm Password*

Cancel ResetPassword

5. Select Reset Password to apply the changes.

The password is reset for the user.

Delete User

This topic describes how to delete Proficy Authentication user accounts.

Log in to Configuration Hub as an administrator.
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1. Go to Proficy Authentication > Security > Users.
The existing list of user accounts appear.

2. Select the user you want to delete.
Delete option appears in the ACTION column.

Identity Provider Glot!p

Q, Search + &
User Name 1 mai Origir
ch_admin ch_admin@test.org
kal_el krypton@gmail.com uaa
mandrake_01 magician@gmail.com uaa
phantom devilwolf@gmail.com uaa
e
T
3. Select 141,

A message appears to confirm the delete action.
4. Select Delete.

The user account is deleted from the Proficy Authentication database.

Windows Integrated Authentication / Auto-login

Windows Integrated Authentication is a new capability added to Proficy Authentication Service from

version 2.5.

When Windows Integrated Authentication or Auto-login is enabled, users logged into any Windows
machine in a domain are able to access Operations Hub and/or hosted Proficy applications without the
need to type in their Windows credentials again. The same Windows logged-in user context is used for
authenticating the user. Based on the user's privileges, access is provided to Operations Hub and/or its
hosted applications.

This document describes the steps to configure the 'Windows Integrated Authentication’ functionality
in an instance of Proficy Authentication service. After configuring auto-login, when you attempt to log
into Operations Hub / hosted Proficy applications, the Select Authentication screen appears (see figure
below) to choose between st andard Proficy Authentication LoginOr Active Directory (W ndows)

I ntegrated Login.
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If you choose Active Directory (Wndows) Integrated Login,the authentication option will follow

the new flow and you will not be prompted for providing credentials. Whereas choosing st andar d

Proficy Authentication Login will take you through the normal authentication flow and prompt for your

credentials.

-~

Note:

scope.

« The auto-login capability is only for authenticating the users. For authorization or access
permissions, you have to configure LDAP IDP. To accomplish this, select the same active
directory service / LDAP server, which brings the authentication service node, application
accessing nodes in the network, and the users seeking auto-login, into the same Windows

« For configuring LDAP IDP, refer to Add LDAP Identity Provider (on page 12).

Select Authentication

® Standard Proficy Authentication Logmr

Active Directory [Windows) Integrated Lomn

Standard Proficy Authenti-
cation Login

Choose this option if you want to use the standard login (username/pass-
word or SAML).

This is a regular login, which is based on username/password, including
LDAP, or SAML.

Active Directory (Win-
dows) Integrated Login

This option appears only if Windows auto-login is configured.

This allows to automatically log into Operations Hub using the user's do-
main login session that was used to log in to Proficy Authentication.

Don't ask me again

Select this check box, if you don't want to display the Select Authentication
screen every time you login.

The system remembers the last selected authentication (between regular
and autologin) and applies it for future logins.
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With Don’t ask me again enabled, you can clear the last selected authenti-

cation only during logout.

You have logged out

You should now close the browser
or click here to login again.
You may also click here to clear the

previgusly selected authentication option.

Select You may also click here to clear the previously selected authentica-
tion option to clear the saved selection. Once cleared, the clearing option is
hidden from the logout screen.

Select click here to login again to return to the login page.

Defer

Select to dismiss this screen, and skip selecting an authentication. You

have the choice to select authentication next time you login.

To configure Windows Auto-login, an administrator performs the following tasks only for the first

time. The first task is performed on all the participating nodes (Active Directory service node, Proficy

Authentication service node, and the client nodes). The second and third are performed on the

Windows Active Directory Server machine. The fourth task is performed on the machine where Proficy

Authentication is installed.

1. Configure Security Policy (on page 54).

2. Create a service principal for your user account (on page 56).

3. Generate the Kerberos keytab file (on page 59).

4. Update the Proficy Authentication .yml file (on page 62).

5. Add LDAP Identity Provider (on page 12) for the Active Directory service used in Steps 2 and 3.

Note:

Users logging into DPM products using Windows Auto-login are authorized / get the

scopes based on the LDAP configuration performed in Step 5.

To configure the browser settings for Windows Auto-login, the following task is performed on the end-user

machine.
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« Configure the browser settings for Kerberos authentication (on page 63).

Figure 1. Windows Auto-login - Deployment Topology and Configuration

ex: uag.tesf.ge.com

All the three participating nodas are in the same realm.

______________ Windows Server hosting

Active Directory Service / KDC

Actions :

1. Ensure that the security pelicy setting
Network security: Configure encryption types
aliowed for Kerberos'is set to same

Elient node accassing Proficy-Authentication Service
from Browser

Actions :

1. Ensure that the security policy setting for Network
security: Configure encryption types aliowed for Kerberos'is
set to same encryplion types as it is on Active Directory
server and the Proficy Authentication service node

2. Launch Internet Explorer and open 'Internet Options'
3. Open "Security” tab and select 'Local Intranet'.

4. Click the 'Sites’ button and add the url of the

Proficy Authentication service to the existing

sites list
5. For the Windows Integrated Authetication use
UseKerbAuth' query parameter while accessing the Proficy
Authentication Service URL, like
https:/fqdnoftheproficyauthneticationservice/uaal?
UseKerbAuth=trus

Configure Security Policy

encryption types as it is on Proficy
Authentication Service node and the Client
node(s).

2. Generate SPN for the Proficy
Authentication service

3. Generate a keyiab file with the SPN

Windows Server hosting Proficy Authentication Service

Actions :

1. Ensure that the security policy setting for Nefwork security: Configure
encryption types allowed for Kerberos'is set to same encryption types as it is on
Active Directory server and the Client node(s).

2. Copy the keytab file from AD server and paste on this machine
in any path

3. Edit the section ‘kerberos’ in the uaa.ymi file (C\ProgramData\GE\Operations
Hub\uas-cenfig) with SPN name (generated on the Active Directery server ) and
local keytab file location.

4. Using the Security Administration Tool or Security plug-in in ConfigHub configure
the same Active Directory server as LDAP IDP.

This topic describes how to configure security policy setting associated to Kerberos authentication.

It is possible that you may not have access to your computer’s local security policy settings, if it is
governed by a group policy (controlled by your domain administrator). In any case, make sure that these
security options are enabled for your computer.

If your environment is not governed by a group policy, then follow these steps to configure local security
policy:
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1. To access Local Security Policy, enter secpol . msc in Windows Run dialog and select OK.

= Ruif X

5 Typt the name of a program, felder, document, or Intermet |
resource, and Windows will open it for you.

=
open: | IETERR ]

Cancel

2. Navigate to Security Settings > Local Policies > Security Options.

» @ User Rights Assignment
» i Security Options
» ] Windows Defender Firewall with Advai
- Metwork List Manager Policies
» [ Public Key Policies
*| Software Restriction Policies
» [] Application Control Policies
» 3 1P Security Policies on Local Computer
» ] Advanced Audit Policy Configuration

:h: Metwork access: Shares that can be accessed anonymously

Ly, Metwork access: Sharing and secunty model for local accounts

i, Metwork security: Allow Local System to use computer identity for.
s, Metwork security: Allow LocalSystem NULL session fallback

o, Network security: Allow PKU2U authentication requests to this co..
‘ Metwark security: Configure encryption types allowed for Kerberos
5 Network security: Do not store LAN Manager hash value on next ..
:,:5 Metwaork security: Force logoff when logon hours expire

jﬁ Metwark security: LAN Manager authentication level

il i ignin ir

i Local Security Policy - ] b
File Action View Help
o 2nm XE )
=Y Security Settings Policy Security Setting -
ra Account ch.ahmes i, Network access: Remotely accessible registry paths and sub-paths  System\CurrentControlS..
v -a Loc:l P:IH-;: 5 Metwork access: Restrict anonymous access to Named Pipesand . Enabled
<@ Audit Policy i, Metwork access: Restrict dients allowed to make remote calls to 5. Mot Defined

Classic - local users auth..
Disabled

Mot Defined

Disabled

AES128_ HMALC_SHA1AES.

Enabled
Disabled
Send NTLMv2 response ..

3. Double-click and open Net wor k security: Configure encryption types allowed for Kerberos

security policy setting.

4. Select the valid encryption types that you want to use as shown in the figure. Ensure that the

selection is same across all the participating nodes.

You can select either AES128_HVAC _SHA1 Or AES256_HMAC_SHA1 as the encryption type. Also select the

Future encryption types option.
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Metwork security: Configure encryption types allowed for ... 7 *

Local Security Setting  Explain
} Metwaork security: Configure encryption types allowed for Kerberos
¢

—TCTY - -
RC4_HMALZ MDS5 [
AES128_HMAC_SHA1
AES256_HMAC_SHA1
Future ancrypion types i v

& O

o] om0

-

Note:

In our current documentation, we use AES256_HVAC_SHAL encryption type in our example

code to generate the keytab file (on page 59).

N

For more information refer to Microsoft documentation on security policy settings.

Create Service Principal Name

This topic describes how to create a service principal name.


https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2012-r2-and-2012/dn452420(v=ws.11)#to-configure-a-setting-for-your-local-computer
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« Create a dummy user account on the Active Directory Server node to represent the Proficy

Authentication application in the active directory registry. Make sure to implement these settings

for the account:

o It is mandatory user is a member of the domain user group. Refer to Microsoft

documentation for more information.

o Set the account password to never expire. To do so, access the domain user account

File

. Active Directory Users and Comp

Action View Help

e 2@ £0 XE

| Saved Queries
v 3 uaatestad.gecom

>

| Builtin

- Computers

2| Domain Controllers

2| Enterprise

| ForeignSecurityPrincipals
| Keys

| LostAndFound

~| Managed Service Accoun
8l MFG

| Program Data

_| System

| Users

| NTDS Quotas

| TPM Devices

L2t

properties dialog: Account > Account options > Password never expires.

s BHre AR TE%R

;:ﬁ Service Account Proficy SPN Autologin Properties ¢ X

G

!EG Published Centificates Member OfF Password Replication  Diakin ~ Chbject

gﬁ Security Environment Sessions Remoate control

- ¥el Remote Desktop Services Profile COM+ Attnbute Editor

ﬂG General  Address  Account Profle  Telephones Crganization

QG User logon name:

%g @uoatestad.go.com :
G User logon name (pre-Windows 2000):

&' b UAATEST srvAcctProficySPN

B«

Eo‘k Logon Hours... Log On To...

2

& n Ll Unlock account

&

E} n Account options:

E; N ("] User must change password at next logon o

& N [_] User cannot change password

& p (] Password never expires

%P || Store password using reversible encryption ~

&B R Account expires

%R » Never

Eb: (D End of: 02 March 2023

s

2

s

s [k ] concet [ wa Help



https://learn.microsoft.com/en-us/microsoft-desktop-optimization-pack/medv-v1/how-to-configure-a-domain-user-or-groupmedvv2#how-to-add-a-domain-user-or-group
https://learn.microsoft.com/en-us/microsoft-desktop-optimization-pack/medv-v1/how-to-configure-a-domain-user-or-groupmedvv2#how-to-add-a-domain-user-or-group
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« Configure Security Policy (on page 54)

A

= - .

7

File Action View Help

& 20 40 XEcz H ai3TE%

1 Active Directory Users and Comp | Nama Tura Dl rrintione
» | Saved Queries & uaaautologin Properties ? x
.4 §3 uaatestad.gecom &
> | Builtin % Organization ~ Published Certificates  Member Of  Password Replication
> ] Computers g Dialin Object Secunty Environment Sessions
» 4. Domain Controllers % Remote control  Remote Desktop Services Profile  COM+  Attribute Editor
» El Enterprise & General Address Account Profile Telephones Delagation
» [ ForeignSecurityPrincipals [
» 1 Keys #,|  Userlogon name:
» 71 LostAndFound %: _HWPfuaaautulugm.uaalesud.ge.c_ @uaatestad.ge.com E
> [Z] Managed Service Accoun & User logon name (pre-Windows 2000):
» ] Program Data B yaaresn uaaautologin
» [ System &
_] Users 2 Logon Hours... Log On To...
» 1 NTDS Quotas 2|
> [l TPM Devices g: [ Unlock account
E: Account options:
%l ["] Use only Kerberos DES encryption types for this account Cu
E ["] This account supports Kerberos AES 128 bit encryption.
2, | [l This account supports Kerberos AES 256 bit encryption.
E; [ Do not require Kerberos preauthentication =
&‘ Account expires
% | (®) Never
%" ) End of: 27 January 2023
3 (o] om [ A e
L4 »

Note:

Delete existing SPNs, if any. Refer to Useful SPN commands (on page 69).

You must be an administrator to perform this task.

1. Log in to your Active Directory machine.

2. Open the Windows Command Prompt application.
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3. Run the following command replacing with the appropriate code: set spn -S HTTP/ <FQDN> <user

account >

Code

Replace With

<FQDN>

Fully Qualified Domain Name (FQDN) of the server on which Proficy

Authentication service is running.

For example, HTTP/ wi n16- phant omhost . uaat est ad. ge. COMAUJAATESTAD-
. GE. com

- ™\
Note:
These should be in capital letters:

o HTTP

o UAATESTAD. GE. coM(the domain name that follows @)
& J

<user account>

Dedicated dummy user account created for Proficy Authentication

service.

For example, ghost 1.

Based on the above examples, your code should look like this: set spn - S HTTP/ wi n16-

phant omhost . uaat est ad. ge. COm@QJAATESTAD. GE. COM ghost 1

The service principal name (SPN) is created.

Generate Keytab File (on page 59)

Generate Keytab File

Generate the Kerberos keytab file.

Create Service Principal Name (on page 56)

You must be an administrator to perform this task.

1. Log in to your system and open the Windows Command Prompt application.

2. Run the following command replacing with the appropriate code: kt pass -out <filename> -princ

HTTP/ <servi ce pincipal nane> - mapUser <user account> -mapQOp set -pass <password> - Crypto AES256-

SHAL - pType KRB5_NT_PRI NCI PAL
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Code

Replace With

<fil enanme>

Name of the keytab file.

Note:

Keytab file name can be any given name.

The file is created at the default location. You also have the option
to specify an absolute path for file creation. For example, - out c:

\ Docurent s\ myskul | cave. keyt ab.

<servi ce pinci pal

nanme>

Enter the service principal name that was created in the following
format: HTTP/ wi n16- phant omhost . uaat est ad. ge. com@QJAATESTAD. GE-

. Com

<User account>

Enter the same dummy user account that was used during creating
the service principal name.

For example, ghost 1.

(o ™
Note:
If you want to use a different user account, delete the ex-
isting user account, (or) rename the logon name in the

user account.
- /

<passwor d>

Proficy Authentication dummy user account password.

AES256- SHA1

Encryption algorithm you want to use.

Note:

GE recommends AES256- SHAL. But you can also use

AES128- SHAL.

KRB5_NT_PRI NCI PAL

Encryption type you want to use.

If the keytab is successfully created, the log should look something like this:

C:\ User s\ Adnmi ni strat or >kt pass -out c:\ Tenp\ SACH NJOHUB21VM uaat est ad. ge. com keytab -princ

HTTP/ SACHI NJOHUB21VM uaat est ad. ge. COM@AATESTAD. GE. COM - napUser Mark -nmapOp set -pass Gei 32litc -crypto

AES256- SHAL - pType KRB5_NT_PRI NCI PAL




Proficy Authentication | 1 - Proficy Authentication | 61

Targeting domain control |l er: uaatestad. uaatestad. ge. com

Usi ng | egacy password setting nethod

Successful |y mapped HTTP/ SACH NJOHUB21VM uaat est ad. ge. com to Mar k.

Key created.

Qut put keytab to c:\Tenp\ SACH NJOHUB21VM uaat est ad. ge. com keyt ab:

Keyt ab version: 0x502

keysi ze 105 HTTP/ SACH NJOHUB21VM uaat est ad. ge. com@UAATESTAD. GE. COM ptype 1 (KRB5_NT_PRI NClI PAL) vno 3 etype 0x12

(AES256- SHA1) keyl ength 32 (0x3f b2a2824864a6b3617bf a4a6458af 83534ef db8a3eac08b02316cce9c4ee’f c)

Example of a failed log:

C:\ W ndows\ syst enB2>kt pass -out c:\Tenp\w nl6-sachi n. uaat est ad. ge. com keytab -princ
HTTP/ wi n16- sachi n. uaat est ad. ge. com@QJAATESTAD. GE. COM - mapUser John - mapQp set -pass Cei 32litc -crypto
AES256- SHAL - pType KRB5_NT_PRI NCl PAL

Targeting domain controller: uaatestad. uaatestad. ge.com

Usi ng | egacy password setting nethod

Failed to set property 'userPrincipal Nane' to 'HTTP/wi n16-sachi n. uaat est ad. ge. COmM@AATESTAD. GE. COM on Dn
' CN=John, CN=User s, DC=uaat est ad, DC=ge, DC=coni : 0x13.

WARNI NG Failed to set UPN HTTP/wi nl16-sachi n. uaat est ad. ge. COmM@JAATESTAD. GE. COM on
CN=John, CN=User s, DC=uaat est ad, DC=ge, DC=com

kinits to 'HTTP/w nl6- sachi n. uaat est ad. ge. COm@QAATESTAD. GE. COM wi Il fail.

Successful |y mapped HTTP/ wi n16-sachi n. uaat est ad. ge. com to John.

Key created.

Qut put keytab to c:\Tenp\w nl6-sachin. uaat est ad. ge. com keyt ab:

Keyt ab version: 0x502

keysi ze 102 HTTP/ wi n16- sachi n. uaat est ad. ge. COMQAATESTAD. GE. COM ptype 1 (KRB5_NT_PRI NCI PAL) vno 9 etype 0x12

( AES256- SHA1) keyl ength 32 (0x8b551a22050935e9ace848cachacc86a4eb845e63b6461d4f 31b7d815158cf 6¢)

You can also do the following to verify if the service principal is mapped to the dummy account, and a
keytab is created:

1. Go to Active Directory Users and Computers > Users.
2. Access the properties of the user account for which you created the keytab file.
3. On the Account tab, verify User logon name. is pointing to your service principal name.
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T Active Directory Users and Compd| name e Description

y = Queries &, rdmiristrator User Built<in account for admin.

v mun-:.‘f‘.grmm B tllowed RODC Passward Rep.. Security Group . Members inthis group ca..
j g:::mm H3, Cent Publishers Security Group . Membiers of this group ar-

!Eclcm:\ahlr Domain Contrellers Seounty Group - Membiers of this group the

: : ED::::;WmIIm E, Denied RODC Passweord Repl_  Security Group - Memhers-m_lh profusa Properties ) »
» B Foreignsecuritybrindpals B2, Dretdrnins Security Group = DNS Admiristr
> B Keps B2, BrsUpdateProxy Security Group _  DNS dients wh ¢ Publishod G MemberOf  Password Replontion
7 LostAndFound %Dﬁmain.ﬁdmins Secunty Group - Designated ad Diakin Ohjoct Security Envimnment Spssions
| Managed Senice Account %Domain(omputers Security Group - All workstation  Remole contrel Remole Deskiep Sendces Profie  OOMs+  Aliribute Editor
» [ Program Data %Domain(orlmlbers Security Group . All domaincon  Genesal Address Hcoounk Profia Telaphans Dalegation
s B System B2 Domain Guests Security Group . All domain gue
| Users EDumainUsm Secunity Group - All domain use
1 NTDS Quotas %Emcfprise Admins Security Group - Designated ad L1
1 TPM Devices B Enterprise Key Admins Security Group . Members of thi User logon name (preWindows 2000)
!Eimnrpriw Read-only Domain.  Secunty Group . Members ofthi UAATEST, profuss
&, Gaurd1 User
R, GeOpHublreTrustStoreMana_  Security Group _  Members inthi Logan Hours... Log OnTo..
B2, Group Policy Creator Owners  Security Group _ Members inthi
%Grnqﬂ Secunty Group - [ Undoek aceourit
B Group2 Security Group _
B Groupa Security Group Agoount options:
EG”""’E User [ wsar misst changs passaond &t nast kogon i
B, Guard3 User [ User cannst change passweed
B Guest User Built-in accsund ] Password never eipies
&, HarishTest User [] Store password using roversble snayplion .
E Koy Acdmires. Security Group . Members of th .
E._-krblgl. Ulser Key Distributio .M:munuw
2, MainGroup Security Group _ @ Never
S Mark Usar CIEnd of 08 Way 2022
& Markliser User
E,mamvrwswlhal Liser
& NaveenTest2 User
& protuaa User oK Cancel Apsly Help
&E,Prmwd Users Security Group . Members. of this group ar.
%PAS and 145 Servers Security Group . Servers in this group can -
!Eﬂmd-nriy Domain Controllers  Secunty Group - Membiers of this group ar
Shdnﬁn&unm.ﬂﬁ.\ad User
B cachintestgroup Security Group -

- Copy the keytab file on the machine, where Proficy Authentication is installed.
- Update the Proficy Authentication uaa.yml file (on page 62).

Proficy Authentication Service Configuration

This topic provides steps to update the Proficy Authentication uaa. ym file.

Make sure you have completed the following tasks:

+ Generate Keytab File (on page 59).
« Copy the keytab file from the Active Directory server, and paste it anywhere on the Proficy
Authentication machine.

« Make a note of the keytab file location on the Proficy Authentication machine.
You must be an administrator to perform this task.

1. Log in to the computer machine where Proficy Authentication is installed.
2. Access the uaa. ym file.
The file is located at C: \ Pr ogr anDat a\ GE\ Oper at i ons Hub\ uaa- conf i g\ uaa. yn
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3. To modify, open uaa. ym in any text editor.
Example: Notepad++
4. Search for ker ber os and enter values for the following keys:

service-principal Enter the service principal name. For more information, refer to Create

Service Principal Name (on page 56).

keytab-location Enter the location path where you copied the keytab file on this ma-
chine.
For example:
ker ber os:

servi ce-principal: HTTP/ wi n16- phant omhost . uaat est ad. ge. cOm@AATESTAD. GE. COM

keytab-1ocation: 'file:///C: /ProgranData/ GE/ Proficy Authentication/uaa-config/ nyskullcave. keyt ab’

5. Save and close the modified file.

6. Restart the GE Proficy Authentication Tontat Wb Server Service.
a. Access the Windows Run dialog.
b. Enter servi ces. msc to open the Services screen.

c. Right-click GE Proficy Authentication Tontat Wb Server and select Restart.

The Proficy Authentication service configuration is updated .
Configure Browser
Configure the browser settings for Kerberos authentication.

Windows Auto-login works if the following tasks are accomplished.

« Create Service Principal Name (on page 56)
+ Generate Keytab File (on page 59)

« Proficy Authentication Service Configuration (on page 62)

The steps describe how to configure the browser settings on Internet Explorer (IE). Since IE settings are

shared by Chrome, you do not have to configure it separately for the Chrome browser.

Important:
Windows Auto-login is not supported on the node where the Proficy Authentication service is
running. To enable auto-login, configure the browser settings on a node different from the Proficy

Authentication service node.
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1. Go to Control Panel > Internet Options
The Internet Properties dialog appears.
2. On the Security tab, select Local intranet > Sites.
The Local intranet window appears.
3. Select Advanced.
4. In Add this website to the zone, enter the URL of the Proficy Authentication service, and then select

Add.

&* Local intranet *

¥  Youcan add and remove websites from this zone. All
websites in this zone will use the zone's security settings.

Add this website to the zone:
Imps:,-'.m.fimﬁ-phantcmhnst.uaatestad.ge.corrﬂ Add

Websites:
*.ad.sys ~ Remove
* _alstom.com
* eqlals.lan
10.93.16.101
10.93.16.149 W

[] Require server verification (https:) for all sites in this zone

Close

5. Select Close.
6. Select OK to close the open windows.

Kerberos supported SPNEGO authentication is enabled on your IE browser.

For Windows Auto-login, use UseKer bAut h query parameter while accessing the Proficy Authentication

service URL. For example, ht t ps: // FQDN of the Proficy Authentication Service Node/ uaa/ ?UseKer bAut h=t r ue

Troubleshooting Error Logs

This topic describes Windows Auto-login success/failure scenarios.
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User logs in successfully

Verify the uaa. | og if the TGT/Kerberos token is generated properly. It should start with YII. You can ignore
the lengthy token value in the log entries.

[2022-02-22 19: 29: 41. 949] cl oudf oundry-identity-server - 14188 [http-ni 0-9480-exec-8] ....
DEBUG --- SpnegoAut henti cati onProcessingFilter: Received Negotiate Header for request

https://w nl6-sachi n. uaat estad. ge. comf uaa/: Negotiate Yl | HVQYGKWY****x* %%

A local Windows (non-domain) user attempts Windows Auto-login (using query
parameter in the URL) from a domain member machine

Browser displays an error. The error message also appears in uaa. | og. The following error appears when
attempting to login with domain name in the URL.
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HTTP Status 500 — Internal Server Error

T Exception Report

(=TT Serviet.init() for serviet [spring] threw exception

[T The server encountered an unexpected condition that prevented it from fulfilling the request.
Exception|

javax.servlet.ServletException: Servlet.init() for servlet [spring] threw exception
org.apache.catalina.authenticator. AuthenticatorBase. invoke(AuthenticatorBase.java:s
org.apache.catalina.valves. ErrorReportValve. invoke(ErrorfeportValve. java:92)
org.apache. catalina.valves. AbstractAccessLogvalve. invoke(Abstractaccesslogvalve. jav
org.apache.catalina.valves. RemotelpValve. invoke(RemoteIpValve. java: 769)
org.apache.catalina.valves.rewrite.RewriteValve. invoke(RewriteValve. java: 289)
org.apache.catalina.valves.RequestFiltervValve. process{RequestFilterValve.java:378)
org.apache.catalina.valves. Remotedddrvalve. invoke( Remotedddrvalve. java: 56)
org.apache.catalina. connector. Coyotehdapter . service(CoyoteAdapter. java: 357)
org.apacthe. coyote. . httpll. HttpllProcessor. service(HttpllProcessor, java: 382)
org.apache.coyote.AbstractProcessorLight . process(AbstractProcessorLight. java:65)
org.apache.coyote.AbstractProtocol$ConnectionHandler. process{AbstractProtocel. java:
org.apache.tomcat.util.net.NieEndpoint$SocketProcessor . deRun{NicEndpoint . Java:1722)
org.apache.torcat.util.net.SocketProcessorBase . run{SocketProcessorBase. java:49)
org.apache. tomcat . util. threads . ThreadPoolExecutor . runkorker ( ThreadPoolExecutor . java
org.apache.tomcat . util, threads. ThreadPoolExecutorfdorker. run{ThreadPoolExecutor, jav
org.apache.tomcat.util. threads. TaskThread$WrappingRunnable.run( TaskThread. java:61)
java.base/java.lang.Thread. run{Unknown Source)

java.lang.IllegalStateException: Listeners cannot be added to context [fuaa] as the context
org. cloudfoundry . identity.vaa. impl . config. vamlServietProfileInitializer. initialize(
org. clovdfoundry. ident ity . uaa. impl.config. YamlServietProfilelnitializer. initialize(
org. springframework .web. servlet . FraseworkServlet, applyInitializers(FrameworkServlet
org. springframework . web. servlet . FrameworkServlet . configureAndRefreshWebApplicationd
org. springframework.web.servlet.FrameworkServlet.createkebApplicationContext(Framen
org. springframework . web. servlet . FrameworkServlet. createkebapplicationContext(Framew
org. springframework web. serviet . FraseworkServliet. initWebipplicationContext (Framewor
org. springframework . web . servlet . FraseworkServlet. initServietBean{FrameworkServlet. §
org. springframewors . web. servlet  HttpServletBean. init(HttpServletBean, java: 178}
javax.servlet.GenericServlet.init(GenericServlet. java: 158)
org.apache.catalina.authenticator. AuthentlcatorBase. invoke(AvthenticatorBase. java:s
org.apache.catalina.valves.ErrorReportvalve. invoke(ErrorfeportValve. java:o2)
org.apache.catalina.valves. AbstractAccessLogValve, invoke(AbstractAccesslogValve, jay
org.apache,catalina,.valves.RemotelpValve. invoke(RemoteIpValve. java: 769}
org.apache.catalina.valves.rewrite.RewriteValve. invoke(RewriteValve. java: 289)
org.apache.catalina.valves.RequestFiltervValve. process{RequestFilterValve.java:378)
org.apache.catalina.valves. Remotedddrvalve, invoke| Remotesddryvalve. java:56)

The following error appears when attempting to login with non-domain name in the URL.
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HTTP Status 500 — Internal Server Error

[T Sendetinit() for sendet [spring] theew exeption
[T The server encountered an unexpected cordition that preverted it from fulfilling the request.
Exception

javax.servlet ServigtException: Servlet.init{} for servliet [spring] threw exception
orgapache. catal ing, suthenticator. duthent icatorBase. irvoke(AuthenticatorBase, java;548)
org.apache.catalina.valves.ErrorReportValve. invoke(ErrorReportValve . java: 52)
org. apache. catal ina, walves abstractacces slogialve. invoke{dbstractaccesiLogvalve. fava: 687)
org.apache. catalina, valves Resctelpvalve . inveke(RescotelpValve. java: 769)
org.apache. catal ina. valves.rewrite Rewritevalve. invoke{Rewritevalve . java: 289)
org.apache. catalina, valves RequestFilteryalve. precess (RequestFiltervalve, java: 378)
org.apache. catal ina. wvalves . RemoteAddrval ve . invoke | Remotedddrvalwe . java: 56
arg. apache.catalina, comnector, Eﬂ,ﬂtl‘”dﬁltﬁlﬂ service[Coyotaddapter. j-&\'a 1357)
org.apache. coyote. httpll Httpllfrocessor . service{HttpllProcessor. java:382)
arg. apache, coyate, AbsTrac EP‘I‘D{!iSﬂI‘L]‘h‘E process{Abstras EPI‘D(!SMI‘L]SHE " jan-a.-. 65
arg.apache. coyote. AbstractProtocol$Connect ionHandler . process{AbstractProtocol . javaz895)
argapache. toncat  util.net. HioEndpoint$5et ketProcessor . doRun{NioEndpadnt. java:1722)
org.apache. tomcat . util net . SocketProcessorBase . run{SocketProcessorBase. Java 149)
org. apache. tomcat.util. threads . ThreadfoolEvecutor. runkorker| ThreadPool Executor. java:1191)
org . apache. tomcat, util  threads . ThreadPoo lExecutoriborker . run| ThreadPoolExecuter . Java:659)
org.apache. tomcat . util.threads . TaikThreaddurappingAunnable. runi{ TaskThread . javaz 61)
java.base/java. lang. Thread . run{Unkrown Source)

koot Causs

java.lang.IllegalstateException: Listeners cannot be added te context [fuaa] as the context has been imitialised
org.cloud foundry. identity. uaa. impl .config. YamlServletProfilelnitializer.initialize(YanlServletProfilelnitializer. favaz B8)
org. cloudfoundry. Identity. usa. iepl . config. vanlServletProfilelnitializer. initialize(YanlServietProfilelni tial izer. fava:54)
org.springframework . web. serviet.FrameworkServlet .applylnitializers{FrameworkServiet . javaz héd)
arf . Springfrastwork  web, serviet, FrasewerkServlet, conf ijureindRefreshidebippl icationfontext{FraseworkSery et fava: 7al)
arg.springframwork . web. servlet. Framewor kServlet . createsebappl icationContext( FrameworkServilet. java t668)
arg . ipringfrasework . web, serviet. Frasewor kServlet, createlebippl icationCont et [ FrameworkServlet, Java: 716)
arg.springfrasewori . web. serviet. FramoworkServlet . indteebappl icationContext( FrameworkServlet. javazs9l)
arg . ipringfrasework  web, serviet. Frasewor kServiet, initServietBean( Frasewor kServlet, favaz530)
org . springfrasework . web. serviet HttpServletBean. inlt{HttpServietBean. java:17a)
javax . fervlet GenerlicServlet  dnit{GenericServliet. favaz158)
org.apache. catalina, authenticator. AuthenticatorBase. irvoke(AuthenticatorBase. java:548)
org.apache. catal ina. wvalves . ErrorReportialve. invoke{ErrorReportvalve . Java: 5i)
arf.apache. cataling, va Ives . AbSTractAccess L-'}s"i'll\'e-. irvoke{Abstrac tﬂt{éiil{lﬂﬂlﬂ. favaz687)
org.apache. catalina. valves . Remotelpvalve . invoke| RemotelpValwe. java: 769)
argapache. catal ina, valves . réwrite, RewriteValve. invoke|Rewr itevalve . java: 289)
org.apache. catal ina. wvalves . RequestFiltervalve. process ([ RequestFllterValve. Java:378)
arg.apache. catal ina, walves . Remoteiddrval ve . invoke| Remotedddrvalve . java: 56)
1357%

Bad or missing keytab file (or) Bad SPN in uaa. yni file

The following errors appear in uaa. | og.

[2022-02-21 19:09: 21. 839] cl oudf oundry-identity-server - 13956 [http-nio-9480-exec-8] .... ERROR ---
Dynani cKer ber osAut hent i cati onManager: Kerberos validation not successful. Encountered Bad Credentials Exception :
Kerberos validation not successful

[2022-02-21 19: 09: 21. 839] cl oudf oundry-identity-server - 13956 [http-nio-9480-exec-8] .... ERROR ---
Dynami cKer ber osAut hent i cati onManager: Kerberos validation not successful. Encountered Bad Credential s Exception :
Ker beros validation not successful

[2022-02-21 19:09: 21. 839] cl oudf oundry-identity-server - 13956 [http-nio-9480-exec-8] .... ERROR ---

Dynani cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : null
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[2022-02-21 19: 09: 21. 839] cl oudf oundry-identity-server - 13956 [http-nio-9480-exec-8] .... ERROR ---
Dynani cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : null
[ 2022-02-21 19: 09: 21. 839] cl oudf oundry-identity-server - 13956 [http-nio-9480-exec-8] .... ERROR ---
Dynami cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : Defective token detected (Mechani sm
| evel : GSSHeader did not find the right tag)
[2022-02-21 19: 09: 21. 839] cl oudf oundry-identity-server - 13956 [http-nio-9480-exec-8] .... ERROR ---
Dynani cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : Defective token detected (Mechani sm
| evel : GSSHeader did not find the right tag)
[2022- 02-21 19: 09: 21. 839] cl oudf oundry-identity-server - 13956 [http-ni o-9480-exec- 8]
WARN --- SpnegoAut henti cati onProcessingFilter: Negotiate Header was invalid: Negotiate
Tl RMTVNTUAABAAAAI 4| | 4gAAAAAAAAAAAAAAAAAAAAAKADK 4 AAAADW==
org. springframework. security. aut hentication. BadCredenti al sException: Bad Credentials excpetion. It could be due to

keytab file and the SPN configuration.

Crypto Mismatch

A crypto mismatch occurs if the encryption algorithm specified while using kt pass. exe to generate keytab
does not match what is supported by the service account.

[2022-02-22 11:39:18.326] cloudfoundry-identity-server - 6084 [http-nio-9480-exec-3] .... ERROR ---
Dynani cKer ber osAut hent i cati onManager: Kerberos validation not successful. Encountered Bad Credentials Exception :
Kerberos validation not successful

[2022-02-22 11:39:18.326] cloudfoundry-identity-server - 6084 [http-nio-9480-exec-3] .... ERROR ---
Dynami cKer ber osAut hent i cati onManager: Kerberos validation not successful. Encountered Bad Credential s Exception :
Ker beros val i dation not successful

[2022-02-22 11:39:18.326] cloudfoundry-identity-server - 6084 [http-nio-9480-exec-3] .... ERROR ---
Dynani cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : null

[ 2022-02-22 11:39:18.326] cloudfoundry-identity-server - 6084 [http-nio-9480-exec-3] .... ERROR ---
Dynamni cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : null

[2022-02-22 11:39:18.326] cloudfoundry-identity-server - 6084 [http-nio-9480-exec-3] .... ERROR ---
Dynami cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : Failure unspecified at GSS-API
| evel (Mechanismlevel: Invalid argunment (400) - Cannot find key of appropriate type to decrypt AP-REQ - RC4 with
HVAC)

[ 2022-02-22 11:39:18.326] cloudfoundry-identity-server - 6084 [http-nio-9480-exec-3] .... ERROR ---
Dynamni cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : Failure unspecified at GSS-API
| evel (Mechanismlevel: Invalid argument (400) - Cannot find key of appropriate type to decrypt AP-REQ - RC4 with

HVAC)
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[2022-02-22 11:39:18.326] cloudfoundry-identity-server - 6084 [http-nio-9480-exec-3] .... ERROR ---
Dynamni cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : Invalid argunent (400) - Cannot
find key of appropriate type to decrypt AP-REQ - RC4 with HVAC

[2022-02-22 11:39:18.326] cloudfoundry-identity-server - 6084 [http-nio-9480-exec-3] .... ERROR ---
Dynami cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : Invalid argunent (400) - Cannot

find key of appropriate type to decrypt AP-REQ - RC4 with HVAC

Clock skew between client and server

The following errors appear in uaa. | og.

[2022-02-19 13: 14:55.556] cloudfoundry-identity-server - 14532 [http-ni 0-9480-exec-9] .... ERROR ---
Dynami cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : null
[ 2022-02-19 13: 14:55.556] cl oudfoundry-identity-server - 14532 [http-ni 0-9480-exec-9] .... ERROR ---
Dynani cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : null
[ 2022- 02- 19 13: 14: 55.556] cl oudf oundry-identity-server - 14532 [http-ni 0-9480-exec-9] .... ERROR ---
Dynamni cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : Failure unspecified at GSS-API
I evel (Mechanismlevel: Cock skew too great (37))
[2022- 02- 19 13: 14: 55.556] cl oudf oundry-identity-server - 14532 [http-ni 0-9480-exec-9] .... ERROR ---
Dynani cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : Failure unspecified at GSS-API
I evel (Mechanismlevel: O ock skew too great (37))
[ 2022- 02- 19 13: 14: 55.556] cl oudf oundry-identity-server - 14532 [http-ni 0-9480-exec-9] .... ERROR ---
Dynami cKer ber osAut henti cati onManager: Root cause for Kerberos validation failure : Cock skew too great (37)
[2022-02-19 13: 14:55.556] cloudfoundry-identity-server - 14532 [http-ni0-9480-exec-9] .... ERROR ---

Dynami cKer ber osAut hent i cati onManager: Root cause for Kerberos validation failure : Cock skew too great (37)

Note:

Make sure the clocks on all the three systems are synchronized.

Useful SPN commands

To view existing SPNs | setspn -F -Q HTTP/ <FQDN>

Example: setspn -F -Q HITP/ wi n16- phant onhost . uaat est ad. ge. com@QJAATESTAD-

. GE. COM

To delete SPN setspn - D HTTP/ <FQDN> <user account >

Example: set spn - D HTTP/ wi n16- phant omhost . uaat est ad. ge. cOMAAATESTAD. GE-
. COM ghost 1
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High Availability

Configure High Availability for Proficy Authentication

This topic describes how to set up a highly available server for the Proficy Authentication service that is

based on the Windows failover cluster and iSCSI technologies.

You need:

 One Windows Server 2019 virtual machine to serve as iSCSI Target.

« Two Windows Server 2019 virtual machines to serve as iSCSI Initiators:
o A primary node (Node1) server
o A secondary node (Node2) server

The following image illustrates the simplest form of deploying the Windows failover cluster and iSCSI
technology-based high available solution for the Proficy Authentication Service.

iISCSI1
target server ) | ] ISC51
I Wirtual Disk
H
Windows Server fail-over cluster

ST TEEE s e EEEEEA e A e e Emm s mmEmEE T, i
' T T T (7T P, Frmemesmcccccccemmeaaaa-
' M, M1, .
. * 15CSI initator

. .
P '

* Postgre50L Sarver

- ] » = 3
Y/l Iy : * Proficy Authantication Service

[——] ———1 [———]

Client nodes ( Browser / Operations Hub / Config-Hub )

In failover cluster technology, a group of independent computers work together to increase the availability
and scalability of clustered roles (identified as nodes in a cluster). Nodes are clustered server machines

running applications and services.

Failover cluster feature and file server roles are installed on the Node1 and Node2 servers (also called
iSCSl initiators). A virtual disk is created on the iSCSI target server for shared storage. Failover clustering

technology arranges for a backup server whenever the primary server has failed for any reason. So, if the
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primary server Node1 is down, then the backup server Node2 is automatically activated to replace the
role of the primary server. This ensures uninterrupted access to shared storage and continuity of services
even during failure of the primary server.

1. Set up the iSCSI Target.
a. Configure iSCSI Target (on page 71)
b. Create a Virtual Disk (on page 74)
2. Set up the iSCSl initiators: Node1 and Node2.
a. Configure iSCSI Initiator (on page 72)
b. Initialize a Virtual Disk (on page 76)
3. Open Failover Cluster Manager on any of the iSCSI initiator nodes in a cluster (Node1 or Node2),
and create a cluster (on page 78).
4. Create and configure a role for the failover cluster. See Configure Role (on page 82).
5. Install Proficy Authentication on both the nodes.

See Configure Proficy Authentication Installation (on page 87).

If you are installing Operations Hub in a highly available cluster, follow the steps as described in

Prerequisites for Installing Operations Hub with External Proficy Authentication (on page 92).

6. Restart the services on both the nodes.

Configure iSCSI Target

This topic describes how to configure an iSCSI target server.

You can configure an external storage using Windows 2019.

1. Log in to the virtual machine where you want to set up the iSCSI target server.
2. Go to Start > Administrative Tools > Server Manager.

3. From the Server Manager dashboard, select Manage > Add roles and features.
4. Complete Add Roles and Features Wizard with these options:

Section What To Do
Before You Begin Skip to the next section.
Installation Type Select Role-based or feature-based installation.
Server Selection a. Choose the option Select a server from the server pool.

b. Under the server pool section, select your target server. You

will be installing the role/feature on this server.

Server Roles In the roles list box:
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Section What To Do

a. Expand File and Storage Services > File and iSCSI Services.
b. Select the check box for iSCSI Target Server.

Confirmation Select Install.

When the installation is complete, restart the machine.

Log in to the same server again and create a virtual disk (on page 74).

Configure iSCSI Initiator

This topic describes how to configure an iSCSI initiator and connect to the target server.
Configure iSCSI Target (on page 71).

You must perform these steps on all the initiator server nodes you want to add to a cluster. Let us assume
you are setting up a basic two-node cluster, where there are two iSCSI initiators:

- A primary server called Node1
« A secondary server called Node2

1. Log in to the Node1 server.
2. Go to Start > Administrative Tools > Server Manager.
3. From the Server Manager dashboard, select Manage > Add roles and features.

4. Complete Add Roles and Features Wizard with these options:

Section What To Do
Before You Begin Skip to the next section.
Installation Type Select Role-based or feature-based installation.
Server Selection a. Choose the option Select a server from the server pool.

b. Under the server pool section, select your Node1 server. You
will be installing the role/feature on this server.

Server Roles In the roles list box:
a. Expand File and Storage Services > File and iSCSI Services.
b. Select the check box for iSCSI Target Server.

Features To allow the installation of Failover Cluster Manager:
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Section

What To Do

b.

a. In the features list box, select the check box for Failover Clus-

tering.

The Add features that are required for Failover Clustering?
screen appears, which shows the dependencies that are in-

stalled with this feature.

Select Add Features.

Confirmation

Select Install.

The selected role and feature is installed on the Node1 server.

5. When the installation is complete, restart the machine.
6. Log in to the same server again and launch Server Manager.

7. From the Tools menu, select iSCSI Initiator.
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8. In the Target field, enter the iSCSI target server address.

9. Select Quick Connect.

If connected, the login success appears as shown in the following figure:

Local Secunty Pk

Wireckimar, Dirtivaten Fomall st detes
Wirckowt damany Disgronts
P ———

Wirshmar, P § s

Wiradow Fower el E



Proficy Authentication | 1 - Proficy Authentication | 74

Targens | Dacovery | Faverne Targets | Vokumes and Devices | RACIS | Configuraton |
itk Coviact

T decover and log on 1o 8 target weng & basc cornection, type e P addness or

tapet | i SN 8 | Quick Connect...
Dvscovered wrgets

e

Targets that are avallable for connecton al the [P address or DS name that yo

pronvicked are lnted below. If multile targets are avalable, you need o conrect
o each target ndrechaaly

Cormecsors made here wil be added 1o the et of Favorite Targets and an athes
fo reshore Them wll b made every bme S computes restarts,

Dascovvered targets

[ hiaeme Siabs

i 195 105 oo mecromefit e -tk | -targest

10. Select Done, then OK to exit.

11. Log in to the Node2 server and repeat steps 1-9.

Initialize a Virtual Disk (on page 76)

Create a Virtual Disk

This topic describes how to create an iSCSI virtual disk and configure the access server.

You must first configure the iSCSI target server (on page 71).

1. Log in to the iSCSI target server.

2. Go to Start > Administrative Tools > Server Manager.

3. Go to File and Storage Services > iSCSI.

4. From the TASKS drop-down menu, select New iSCSI Virtual Disk.
5. Complete New iSCSI Virtual Disk Wizard with these options:
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Section

What To Do

iSCSI Virtual Disk Loca-
tion

The iSCSI target server and volume details are displayed.

iSCSI Virtual Disk Name

Enter a name for the virtual disk. For example, shar edDi sk

iSCSI Virtual Disk Size

a. Enter the disk size. For example, 10G8. The disk size depends
on your database utilization and number of users.

b. Select Dynamically expanding.

iSCSI Target

Select New iSCSI target.

If the target is new, then it should be assigned later as described in
step 8.

Target Name and Access

Enter a name for the iSCSI target server. For example, hauaat ar get

Access Servers

Add the iSCSl initiators (Node1 and Node2) and enable them to ac-
cess the iSCSI virtual disk. Follow these steps to add the servers one
at a time:
a. Select Add. The Add initiator ID screen appears.
b. Select Enter a value for the selected type.
c. From the Type drop-down menu, choose any of the following
options to enter a value:
= If you select DNS Name, enter the DNS name of the
computer where the iSCSI initiator is installed.
= If you select IP Address, then enter the IP address of
the computer where the iSCSl initiator is installed.
= If you select Mac Address, then enter the MAC address
of the computer where the iSCSlI initiator is installed.
d. Select OK to exit.
e. To add Node2, repeat the above steps.

Enable authentication

Skip to the next section.

Confirmation

Select Create.

When the iSCSI virtual disk is created successfully, select Close to exit the wizard.

6. In Server Manager, go to File and Storage Services > iSCSI and verify the newly created virtual disk
is listed under iSCSI virtual disks.
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The virtual disk status appears as Not Connect ed. This occurs when a new iSCSI target is selected

during iSCSI virtual disk creation.

7. Right-click the Not connect ed iSCSI virtual disk and select Assign iSCSI Virtual Disk.
8. Complete Assign iSCSI Virtual Disk Wizard with these options:

Section

What To Do

iSCSI Target

Select Existing iSCSI target and select the target server to connect.

Confirmation Select Assign.

When the iSCSI virtual disk is assigned successfully, select Close to exit the wizard.

Initialize a Virtual Disk

This topic describes how to initialize a disk and create a volume.

Create a Virtual Disk (on page 74).

You need to perform the following tasks only once on any of the iSCSI initiator nodes and it applies to the

other nodes in a cluster. Suppose there are two nodes in a cluster, Node1 and Node2. If you initialize a

virtual disk on the Node1 server, then you don't need to do it again on the Node2 server.

1. Log in to any of the server nodes in a cluster (Node1 or Node2).
2. Go to Control Panel > Administrator Tools > Computer Management > Storage > Disk

Management.

3. Look for the unknown disk, right-click and select Online.

If the unknown disk is offline, you must bring it online.

= Disk 1 |

Basic Waal3CS1 (G:)

24 28 GB 2428 GB MNTFS

Onlline Healthy [Frimary Partition)

O Disk 2 |
Unkmoesn

10,00 SB

Pris pras oo,
= CD-ROM O Help
DA (D)

B uUnallocated Il Primarny partition

4. Right-click the unknown disk again and select Initialize disk.
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The Initialize Disk screen appears.
5. Select OK.

Initialize Disk >

ou must initialize a disk before Logical Disk Manager can access it.
Select disks:
! Disk 2

Use the following partition style for the selected disks:

MER (Master Boot Racord)
# GPT (GUID Partition Table)

Mote: The GPT partition style is not recognized by all previous versions of

Windows
o] oo

6. Right-click the unallocated space on the disk, and select New Simple Volume.
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M RAID- S Volume
= Diak 2 Prospartios

Bagie
998 GB od GB ————-———__.—-—-' Halp
Cialline

Unallocated

— OO O
DAAD (k)
B Unallscated [l Primary partiticn

The New Simple Volume Wizard screen appears.
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7. Complete the steps in the wizard to create a new volume.
You need to:
- Specify the size of the volume you want to create in megabytes (MB).
> Assign a drive letter to identify the partition.
o Format the volume with default settings.

The newly created volume should appear under This PC on the logged-in machine.

Create a Cluster

This topic describes how to create a failover cluster.

Install Failover Cluster Manager on the iSCSI initiator nodes. Refer to steps 1-4 in Configure iSCSI Initiator
(on page 72).

You can perform these steps on either Node1 or Node2. Suppose you perform these steps on Node1, they
are automatically applied to Node2.

1. Log in to the iSCSI initiator node.

2. Go to Start > Administrative Tools > Failover Cluster Manager.

3. In Failover Cluster Manager, select Validate a Configuration.
Before starting to create a cluster of nodes, you should validate whether the nodes that you are
adding to the cluster are compatible with the cluster hardware requirement. For more information,
refer to the Microsoft documentation.

4. Complete Validate a Configuration Wizard with these options:

Section What To Do

Before You Begin Skip to the next section.

Select Servers or a Clus- | Browse and locate the servers you want to add to the cluster. Refer to

ter Add Server Nodes for Validation (on page 79).
Testing Options Select Run all tests (recommended).
Confirmation Review the list of tests run on the selected servers. The number of

tests run are based on the roles installed on the server nodes.

Validating This process may take several minutes depending on your network
infrastructure, and the number of server nodes selected for valida-

tion.



https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2012-r2-and-2012/jj134244(v%3dws.11)
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Section What To Do

Summary a. Select View Report.

b. Review Failover Cluster Validation Report and fix any failed
validations. You can ignore expected warnings. The validation
report should be free of any errors, otherwise the cluster setup
will not be successful.

c. Select Finish.

5. In Failover Cluster Manager, select Create a Cluster.

6. Complete Create Cluster Wizard using these options:

Section What To Do
Before You Begin Skip to the next section.
Select Servers Nodes were already added during validating the configuration
process.
Validation Warning Select No.

Access Point for Adminis- | Enter a unique name for your cluster. For example, hauaacl ust er
tering the Cluster

Confirmation Clear the check box for Add all eligible storage to the cluster.

Creating New Cluster This process may take a while as there are several checks that must
be run, and tests that are conducted while the system is configured.

Summary Select Finish.

Add Server Nodes for Validation

This topic describes how to select computers during validating a cluster configuration.

In the following steps, uaAAHANODEL (Node1 server name) and UAAHANGDE2 (Node?2 server name) are used as

example server nodes in a cluster.
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1. On the Select Servers or a Cluster tab, select Browse.

B9 validate a Configuration Wizard

ﬁ Select Servers or a Cluster

To valdate & set of servers, 8dd the names of all the servers.

Totest an exdsting cluster, add the name of the cluster or one of B8 nodes.

Erter name
pelected servers: Add
« Previous Tie Cancsl
The Select Computers screen appears.
2. Select Advanced.
Select Computers x
Select thes obpect type:
Computers Object Types...
From this location:
chyster.ge.com Locations...
Enter the obct names to select (examples):
| Check Names
Advanced... oK Cancel

3. Select Find Now.




Select Computers

Select this object type:
[Computent

[From this location:

clustern ge.com

Common Qusnes

Namw

Starts with -

Deserpbon:  Stads with

L] Disabled sccounts

Mo sapaning password

Diays snce last logon:
[ Search resuls:
Marmes In Foldar
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Coject Types...

Locations...

A screen appears prompting to enter the network credentials.

4. Enter the user name and password of the domain where the cluster validation is being performed,
and select OK.

T Pt Bhphel BT
G

P g i
[T

gt Typirs.

= |

L it

Wik Seuily

Enter network credentials

Emter your credentiah lor am accoiunt with permissions. for
chuster ge.com.

For example user, useriBemmple microtoft com, or domainiueser

|

| Paswavord

ilF

Domain: CLUSTER

oK

L]

After successful login, you can see the associated nodes.

5. Select uaAHANCDEL and UAAHANODE2, and select OK.
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6. Select OK to exit.

S Yy i
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Configure Role

This topic describes how to configure a highly available virtual machine.
In failover cluster technology, each highly available virtual machine is considered to be a role.

You can perform the following steps on either Node1 or Node2. Suppose you perform these steps on

Node1, they are automatically applied to Node2.

1. Log in to any of the iSCSI initiator nodes.

2. Go to Start > Administrative Tools > Failover Cluster Manager.

3. In Failover Cluster Manager, expand your cluster name and go to Storage > Disks.
The cluster name is the unique name entered when creating your cluster. Refer to step 6 in Create a
Cluster (on page 78).

4. Right-click Disks and select Add Disk.
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The Add Disks to a Cluster screen appears.
5. Select the disk you want to add, and select OK.
6. In Failover Cluster Manager, expand your cluster name and select Roles.
7. Right-click Roles and select Create Empty Role.
The newly created role appears in the Roles pane with the name New Rol e.
8. Right-click New Rol e and select Properties.
The New Role Properties screen appears.
9. Enter a name for the new role, and select Apply.
You can assign the role to multiple node servers and set an order of preference.
For example, the new name is Demo Rol e.

Mew Role Properties x

General Failover

Mew Role
MName:
Demo Role|

Prefemed Cwners

Select the preferred owners for this clustered role. Use the buttons
to list them in order from most preferred at the top to least preferred
at the bottom

] vashanode1
[] uaahanode2

Priorty Medum
Status: Running
Node: uaahanode 1

10. Right-click Deno Rol e and select Add Storage.

The Add Storage screen appears.
11. Select the storage that is already associated to the cluster, and select OK.
12. Right-click beno Rol e and select Add Resource > Client Access Point.
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13. Complete New Resource Wizard with the following options.

Section

What To Do

Client Access Point

Enter a name. For example, hauaacl ust er

Make a note of this name. You need to provide the fully qualified do-
main name while installing Proficy Authentication. See step 3ain
Configure Proficy Authentication Installation (on page 87). For ex-
ample, hauaacl ust er. cl ust er. ge. comwherein cl ust er. ge. comis the
domain where cluster is installed. Make sure all the initiator nodes

are in the same domain name.

Confirmation

The network name and IP address are displayed for confirmation.

L ™
Note:
After creating this resource, the IP address and the name

should be added to the host s file on the node servers config-

ured for high availability.
. J

Configure Client Access
Point

Verifies the validity of the client access point settings and creates a
new resource.

Summary

Select Finish.

On the node servers configured for high availability, go to . . \ W ndows\ Syst enB2\ Dri ver s\ et c\ host s
and open the file in a text editor to add the network IP address and name as follows.
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<i paddr ess> hauaacl ust er. cl uster. ge. com

<i paddr ess> hauaacl ust er

In the above example, <i paddr ess> should be replaced with the actual ip address of your machine.

14. Right-click beno Rol e and select Add Resource > Generic Service.
15. Complete New Resource Wizard with the following options:

Section What To Do
Select Service In the services list, select GE Proficy Authentication Tontat Wb
Servi ce.
Confirmation Skip to the next section.

Configure Generic Service | Skip to the next section.

Summary Select Finish.

16. Add the dependency service to role using properties of the added service, so that services restart

when switching the node (failover condition).
a. In Failover Cluster Manager, select the added service.

b. Select Properties.

Wanager Acticrn
A . Chueries w (| = | o | Rotes -

e S Type Crares Niovde Ercery Foaton e

. ) Furnng Ot ot arde Blochurr

B e

| G Proicy Authantoaton Posigresn.

The properties screen for that service appears.

c. Select the Dependencies tab, and select Insert.
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GE Proficy Authentication PostgreSQL Database Properties X
Advanced Policies Registry Replication
General Dependencies | Polices

Specify the resources that must be brought online before this resource can
be brought online:
ANDIOR Resource

e |Click here to add a dependency

No dependencies.

OK Cancal Apply

A row is added to specify our required dependencies.

d. From the drop-down, select the required resource one by one to be added as part of
dependencies.
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GE Proficy Authentication PostgreSQL Database Properties >
Advanced Policies Registry Replcation
General Dependencies Palicies
Speciy the resources that must be brought online before this resource can
be brought online:
ANDIOR Resource
| Cluster Disk 1
AMND IP Address: 10.181.251.217
» AND | Name: hauaacluster -

¢ |Click here to add a dependency

Inset || Delete

Cluster Disk 1 AND IP Address: 10.181.251.217 AND Name:

hauaacluster
OK \ Cancal Apply

e. After inserting the resource, select Apply and then OK.

Configure Proficy Authentication Installation

This topic describes Proficy Authentication installation setup in a high available environment.

For fresh installation, you can straightaway proceed with the procedural steps in this topic. But, if you
want to use an existing database, do the following before you start with the procedural steps:
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1. Copy your Proficy Authentication existing database (found in the Postgress database location)
from wherever installed to the shared drive created using the iSCSI server. When you copy, make
sure the cluster is pointing to the drive before copying the database. For example, if the cluster is
pointing to Node1, then copy the database to NodeT1.

2. Make a note of the location path where you copied the database in the iSCSI server. For example,
F: \ UaaConf . You need to provide this path for installing Proficy Authentication on Node1 and Node2

machines.

To install Proficy Authentication on the iSCSI initiators (Node1 and Node2), make sure the shared drive in
available on the node where you want to run the installation.

1. Log in to the iSCSI initiator Node1 server.
2. Open Failover Cluster Manager and verify that the cluster role is associated to the node where you

want to install Proficy Authentication.

Roles (1)

Hame Status Type DVLEer_No_:FE Priorty Information

7 Demo Role () Running Other (" uaahanode | \> Medium

~ -

hd L} Demo Role Prefemed Cramer

Name Status Information

Storage

# 4 Cluster Disk 1 #) Onine

If not, then follow these steps to associate the node server:

a. Right-click your cluster role and select Select Node.
The Move Clustered Role screen appears.

b. Select the Node1 server, and select OK.
Once the cluster is mapped to Node1, the shared drive is available on Node1.

3. Run Proficy Authentication installation setup, and provide these details for the respective screens:
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a. In All Host Names field, enter hauaac! ust er. cl ust er . ge. comas the leading hostname,

followed by any other hostname/s.

@ Proficy Authentication 2022

Host Names

To allow secure access to the hosted web applications, please prowi
host names [fully qualified domain names and others) of this server,
separated by comma.

All Host Mames: hauaaclusterchestern fe.comg Bl 3 localhost, 12 7£.000. 1 ophub-host

P irr'lary Hast Name: hataac |u5.1‘11-|'.|:h|5.EM.g_{l.Em'n

Motas:
Thee pramasny bost namie must be
IP addresses may be entered i p ant us ¥ cess web applications by IP sdo

- Ervircenmienit

Cancel

b. This step applies for associating existing database. Enter the iSCSI server shared drive
location path where you copied the Proficy Authentication database. Refer to the steps at
the beginning of this topic (on page 87).

For example, F: \ UaaConf

@ Proficy Authentication 2022
Customize Log Files and Postgres Data Locations

Log Files Base Folder: %ProgramData%\ProfcyAuthenticationLogs
Proficy Authentication Database Folder: | IEIREETET

Mote: leave database folder entries blank if no customization is needed.

Cancel Prensous
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4. Log in to the iSCSI initiator Node2 server, and repeat the above steps to install Proficy
Authentication on Node2.
5. After installing Proficy Authentication on both the nodes, copy the DATABASE_PASSWORD registry key
from the last installed node to overwrite the registry key in the first installed node.
For example, in the following scenario:
a. First Proficy Authentication is installed successfully on the Node1 machine.
b. Next Proficy Authentication is installed successfully on the Node2 machine.
Node2 is considered as the latest installation. Node1 is considered as the first installation. So,
copy the Node2 registry key and overwrite the Node1 registry key.

=
Corngaatas’ HIEY LOCAL MACHINESOF TWARE(WOWS 12 Nedei Apadhe Soltmans Foundation) Procnen 205U Tosrmaat Pl et
D # || Hame Type beE ]
Chparii S el REG ST v oD
L A ] s el REG WAULTI 52 LCRGAR RGPS LRL =T B DN felasiars ricpared o
pgpAdimin 4
ol
Chatys Eefln B Saveeay .o
Lo BT BV T
Sptup Va3 T
Vidware. In Ereoramant;
L WG N ) Natas claa
¥ I Apsche Soltwire Foundation LM CUOMF LR WV IF it T uiton]_Coy e
» | Peocns 20 LU DOMFIG_FILE =C ProgramalandE Frodoy Aullrbebon
w | saTomcat o
v Paamaben silicelasin
Wed
Log
St
Shogp
[ ToTY
et £ »
CrerweSasio
o Co] om
rlel
Miicrouait
BwgrterndApplcations
TNLA
SWRTEM
HIEY LSERS
HKEY CLERENT_ CONFI L
« *

6. Copy and replace the uaA yani file from Node 2 (latest installation) to Node 1 (first installation).

The file is located here C:\ Pr ogr anDat a\ GE\ Prof i cy Aut henti cati on\ uaa-confi g

ITER -

“ e e -

=

ChProgramDetsy GE Profscy Austhesiticationusa -conliy

o Chuisck sooess

B Desitop - i
4 Downloads L ]
| usayrrl
¥ Doaments *
uMl,u'JIﬂu'p'.n"a-

- Pictures -

Legs

rraracubee dEtup uad

Pregdhustinle
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7. Copy server.crt and server. key from Node 2 (latest installation) to Node 1 (first installation).
The certificates are located here: C:\ Program Fi | es\ GE\ Prof i cy Aut henti cati on\ htt pd\conf\cert

« L — n] w0
_ Home Shaee Vi ﬁ
= - f Of » Proficy Aathentication » Bitpd » cond 3 ol w il 3 1 »

s
#r (pack socess:
B Deiktop - l bocelouton )
3o . escalent kiry ik
& servencrl TA-06-202F 1053 Security Certificate ]
* Documents o server key 24-06-2022 1859 KEY Fle 4 KB
= Pichaes L

il

8. After copying the certificates (to Node1), rename server. crt t0 server. pem

9. Open ﬁ Certificate Management Tool on Node1 from the desktop shortcut, and import the
certificates as follows:

a. For Certificate File, select the server. pemfile created in the earlier step.
b. For Key File, select the server . key file.
c. Select Import.
oy GE Operations Hub Certificate Management Tocl = o
Server Catficate Edemal Tnst  Messages

On this page. you can view and update the cediicate chain used by the main web server
You can use 3 localy generated server cerificate. of impon one issued by & thind pary

Lozal Contificats

hew Rerew
Inpaorted Certfcate

View Remove

Certficate 1o Impost

Centficate Fle: | C!\Lisers\Administrator Desktop senver pem

Select Vhew
Haey Fibe |E\Uners’ Administrator Desktop server key Select Clear

Password: | | foriy for PFX/P12 Fie)

You can mport a cenificate (chain) fle in ether PEM format or PFXUP12 format . Fthe contificats file
doas ot contan the prvate ey, then you must provide a standalons key fle in PEM format.

() Use Local Certficate (@) Use mported Certficate Aoply

Close
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Prerequisites for Installing Operations Hub with External Proficy
Authentication

This topic describes how to install Operations Hub with external Proficy Authentication in a high available

environment.

Set up a high available environment. See Configure High Availability for Proficy Authentication (on page
70).

These steps apply for installing Operations Hub with external Proficy Authentication. The steps include
mandatory changes prior to installing Operations Hub on any highly available server.

1. Log in to the node server where you want to install Operations Hub.
2. Open a browser and enter htt ps: // hauaacl ust er. cl ust er. ge. com / securi t yadni ni strati onapp/

3. Select the lock icon next to the web address, and then select Connection is secure.

] }aumchﬁtw.(hlsler ge.com/securityadministrationap

hauaacluster.cluster.ge.com ®
#  Connection is secure *
& Conkies TR A
£ Site settings A

4. Select Certificate is valid.

#  hauaacster.duster.ge.com/securityadministrationapp/#;

@ Security x

& Connection is secure

b

B Certificate s valid

The issued certificate appears.
5. Select Certificate Path > View Certificate.



Gereral Details

Certification Path

Certification path

| UAAHANODE? Root CA 202206062043

Lol vashenoda?

Certificate stabus:
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View Certificate

is certificabe is Ok,

6. Select Details > Copy to File.
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Gereral | Details | Certificaticn Path
Show: | <Al > v
| =jeld valLe
[Cversion W3
[J5er &l <wimber e e FafeBT0e
[Dsignatre aljoritbm  sha2SERSA,
[ISignatre hash alg... sha2se
[Clssuer GE Customer, Cper.,
[ valid from 05 Jure 2022 05:30...
[Hvalid to 05 Jume 2027 05230,
[subject CE Customer, Oper.,
[Py il ke RSA (4719 Fitsi
Edlit Propartes Copv to Fila, .
K

The Certificate Export Wizard appears.
7. Select Next.
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£+ Certificate Export Wizard

Welcome to the Certificate Export Wizard

This wizard Felps wou copy certificates, certificate trust lists and certificate revacation
lists from a certificate store to your disk.

A cortificate, which i isoued by 8 certification authority, is 8 corfirmation of your idenkity
ad contairs information usad bo protect data or bo establish seaure nebwork corrections.
A certificate store ks the system area where certificates are kept.

To conbinue, click Mest.

“Nea ]| cance

8. Select Base-64 encoded X.509 (.CER), and select Next.

€ &* Certificate Export Wizard

Expart File Format
Certificates can be exported ina variety of file formats.

Sarbict B farmat you wearit o us:
(IDER erooded binary X509 [ CER)
(W) Barga-6d ereociiad X500 { CER)
() Cryptograpie: Message Synibas Standard - PKCS #7 Certificates ( P7B)

Irichude sl cortificates in it

& cortilicator oot IF oot
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9. Browse and specify the file location, and select Next.

£* Certificate Export Wizard

File to Enport
Specify the name of the file you want bo export

£il :
C:\sers\AciministrstorDownloackias_certificate cer

et Cancel

10. Select Finish.

=* Certificate Export Wizard

Completing the Certificate Export Wizard

o have successfully completed the Certificate Export wizand,

Youd have gpecified the Following settings:

Filie Msrne C:lsers)\ Administrator\Downloads)|_lsa_d
Expoort Kieys oy

Inchude all certificates in the certificabion path Mo

Flle Format Buarsedd Encodied X509 (* cer)

[ ]| o
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11. Rename Uaa_certificate.crt to Uaa_certificate. pem
12. Run Operations Hub installation setup, and provide these details for external Proficy Authentication

fields:
Proficy Authentication Base URL https://hauaacl uster.cl uster.ge. conf uaa
Admin Client ID adni n
Admin Client Secret Gei @21litc

@ GE Operations Hub 2022.4.1

Proficy Authentication Service

Configure a built-in or external Proficy Authentication instance
Use External Proficy Authentication:

Proficy Authentscation Base URL:

Admin Clsendt 1D:

Admin Chent Secret:

above.
the inpuls befo

Cancel Prevsous MNext

Operations Hub is installed successfully.

Customize Login Screen

This topic describes how to customize the Proficy Authentication login screen.

You can customize the company name, logo, favicon, and include additional text/links to appear on the

login screen.

1. Log in to Configuration Hub.
2. Go to Proficy Authentication > White Labelling.
The default login screen details appear.
3. Use the following fields to customize your login screen.

A quick preview appears on the DETAILS tab.
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Field Description
Company Name Name of the company that appears on the login homepage.
Company Logo Select an image from your local system to upload as company logo.

Select ™ to remove an existing image.

Square Logo Select an image from your local system to upload as a favicon,

which appears on the browser tab.

Select “* to remove an existing image.

Footer Legal Text Use this space to enter any legal information.

Footer Links To add hyperlinks, create a label and provide a URL to connect.
a. Select 1 to add a row.

b. Enter a label name.

c. Enter a URL for the label name.

Select TEI— to delete existing labels.

4. Select Save to save the updates you made to the login screen appearance.
To undo the saved changes, select Reset. The login screen is reset to the previously saved

appearance.

SGHH

Foatar Links

5. Restart GE Proficy Authentication Toncat Wb Server to apply the changes.
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