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Chapter 1. Alarm Configuration

About Alarms

CIMPLICITY software generates alarmsfor:

 Alarm messages about system events, such as device failures, program terminations, system
startups, and system shutdowns. Y ou create and modify system event alarmsin the Alarm
Definition dialog box through the Alarms folder.

* Pointsthat are in an alarm state. Y ou create point alarms in the Point Properties dialog box. Y ou
can modify them in the Point Properties dialog box or through the Alarms folder.

|5/ Note: CIMPLICITY comes with several configured Event alarms.

CIMPLICITY aarm features in the Workbench |eft-pane include the following:

e o M
¥4 ProfCIMp.gef - CIMPLICITY Workbench (=6 ]
File Edt Computer Project Wiew Took Help
s s PGS IR EELE 8@ [HMi}
¥ E::Jett * | Alsrm ID ClassID *
+ SCrEETiL | -
:,.;J o‘;pm 8 HEATSystem. WEST.SECTIONID_Station18_Machi... BASIC
' Clagzes ﬂ HEATUI HERT
g - Points 1 LeveLTERST TANEL
o 8 LeveLTioRTH TANEL
- =| | 8 LeveLTsouTH TAMEL i
* E Alarm Setups 2 LEvELTWEST TANEL ,"f
Alarm Classes 8 LEVEL_Reservoir_EASTTS_Region1 725_29665 TANEL &
Alarrn Strings LEVEL_Reservor_NORTH_SECTION1A Stationl5... TAMKL
Alarm Printer 18 LEVEL_Reservor_SOUTHED_Region] 710_254875 TANEL
b plarm OPC Client 8 LEVEL_Reservoir_WESTTO_Reqgion]720_25830 TAMEL
& Alarm Blocking g:ﬁ;?oﬂ?cmw ::;H
+ t' Alarmm Translator H PacEan] MED
gaied 18 packan MED
.. m"og n{:TﬂllTﬁl\umU BASET
Advanced sl |2 m L4
Ready Stop

Other features of alarming include:

Feature Description
Alarm classes (page 7) Group alarms with similar characteristics.
Alarm strings (page 40) Name alarm states.
Alarm printer (page 51) Print alarms and/or events as they occur.
Alarm OPC client (page 159) Send and receive data through an Alarm and Event OPC server.
Alarm blocking (page 19) Configure a hierarchy of alarms to receive the most important alarms first.
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Feature

Description

Alarm translator (page 62)

Offer language and text string options for configuration.

CIMPLICITY Event Alarms

A set of CIMPLICITY event dlarmsisincluded in your base configuration. These alarms are not
associated with any single CIMPLICITY point ID during configuration. CIMPLICITY event alarms
may be modified, but they should never be deleted. They are:

CIMPLICITY Event Alarms

Function During Runtime

$ACAL_ADD_OV

Event added alarm generated by the Action Calendar.

$ACAL_CFG_ERROR

Configuration error alarm generated by the Action Calendar.

$ACAL_DAYTYPE_OV

Day type override alarm generated by the Action Calendar.

$ACAL_EVENT

Setpoint event occurred successfully generated by the Action
Calendar.

$ACAL_TIME_OV

Event time override alarm generated by the Action Calendar.

$ALARM_DISABLED

Alarm is disabled for the specified point.

$ALARM_ENABLED

Alarm is enabled for the specified point

$ALARM_MODIFIED

Alarm limits are modified for the specified point.

$ALARM_RAWLIM

Range limits exceeded for the specified point.

$ALARM_RESTORED

Alarm limits restored for the specified point.

$AM_STATUS

Alarm Management status message used to analyze system
performance. This message is issued every half-hour and shows the
number of alarms generated, the count of alarms acknowledged, reset
and deleted, and the average number of seconds required to log an
alarm.

[ Note: Alarms generated is also incremented when an alarm is
reset. In the case of reset, the message must be re-sent to clients to
change state. Alarms Deleted is only incremented when a manual
delete is performed.

$DEVICE

Indicates if the device is up (able to communicate) or down. When the
device is up Normal displays. When the device is down is in Alarm
State. Configure a separate resource for each device. This helps
separate the alarms, which would get stacked with the same resource.

$DEVICE_DOWN

Device failure message for specified device.

$DEVICE_FAILOVER

Reserved for future use.

$DL_FILE_FULL

Log file full message for specified log file.
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CIMPLICITY Event Alarms

Function During Runtime

$DOWNLOAD

Setpoint was downloaded to specified device.

$DYN_CFG

The specified entity has been changed dynamically.

$EM_OUTOF_MEMORY

An out of string space error has occurred.

$HIST_COLLECTOR

Indicates that the Historian Collector has stopped collecting data.

$HIST_SERVER

Indicates that CIMPLICITY cannot connect to the Historian server.

$LOGIN_FAILURE

Specified user failed to log in to the specified CIMPLICITY project.

$LOGON

Specified user has logged in to a specified CIMPLICITY project.

$LOGOUT

Specified user has logged out from a specified CIMPLICITY project.

$OPC_MODEL_EVENT

Generates alarms from OPC events.

|5 Note: Alarms that are logged to the event log are treated as OPC
A&E events by the OPC server. OPC events received by the OPC
client are logged to the event log by default.

$REDUND_DEV_DOWN

Alarm message for PLC redundancy.

$RTR_LINK_DOWN

Router link has been lost to specified node.

AMSI_ALARM

AMSI_ALARM is generated when a XASMGR (External Alarm State
Manager) stops unexpectedly; the alarm is cleared when XASMGR
restarts.

DB_CONN_DOWN

Process has lost connection to specified logging database.

DB_START_FORWARD

Process is forwarding data to specified logging database.

MCP_PROC_DOWN

Specified CIMPLICITY process has terminated unexpectedly.

Event Alarm Configuration

Event Alarm Configuration

In most cases you will create and configure alarms through the Point Propertiesdialog box or through
scripting. CIMPLICITY places the alarmsin the Alarms folder, where you can conveniently modify

them.

It is recommended that you do not create event alarms. In almost all cases, CIMPLICITY creates and

configures these alarms for you.

These steps are available if there is some reason that you must create or configure an event alarm.



Alarms and Messages | 1 - Alarm Configuration | 10

2]
—
@
©
[N

Open an Alarm Definition dialog box.

°Z

Configure an event alarm.

Configure alarm routing.

=0

o

lﬁm@
[{@]
LS

Configure alarm options.

)
o 3
® |in

Set global alarm settings.

=
]
-

Sep 1. Open an Alarm Definition Dialog Box

Step 1. Open an Alarm Definition Dialog Box

Option Create a new event alarm.
.1 (page
0

;

Option Open an existing Alarm Definition dialog box.

1.2 (page
11)

Option 1.1. Create anew Event Alarm

CIMPLICITY provides several methods to open a new Alarm Definition dialog box.

1. Select Project>Alarmsin the Workbench left pane.

2. Do one of the following.
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[ T PROSCIMP - CIMPLICITY Workbench Lo | =) ]
Fie | Edt Computer Project View Tock Help
P32/ 83 i
2 Prapedt Alasn 1D Class Il = 5w
Sy Soreens ¥
ﬂl-lEAT.FA.CTDRYCIl.W... HEAT -
T Objects =
[ 8 HEAT FRCTORYOZ MA... HEAT r
i Classes a8
2 88 Foints {8 HEAT SOUTH.Region.... HEAT
1 8 HEAT SOUTHRegion.... HEAT
v [ Script Engine BN HEAT. SOUTH.Region. ..
Equipment: [
] SecuEky e
| Satus Log L]
| Advanced fiH X
Managed Files LG @
& Database Lagger 18 HEST=sbem. WEST.5... =
«F PC @ Heatur HEAT o
5 Recipes 8 LEVELTEAST Tawy
[ Dacument Delvery 8 LEvELTHORTH TANKL 5
. m":“w” 8 LEVELTSOUTH TRNEL
i ¢ 8 LeveLTwesT TAMEL = en
+) Runtimne - = =
Ready
A Click File>New>Object on the Workbench menu bar.
B Click the New Object button on the Workbench toolbar.
C In the Workbench left pane:
Either Or
Double click Alarms. a. Right-click Alarms.
b. Select New on the Popup menu.
D In the Workbench right pane:
a. Right-click any alarm.
b. Select New on the Popup menu.
E Press Ctrl+N on the keyboard.

The New Alarm dialog box opens when you use any method.

3. Enter the name of the new event dlarm in the Alarm ID field.
NewAlarm x|

Blarmn |D: IEVENT.&LAF!M oK I
Cancel |

4. Click OK.

The system verifies that the Alarm ID does not aready exist, and that no invalid characters have been
used.

If the Alarm ID you entered is valid, the Alarm Definition dialog box for the new alarm opens.

Option 1.2. Open an existing Alarm Definition Dialog Box
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CIMPLICITY provides several methods to open an existing Alarm Definition dialog box.

1. Select Project>Alarmsin the Workbench left pane.
2. Select an alarm in the Workbench right pane.

3. Do one of the following.

T FROFCIMP - CIMPLICITY Workbench ==
] 5&5&; Computer  Froject  View Took Help
o™ &5
Froject [ s 1o Classil vl
| %x“: 8 HEAT FACTORYOLW... HEAT
=i Cla:c {8 HEAT FACTORYOZMA... HEAT -
| 5 8
= boies 8 HEAT S0UTHRegion.... HEAT
G m & HEAT 50UTH.Region.... HEAT
‘h: Recipe:s @ eveLTERST TargL Y
1 Dacument Delvery 48 LEVELTHORTH T
Action Calendar & eveLTsouTH THMKL .
i :i:";" |ﬂLE'¢'ELTW'E5T TANGL S
ks m ] ==
Ready
A Click Edit>Properties on the Workbench menu bar.
B Click the Properties button on the Workbench toolbar.
C In the Workbench left pane:
a. Right-click Alarms.
b. Select Properties on the Popup menu.
D In the Workbench right pane:
Either Or
Double click an alarm. a. Right-click an alarm.
b. Select Properties on the Popup menu.
E Press Alt+Enter on the keyboard.

The selected alarm's Alarm Definition dialog box opens when you use any method.

Sep 2. Configure an Event Alarm




Alarms and Messages | 1 - Alarm Configuration | 13

x
Alam Defirition | Alaim Fiouting | Alam Dptions |
Diescription: |Use| created ewvent alamm
Memclss:  [HGH @) |
Alarm type: DB_LOGGING -

Help file: Severty: |75 =

Alamm message: |Luggnu 15 downl

Alaim Lopging
W Generate [T Delete Mo siacked Iw
¥ &cknowledge [~ Reset

ok | Cancel |  Appy Help

rect 13, 45, 385, 78 (page 13)
rect 171, 182, 322, 215 (page 14)
rect 16, 176, 167, 231 (page 14)
rect 9, 77, 245, 107 (page 13)
rect 12, 104, 247, 124 (page 13)
rect 12, 123, 209, 150 (page 13)
rect 208, 122, 343, 151 (page 14)
rect 11, 149, 383, 176 (page 14)

Fill inthefields asfollows.

Field Description
Description Describes the alarm so a user can identify it more
easily. Can display in the Workbench and the Alarm
Viewer.
Alarm Class (page 27) Selection groups this alarm with alarms that have

similar characteristics.

Alarm type Identifies the application with which the alarm is
associated.
Help file A text help file that users can display when they click

the Help button in the Alarm Viewer.
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Field

Description

Severity

A number from 1 through 1000. The higher the number
the more severe the alarm is considered. CIMPLICITY
treats more severe alarms with a higher priority.

|5/ Note: The Severity for the Alarm String Index
must conform to the OPC UA specification guidelines.
If you are using Operations Hub with CIMPLICITY,

be sure to read the "Alarm Microservice" topic or
search for "alarm severity" in the Operations Hub
documentation. It's important to configure this severity
correctly so that you get the results that you want to
see in Operations Hub. For example, events of high
urgency can be mapped into the OPC severity range of
667-1000, events of medium urgency can be mapped
into the OPC severity range of 334 to 666, and events
of low urgency can be mapped into the OPC severity of
1 to 333.

Alarm message

Message that displays in the Alarm Viewer when the
alarm displays.

Alarm Logging

Check if and when you want an event alarm to
be logged in the Alarm Logging box on the Alarm
Definition tab. You can select any or all of the options:

» Generate

» Acknowledge
 Delete

» Reset

When the configuration is applied, CIMPLICITY will
add the point to its default EVENT_LOG.

Maximum stacked

Enter a number between 0 and 20.

'= Note: Maximum stacked treats event alarms the
same way as it does point alarms.

|=/ Note: Many fields on the Alarm tab in the Alarm Definition dialog box is the same as the
Advanced Alarm tab in the Point Properties dialog box.

Sep 3. Configure Alarm Routing

Alarm Routing lets you select the roles that can view any alarms generated for the selected event

alarm.

Configuration for Alarm Routing , which is done on the Alarm Routing tab in the Alarm Definition
dialog box, is the same for event alarms and as alarm routing configuration for point alarms.




Zdsrn Defrdon  Akam Routing | Alowss Ophiony
Ayailable Configured roles for alam

DPER Add > | SYSMGR
<-Remove |
Fropesties |
New |

Sep 4. Configure Alarm Options
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Configuration for the features included on the Alarm Optionstab in the Alarm Definition dialog
box is the same for both event alarms and point alarms.

Change approval provides the functionality to maintain an audit trail of user performed alarm

operations.

| Point Properties - Logonly1Testing

Alam state: | HiHi Use the same settings for al
Deletion requirements [ Manual reset allowed
Acknowledge ] Mamm on delay
Reset [] Alam off delay

Automatic actions

Printer repeat: <Mone>
Auto acknowledge: | <Mone>

Auto reset: cNones

General Vitual View  Limits Conversion Alam  Alarm Routing  Alam Options

| alarm states

Alarm Logging
[ Generate

[] Acknowledge
[]Reset
JDelete

Change Approval

() Perform

() Perform and Verify
{®) Log oy

() None

[] Unsigned Actions

Cancel Apply

Help

|5/ Note: CIMPLICITY v9.0 clients will not support acknowledging or resetting alarms from
aCIMPLICITY v6.1 or earlier server. (CIMPLICITY v6.1 and earlier versions are no longer

supported.)
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Sep 5. Set Global Alarm Settings

Y ou can choose to store runtime alarm comments that a user enters while the alarm is being
displayed in the Alarm Viewer. Normally, these comments are deleted when the alarm is del eted.
CIMPLICITY savesthe 20 most recent alarm comments in afilein the project'salarm_help
directory.

* Guidelines for storing alarm comments
* Set global alarm settings

Guidelines for storing alarm comments

« Each comment can contain up to 720 characters.
+ Up to 20 comments are stored in an alarm comment file. When the 21% comment is placed in
thefile, the first (oldest) comment is removed.

« If you intend to enable the Stor e alarm comments option, make sure that the al ar m_hel p
directory iswritable.

« If you want a comment to be associated permanently with an alarm, put it in the alarm's help
file

Set Global Alarm Settings

1. Select Project > Properties on the Workbench menu bar.
The Project Properties dialog box opens.

2. Select the Settings tab.
3. Select Alarms.

4. Click Settings.



Project Properties

General | Options Setlings I Change Management | Hiztonan

= Settings

D atabase Logger
Ewvent Editar
Measurement Urnits
Fairts

Users
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The Alarm Properties dialog box opens.

Options are asfollows.

Alarm Properties

¥ Store alaim comments

¥ Filter &4E OPC alarms by user

X|
_ Coreel_|

Cancel

Urfilterable severty: |50 =

Checkbox Description

Store alarm Check | Save up to 20 alarm comments beyond the life of alarms.

comments
Clear | Alarms comments are deleted when the alarm is deleted.

Filter A&E Check | Filter alarms and events that go to the Alarm & Event OPC server. The filter is

OPC alarms determined by the resources that are allotted to the Alarm & Event OPC server user.

by user Note: The user is specified in the Alarm & Event OPC server's Project Properties (page

163) dialog box.

Clear [ All alarms and events go to the Alarm & Event OPC server.

Unfilterable An alarm that has a severity (page 44) that is equal to or greater than the entered value

severity cannot be filtered out. Even if the value dips below the alarm severity threshold, the alarm will
continue to display in the Alarm Viewer until it is deleted. Once deleted, the cycle will begin again.
If the value again goes into an alarm state that is equal to or greater than the entered severity the
alarm will display until it is deleted.

5. Click OK.

|5/ Note: Click Cancel to cancel the changes.

Up to 20 alarm comments are stored in afile in the project's al ar m hel p directory.
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|=/ Note: Configuration update will overwrite read-only files.



Chapter 2. Alarm Blocking Configuration

About Alarm Blocking

» Overview

» Assign alarms

* Choose blocking modes

» Assign alarm priorities
 Alarm blocking guidelines

Overview

Monitoring and control systems do an excellent job of informing operators of problem conditions
through alarms. However, there are times when operators can be overwhelmed by numerous alarms
that are the result of one major problem. For example, when a process conveyor stops, it affects all
machines feeding into it. The operator needs to know that the major problem is the stopped conveyor
and not waste valuable time looking through all the other resulting alarms. Alarm Blocking lets you
configure a hierarchy of alarmsfor your process so users see the important alarms first.

Alarm Blocking lets you:

* Logically group alarmsinto blocking groups.
+ Select aruntime blocking mode for each blocking group.
» Assign apriority level to each alarm in a blocking group.

Each Alarm Blocking group works independently. This means that the high priority alarmsin one
group do not block the high priority alarmsin another group.

Before you implement Alarm Blocking, you need to plan how you want to group and prioritize your
alarms for your project. Y ou need to decide:

* The number of blocking groups you need.

» Which alarms are to be assigned to each blocking group.

» How the alarms are to be prioritized in each blocking group.

» How to handle the display of equal priority alarmsin each blocking group.

Alarms that you do not assign to Alarm Blocking groups are not affected by Alarm Blocking.
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Assign alarms

CIMPLICITY software generates two types of alarms; point alarms and system alarms. Each point
alarmisuniquely identified by its Alarm ID. Each system alarm is uniquely identified by its Alarm
ID and Resource ID.

For example:

* For point XY Z, theunique Alaam ID is XY Z.
« Each unique instance of the SALARM_MODIFIED system darm isidentified by the Alarm ID
and the Resource ID of the affected device.

|=! Note: A possible exception is for $DEVICE_DOWN. Y ou can use the Global parameter
DEVICE_DOWN_DEVICE_REF to put only the Device ID as the alarm reference.

For Alarm Blocking, you can assign auniquely identified alarm to only one group. This means:

* You can assign a point alarm to only one blocking group.
* You can assign auniquely identified system alarm to only one blocking group.

This means that you can have more than one instance of a system alarm in a blocking group or you
may have system alarms in more than one blocking group, provided that the Resource ID you assign
to each instance is unique across all Alarm Blocking groups.

Choose blocking modes

Y ou can select (page 23) one of two blocking modes for each Alarm Blocking group that you
Create.

* Peer Blocking mode: Only thefirst alarm in a set of alarms with equal priority displays.

» Non-Peer Blocking mode: All alarmsin a set of alarms with equal priority display.

Assign alarm priorities

Y ou need to assign each alarm in an Alarm Blocking group a number from 0 to 32767. The higher
the number you enter, the higher the priority of the alarm. For example, alarm XXX with priority 100
blocksalarm YY'Y with priority 10. You can assign the same priority number to more than one alarm
in an Alarm Blocking group. The priority of an alarm and the blocking mode of the group determine
whether the alarm is blocked or not.

Alarm blocking Guidelines

When an alarm that is assigned to an Alarm Blocking group is generated:
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« If thereisacurrent alarm with higher priority in the group, the newly generated alarm is
blocked.

« For Peer Blocking, if there is a current alarm with equal priority in the group, the newly
generated alarm is blocked. In other words, only one alarm in a set of alarms with equal priority
displays at any given time.

« For Non-Peer Blocking, all current alarms with equal priority display at any given time.

When the blocking alarm returns to Normal state or is deleted:

« For Peer Blocking, if alarms of equal priority exist, the oldest one displays and becomes the new
blocking alarm.

« For Non-Peer Blocking, al alarms with the next lower priority display and become the new
blocking alarms.

If lower priority alarm is the current blocking alarm and a higher priority alarm is generated, the
lower priority alarm remains on the list of alarms and the higher priority alarm becomes the new
blocking alarm.

If an alarm already existsin Normal state and it returns to Alarm state, the alarm is not blocked.

Alarm Blocking Configuration

Alarm Blocking Configuration

Create a new alarm blocking group.

Open an existing Alarm Blocking dialog box.

Configure an alarm blocking group.

Add/remove/modify alarms.

L@E‘* @E‘” BE“ L@E‘“

1. Create a new Alarm Blocking Group

CIMPLICITY provides several methods to open anew Alarm Blocking dialog box.
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1. Select Project>Alarms>Alarm Blocking in the Workbench left pane.

2. Do one of the following.
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A Click File>New>Object on the Workbench menu bar.
B Click the New Object button on the Workbench toolbar.
C In the Workbench left-pane:
Either Or
Double click Alarm Blocking. a. Right-click Alarm Blocking.
b. Select New on the Popup menu.
D In the Workbench right pane.
a. Right-click any Alarm Blocking group.
b. Select New on the Popup menu.
E Press Ctrl+N on the keyboard.

A new Alarm Blocking dialog box opens when you use any method.

2. Open an Existing Alarm Blocking Dialog Box

CIMPLICITY provides severa methods to open an existing Alarm Blocking dialog box.

1. Select Project>Alarms>Alarm Blocking in the Workbench | eft pane.
2. Select an Alarm Blocking group in the Workbench right pane.

3. Do one of the following.
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A Click Edit>Properties on the Workbench menu bar.
B Click the Properties button on the Workbench toolbar.
C In the Workbench left pane:
a. Right-click Alarm Blocking.
b. Select Properties on the Popup menu.
D In the Workbench right pane:
Either Or
Double click an Alarm Blocking a. Right-click an Alarm Blocking group.
group. b. Select Properties on the Popup menu.
E Press Alt+Enter on the keyboard.

An Alarm Blocking dialog box associated with the selected alarm blocking group opens when you
use any method.

3. Configure an Alarm Blocking Group

Enter the following information to create a new Alarm block group:

Alarm Blocking x|

General I

Group ID: [ALARMBLOCKA [+ Peer block
Description: [

Alam 1D Prioty Resowce ID Add.
ALARMBLOCKS _I
ALARMBLOCKA
ALARMBLOCKS
ALARMBLOCK2
ALARMBLOCKT
ALARMBLOCKE
ALARMBLOCKT
ALARMBLOCKS
ALARMBLOCKY
BLARMBLOCKTD

e[ == [
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Field Description

Group ID Enter a new, unique Alarm group name. The group name can be up to 32 characters long.

Description | Enter a description of the Alarm group. The description can be up to 40 characters long.

Peer block
» Check to enforce Peer Blocking mode (page 20) for this group.
« Clear if you want to use Non-Peer Blocking mode (page 20).
The Blocking Mode and alarm priorities determine the alarm blocking hierarchy at run-time.
Alarms Displays the current list of alarms in the Alarm block group; Alarm ID, Priority (page 20) and Resource

ID. Change an alarm on the list by directly editing its Alarm ID, Priority or Resource ID or by selecting the
Alarm ID and clicking Set attributes .

|=/ Note: You can resize the width of the Alarm ID, Priority and Resource ID fields to suit your
needs.

Click one of the following:

Button Description
Add Select an Alarm ID from the Browser dialog box.
Delete Delete an alarm from the list.
Set Attribute (page 24) Open the Set Attributes dialog box for a selected alarm ID.
OK Close the Alarm Blocking dialog box and save the configuration.
Cancel Cancel the configuration done while the Alarm Blocking dialog box was
open.

4. Add/Remove/Modify Alarms

* Add an darm.
» Remove an darm.
* Modify an alarm.

Add an alarm

Y ou can enter the name of an Alarm ID in the Alarm ID field in the Alarm Blocking dialog box in
any of the following ways:

* Click Add to open the Browser dialog box and browse for the Alarm 1D you want.
» Click the Browser button to the right of the input field to open the Browser dialog box and
browse for the Alarm ID you want.
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* Click the Popup menu button to the right of the input field to create anew Alarm 1D, modify
the current Alarm ID or browse for an Alarm ID.

Enter the priority of the Alarm ID in the Priority field. This can be a number from 0 to 32767. The
higher the number you enter, the higher the blocking priority for the alarm. For example, if you have
alarm XXX with priority set to 10 and alarm YY'Y with priority set to 100 in the same group, when
aarm YYY generates, it blocks alarm XXX.

If the Alarm ID does not have a Point ID, you must assign a Resour ce I D to the alarm. Y ou can
click the Browser button to the right of the input field to open the Browser dialog box and browse
for the Resource ID you want. Y ou can also use the Pop-up menu button to create a new Resource
ID, modify the current Resource ID or browse for a Resource ID. Remember that each Alarm 1D/
Resource ID combination must be unique within a group and across all groups.

Remove an alarm

1. Select the alarm from the list in the group's Alarm Blocking dialog box.
2. Click Delete.

Modify an alarm
To modify an alarm'sname, priority and Resource ID in thelist:

1. Select the alarm ID you want to edit in the selected group's Alarm Blocking dialog box.
2. Typein your changes.

If you are changing an Alarm ID or Resource ID, you can also use the Browser and Popup menu
buttonsin the field to search for anew one.

To set anumber of alarmsto the same priority and/or Resource ID at the same
time:

1. Select the alarms whose priority and/or Resource ID you want to set. Y ou can use the Shift and
Ctrl keys while making your selection.
2. Click Set Attributes.

The Set Attributes dialog box opens.

x
Friarity: |2 5‘
Hesaurce [1I: I ﬂ j
QK. I Cancel |

3. Enter the new priority and/or Resource ID for the alarms.
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4. Click OK.

All the selected alarms will be assigned the new priority. Non-point alarms will be assigned the new
Resource ID.



Chapter 3. Alarm Classes Configuration

About Alarm Classes

Y ou can group Alarms with similar characteristics by Alarm Class.

Y ou can then assign:

» An order or priority to each Alarm Class. The order is a number from 0 to 99, where O isthe
highest priority and 99 is the lowest priority.

+ Colors and blinking that provide immediate visual recognition of different levelsin the alarm
Class state.

For example, an alarm class may be defined as a high priority alarm. The alarm state may bein
aHigh state.

+ Audio support that provides immediate recognition when an alarm in the class is generated.

1) Important: The default number of alarm classes is 550. This number can be changed by adding
aMAX_ALARM_CLASSES parameter to aglobals.ini file.

Alarm Class Configuration

Alarm Class Configuration

Step 1 | Open the Alarm Class Configuration dialog box.

A
o |3
® o

Enter alarm class specifications.

g8

0]
=
@
=}
w

Configure sound for an alarm class.

Sep 1. Open the Alarm Class Configuration Dialog Box

Step 1. Open the Alarm Class Configuration Dialog Box
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Option Create a new alarm class.
1

Option Open an existing Alarm Class Configuration dialog box.
1

Option 1.1. Create anew Alarm Class

CIMPLICITY provides several methods to open anew Alarm Class configuration dialog box.

1. Select Project>Alarms>Alarm Classes in the Workbench | eft pane.

2. Do one of the following:

T PROFCIMP - CIMPLICTTY Workbench [ | D )
AdFie | Edt Computer Project View Tooks Help

go k™| &5
1 Project « | dass1o Class Descripbion = 3
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:‘J EE:::; O High Pricrity Alarms —
. 5 Points = LW Lows Priority Alarmes Q.
ﬁ Alarms i reD &
+-§8 Alarm Setups 1 norTH
G eoc N
‘alarm Strings f FrT -
Alarm Prirter f rco f A
& alaem OPC Clisnt f 1a0B Tadb Class Alarms e
) Alarm Blodking e <
+- @, Alarm Translstor £ TamL - =
X Script Engine bl 2 ‘ol
Ready
A Click File > New > Object on the Workbench menu bar.
B Click the New Object button on the Workbench toolbar.
C In the Workbench left pane, do the following:
Either Or
Double click Alarm Classes. a. Right click Alarms.
b. Select New on the Popup
menu.
D In the Workbench right pane, do the following:
a. Right-click any alarm.
b. Select New on the Popup menu.
E Press Ctrl+N on the keyboard.

An Alarm Class Configuration dialog box that includes information for the selected alarm class
opens when you use either method.
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Alarm Class Configuration ﬁ
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Fosegiourd | s w | Bk rate in tenths of & second:
Background [\hite vl Black
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S [ )

Option 1.2. Open an existing Alarm Class Configuration Dialog Box

CIMPLICITY provides several methods to open an existing Alarm Class configuration dialog box.

1. Select Project>Alarms>Alarm Classesin the Workbench | eft pane.
2. Select an alarm class in the Workbench right pane.

3. Do one of the following:

(T PROFCIMP - CMPLICTTY Workbench .2 | D it
[ AJ|Edt | Computer Project View Tools Help ]
G2 &5
- Project
-5y Scresns
?.'l()hptts
Classes
45 Poirks
- smdms
i Alarm Setups

Alarm Strings
B Alarm Prinker
B farm OPC Clent
) Alarm Blocking
+ t_ Alarmn Transiator
i1 Seript Engine -
\Ready

Fa - T

A | Click Edit>Properties on the Workbench menu bar.

B | Click the Properties button on the Workbench toolbar.
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C | In the Workbench left pane:
a. Right-click Alarm Classes.
b. Select Properties on the Popup menu.

D | In the Workbench right pane:

Either Or

Double click an Alarm Class. a. Right click an alarm.
b. Select Properties on the Popup menu.

E | Press Alt+Enter on the keyboard.

The Alarm Class Configuration dialog box for the selected alarm class opens when you use either
method. The Class ID field is read-only.

Alarm Class {onFix}ur,\:ion - MORTH é
Alsern Clatz | Anacho

Clazs 1D MORTH Oider, O

Deser
Oithwer slabes
State: Noemal | Bk rate in terthe of a second: 0
Fouegrourd |4 -
Background | Gray |
Sl #ahe
Al levet | HHi || W the caine seitings ol ol sl vl
Fosgound | ik = | Blrk rabe in tenths of a second )
Batkgiturd | Red vl
Acknowhedged state
Al levet |HiHi = | Use the same settngs or ol slarm levels |
Fotegrourd |y faa w | Birk rabe in tenthe of & second: )
Backgiound | B -1

Open || Cancel |[ oo | [ Heo

Sep 2. Enter Alarm Class Specifications

Step 2. Enter Alarm Class Specifications

Step 2.1 | Enter alarm class general specifications.

(page
31)

Step 2.2 | Select colors and blink rates for the alarm states.
(page
32)
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Step 2.1. Enter Alarm Class General Specifications

General specifications on the Alarm Class tab in the Alarm Class Configuration dialog box include
the following.

Alarm Class Configuration - NORTH x|

Alarm Class |,€.-.,u.;|i.;. |

INDHTH

Classz ID:

Order: IIJ _Ij

Deszcription: I

|—Dther states

--—'_‘--_.»—'?\-——-J-“n._‘4

rect 11, 21, 156, 55 (page 31)
rect 193, 55, 338, 89 (page 32)
rect 20, 87, 437, 121 (page 31)
rect 50, 55, 195, 89 (page 31)

Field

Description

Class ID

Alarm class name.

* New alarm class

The Class ID field is read/write when the alarm class is created. The class ID:

o Can be up to 5 characters in length.
o Must be unique.
o Cannot include the $ or | characters.

Alarm Class Configuration

Alaim Class | Audio |

CessiD:  [NORTH <l

e

* Previously created alarm classes

The Class ID field is read-only for previously created alarm classes.

Alarm Class Configuration - NORTH

Alam Class |Aucio |

Class ID: |N|:|F“H i

. T mnimbi I -

Description

» Can be up to 64 characters in length
« Displays in the Class Description field in the Workbench right pane.
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Field Description

Order Priority number

« Alarms with a 0-order number have the highest priority. The higher the number, the
lower the priority.

+ Alarms use these priorities internally and to prioritize occurrences, such as alarm
sound.

« If you assign the same order to more than one class, the classes are alphabetized
within the order.

Example

You assign order 0 to High, Medium and Low alarm classes. When you select to sort
classes in the CIMPLICITY AMV Control Properties dialog box, the Alarm Viewer will
sort by the selected order, descending or ascending.

o High

o Low

o Medium

Step 2.2. Select Colors and Blink Rates for Alarm States

Selected foreground (font) and background colors display in the Alarm Viewer for each of the
following states and levels.

Other States
Field Description
State Normal
Unavailable
Foreground Font color
Background Background color
Blink rate in tenths of a second Alarms in either or both Other states can blink when the
state is active.
Blink rates for each Other state include:
Value
0
1
2
20
N
Blink foreground color Font blink color.
The second color is the Foreground color for the selected
state.
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Field Description
Blink background color Blackground blink color.
The second color is the Background color for the
selected state.
Alarm state
Field Description
Alarm level Levels map to the point alarm limits defined in the Point
Properties dialog box, which use the alarm string indices.
Foreground Font color.
A different color can be selected for each level.
Background Background color.

A different color can be selected for each level.

Use the same settings for all alarm levels

When clicked, uses the Foreground and Background for
the selected Alarm level.

1. Select an Alarm level.

2. Select a Foreground.

3. Select a Background color.

4. Click Use the same settings for all alarm levels.

Blink rate in tenths of a second

Blink foreground color

Blink background color

Acknowledged state
Specifications for alarm levels when the alarms are acknowledged.

Configuration options are the same as for Alarm State.

Sep 3. Select Sound for an Alarm Class

Step 3. Select Sound for an Alarm Class

Y ou can configure an alarm class to use audio alarming on the Audio tab in the Alarm Class
Configuration dialog box.

» Hardware and software requirements to generate an audio alarm.
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* Steps to configure an audio alarm.

Har dwar e and softwar e requirementsto generate an audio alarm

Sound Requirements
Wave file
« Sound card to generate the sound.
» Sound system, such as a speaker or headset, to make the sound audible.
« Appropriate . wav file on the computer being used.
Beep

 No requirements for:

> A beep

> (Supported Windows versions) the frequency, duration and number of beeps
+ Sound card for:

A beep, the frequency, duration and number of beeps.

Stepsto configure an audio alarm

Display the Audio tab in the Alarm Class Configuration dialog box.

Configure sound for selected alarm levels.

D) Important: Soundsonly play if the CIMPLICITY® Alarm Sound Manager is running.

Step 3.1. Display the Audio Tab

Select the Audio tab in the Alarm Class Configuration dialog box.




#Alarm Class Configuration - NORTH

Alamm Class Audluﬂ
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Alam levek Im Use the same settings for all alam levels |
" Mo sound
" Wave file File name; | |
" Beep Erequency Il_ He
Nocfbesps O
Diela Il_ M Test
— —L
|
Lo ] oo | o | v |

|=) Note: Y ou can open the Alarm Class Configuration dialog box and configure the audio for a

point alarm through the Point Properties dialog box.

Step 3.2. Configure .wav Filesfor an Alarm Class Sound

1. Select an Alarm level.

|5/ Note: Alarm levels (page 32) map to the point alarm limits defined in the Point
Properties dialog box, which use the alarm string indices.

Alarm levels for sound use the alarm conditions and sub-conditions as follows.

HiHi
Hi
Lo

LoLo

2. Select a sound option for the selected level.
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Option Description
No sound | There is no sound
when the selected
level is reached.
Alarm Class Configuration - NORTH
Wave file | The sound from the

.wav file plays when
the selected level is
reached. Enter the
path and .wav file you
want to use as the
sound for the selected
level.

Tip: You can
specify logical names
in the file name,
such as SITE_ROOT
and BSM_ROOT
in the path name
for the wave file.
These are expanded
into actual directory
names when the file
is used. For example,
SITE_ROOT: \sounds
\high.wav refers to
the file high.wav in
the sounds directory
within the project's

directory.
x4
Alaren Class: ml
Hlesrn et [HHi *]  Lsathe same cotings e ol slum levels |
" o gourd
ave fle Flegame:  [CWWINNT Media\chord wav .
(‘n” Fremquencs Ij Hz
2 O
If] W Tesd
|
0k | cacel | aeoh | Hee |
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Option Description

Beep A defined beep
sounds when the
selected level is
reached.

Frequency
Duration
No of

beeps

Delay
x|

Alarm Clazs. Audio |

Aleem lovet. [HHi - s the same selfings foe ol sl leveds |

" Mo gound
" Wave fis

Test Click to test the sound.

3. Do one of the following:

* Repeat the above steps for the Alarm Viewer to play the selected sound for the active alarm
state level.

* Click Use the same settingsfor all alarm levels for the Alarm Viewer to play the selected
sound for all levels when the point isin an alarm state.

Alarm Class Color Assignments
Alarm Class, alarm state animation and color index animation use indexes 0 through 15 in the
rgb.dat file as the default colors.

If you define an rgb.dat file and change the colors in indexes O through 15 of the, you need to
change colors displayed in the Alarm Class dialog box to match them.

Reasons to define an rgb.dat file include:

 Change any of the default colors (0 through 95)
» Add more colors to the default table (indexes 96 through 255 are available for this purpose)
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* Import screensfrom a CIMPLICITY System-1/U, -D/V, -H/U or -RS/U system that do not use
the default color mappings.

Default Alarm Color Mappings

The default mappings for Alarm Colors are:

Number | Red | Green | Blue | Color
0 0 0 0 Black

1 255 0 0 Red

2 0 255 0 Lime

3 0 0 255 Blue

4 128 0 0 Maroon
5 0 128 0 Green
6 128 0 128 Purple
7 255 255 255 White

8 0 128 128 Teal

9 128 128 128 Gray
10 128 128 0 Olive
11 32 64 64 Dark
12 224 176 160 Rose
13 255 0 255 Fuchsia
14 0 255 255 Aqua
15 255 255 0 Yellow

Procedure to Map Alarm Class Colorsin rgb.dat

1. Create an am_colors.cfg file in the same directory as your rgb.dat file.
Thefirst linein the file must contain only the |-* characters.

Each succeeding line contains an index number (0 through 15) followed by avertical bar (|)
and the color name.

2. Usethe samergb.dat and am_colors.cfg filesfor all projects.
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(1) Important: Thefilethat is used to display colorsisthefile for the project in which Alarm
Viewer or CimView was started in, not the file for the project where the alarm classes or
CimView screens were configured.

am col ors. cf g file

The colorslisted in this sample file match the default colors.

=
O|Black
1|Red
2|lLime
3|Blue
4|Maroon
5|Green
6|Purple
7|White
8|Teal
9|Gray
10|0live
11|Dark
12|Rose
13|Fuchsia
14|Aqua

15|Yellow



Chapter 4. Alarm Strings Configuration

About Alarm Strings

Y ou use Alarm Strings to name alarm states. An alarm displays the string for its alarm state when
% State isincluded in the alarm message.

Alarm messages are configured in the Point Properties and Alarm Definition dialog boxes.

+ Analog point alarm strings.
* Digital point alarm strings.
* Alarm string sets.

Analog point alarm strings

For analog points, you can define up to four alarm values for a point. Each value corresponds to an
alarm state; each state has a corresponding alarm string:

Point Value Alarm State | % Statefield Display

Greater than or equal to Alarm High. Alarm High Alarm High Msg

Greater than or equal to Warning High and Less than Alarm High. | Warning High Warning High Msg

Less than or equal to Warning Low and Greater than Alarm Low. | Warning Low Warning Low Msg
Less than or equal to AlarmLow. Alarm Low Alarm Low Msg
Less than Warning High and Greater than Warning Low. Normal Normal Msg

Digital point alarm strings

For digital points, only one alarm state can be defined. That is, adigital point isin alarm state when it
iseither 1 or 0. Otherwise, the point's value is in the Normal state. Also, note the following:

Point Value | Alarm State | % State field Display

1 Alarm state Alarm High Msg

0 Alarm state Warning High Msg




Alarms and Messages | 4 - Alarm Strings Configuration | 41

Alarm string sets

An index number, which is specified when a set is defined, identifies each set of alarm strings. Y ou
can configure up to 99 alarm string sets, numbered 1 through 99. When you configure a point you
can select the set that applies to the point for inclusion in the point's alarm message.

The CIMPLICITY default configuration includes a set of alarm strings for Index number 1. The
Index number 1 alarm string is the default when you add a device point. This string may be modified
but should never be deleted.

Alarm Sring Configuration

Alarm String Configuration

The Workbench displays a project's existing alarm strings (message groups) in the right pane.

Steps to configure an alarm string include:

Step 1 | View existing alarm strings.

Open the Alarm String Index dialog box.

» =10
o
lL\BmF
[{e]
® o

@EE

Configure an Alarm String Index Set

Sep 1. View Existing Alarm Strings

Select Project > Alarms > Alarm Stringsin the Workbench left-pane.

The Workbench right pane displays the following fields for each Alarm String Index:

* HiHi (alarm high) Msg
* LoLo (alarm low) Msg
* Hi (warning high) Msg
* Lo (warning low) Msg
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T PROFCIMP - CIMPLICITY Wiorkbench L= | &0 e
Fia Edt Computer Project View Tools Help
| EFN |1 PGS IBERGEELE 8@
Project = | index | HiHi {alarm high) Meg | LoLo (alarm low) Msg | Hi (waming high) Msg | Lo {waming low) Msg | Mormal Msg
% “ﬁ z:v: g1 HH Lodo Hi Lo MNORMAL
B Classes 4 ¢ TooFasst Too Sow Fanst Show NORMAL I
o o s 43 Tookot Too Cool Hot Cool hoAMAL
B A 44 STATEL STATES STATEZ STATEZ NORMAL
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Alarmn Classms & & VERYHIGH VERY LOW HEGH L MORMAL
&7 CUTRSEFED Toeprn | T FAST OO SLOW NORMAL
Alarm Prinker =
B sl OPC Chent
) Alarm Blacking
* t Alarm Translabor =
Ready Sop E

|=) Note:  Use the Workbench Field Chooser to remove or re-display any of the fields, except the
Index. The Index is required.

The Alarm Definition list isinitially sorted by Index. Y ou can click on any of the other column titles
at the top of thelist to sort the list by that attribute.

Sep 2. Open the Alarm Sring Index Dialog Box

Step 2. Open the Alarm String Index Dialog Box

Option Create a new alarm string set.
2.1 (page
42)

Option Open an existing Alarm String Index dialog box.

2.2 (page
43)

Option 2.1. Create a new Alarm String Set

CIMPLICITY provides several methods to open a new Alarm String Definition dialog box.

1. Select Project>Alarms>Alarm Stringsin the Workbench left-pane.

2. Do one of the following:
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( T/ PROFCIMP - CIMPLICITY Workbench E=E)
_.FlFile | Edit Computer Project Wiew Tools Help
9ok D& F
=-[) Project - i " s
, t;]::[“m Index Hin (alarm high) Msg .E.'i
'.’f'] Chbjects 4L HH =
! Classes L @ 2 TooFast 4@
-7 Points [ E}I“ Too Hot
= ﬂ' Alarms
+ Alarm Setups
3 Alarm Classes B
Alarm Printer iil
& plarm OPC Client 1
) Alarm Blocking .
+ t Alarm Translator = |« [ 0 =
_Rea.dy
L.
A Click File>New>Object on the Workbench menu bar.
B Click the New Object button on the Workbench toolbar.
C In the Workbench left-pane:
Either Or
Double click Alarm Strings. a. Right-click Alarm Strings.
b. Select New on the Popup menu.
D In the Workbench right-pane.
a. Right-click any alarm string.
b. Select New on the Popup menu.
E Press Ctrl+N on the keyboard.

An Alarm String Index dialog box that displays the next highest number opens when you use
any method.

Option 2.2. Open an existing Alarm String Index Dialog Box

CIMPLICITY provides several methods to open an existing Alarm String Index dialog box.

1. Select Project>Alarms>Alarm Stringsin the Workbench left-pane.

2. Select an alarm string in the Workbench right-pane.

3. Do one of the following:
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[ ¥4 PROFCIMP - CIMPLICITY Workbench E=E)
[F AJ Edt | Computer Project Wiew Tooks Help
e &3
=) Project - i ; —_
e f;:}:cmehs Index HHl (alarm high) Msq 'y
P, Objects g1 HH =2
B Classes @ 2 TooFast /&;l
- Points
= ﬂ‘ Alarms
+ Alarm Setups
Alarm Classes
c
§  Alarm Printer
& plarm OPC Client el
Ty Alarm Blacking @
@ Alarm Translator = |« [Lm =
Ready
A Click Edit>Properties on the Workbench menu bar.
B Click the Properties button on the Workbench toolbar.
C In the Workbench left-pane:
a. Right-click Alarm Strings.
b. Select Properties on the Popup menu.
D In the Workbench right-pane:
Either Or
Double click an alarm string. a. Right-click an alarm string.
b. Select Properties on the Popup menu.
E Press Alt+Enter on the keyboard.

An Alarm String Index dialog box associated with the selected alarm string opens when you use

any method. The Alarm string index field is read-only.

Sep 3. Configure an Alarm String Index Set

x4
e stingindex. [2 2]

Sting values

Alam highc Too Full Severitw [1o0 5‘

Waming high: |[Almost Full
\Waining low:  [Almost Empty

Alairn lowr Empty
Maormal MORMAL

0

j

Severity:

Severity: |5':' _|::'
Sewverity: |1 o 5‘
Severity: |':| _|::'

o |

Cancel |
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Alarm string index

String values

Severity

Example 1

Example 2

I
)
L

1. Alarm String Index

Alarm string identification.

* New alarm string sets

The next available number displaysin the Alarm string index field when the alarm string is
created. Thefield is read/write.

If the default number is changed, the new alarm string index number:

> Must be from 1 to 99 and
> Cannot conflict with an existing Alarm String Index.

Alarm String Index

* Existing alarm string sets
The Class ID field isread-only for previously created alarm string sets.

Alarm string indexc [q

~ Sting walses -
P L | T

The index number is selected for an alarm to associate an alarm string set with that alarm.

2. String Values
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Valuesfor each of the following fields can contain up to 16 characters.
Alarm high

Warning high

Warning low

Alarm low

Normal

The value you enter for an alarm string index:

« Corresponds to Normal and Alarm State levelsin the Alarm Class Configuration dialog box.

* Displays on the Alarm tab in the Point Properties dialog box when the string index is selected.

+ Displays when specified as “STATE in a point's alarm message when the point isin the related
alarm state.

3. Severity

A number from 1 through 1000. The higher the number the more severe the alarm is considered.
CIMPLICITY treats more severe alarms with a higher priority.

|=/ Note: The Severity for the Alarm String Index must conform to the OPC UA specification
guidelines. If you are using Operations Hub with CIMPLICITY, be sure to read the "Alarm
Microservice" topic or search for "alarm severity" in the Operations Hub documentation. It's
important to configure this severity correctly so that you get the results that you want to seein
Operations Hub. For example, events of high urgency can be mapped into the OPC severity range of
667-1000, events of medium urgency can be mapped into the OPC severity range of 334 to 666, and
events of low urgency can be mapped into the OPC severity of 1 to 333.

|5/ Note: You can select and display the Severity in the Alarm Viewer.

This example shows how the alarm string value for alarm string index 2 displaysin the Alarm
|
Alarm shing index: |2 _l:‘ \1/

— String values

Alambigh:  [TooFul Seveitz[50 =]
Warminghigh [AmostFul — Sevedity: 200 =]
Warminglow. [MmostEmply  Seventy [200 =]
Aamlow.  [Empy  Seveitp[o50 =]
Mommak ’W Severty m

ok Cancel |

Viewer M essage field
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String values are entered in the Alarm String Index dialog box.

String field Value

Alarm high Too Full
Warning high Almost Full
Warning low Almost Empty
Alarm low Empty
Normal NORMAL

Point Properties - N110

General | Virtual | View | Limts | Conversion Alarm | Alaum Routing | Alarm Options |

Definition

Al message: |%STATE VAL N110 24 j
Alam class: NORTH ﬂ j Sting index: |2 @d

o Alam s~ 2C | 1 Alam criteria
Too Full ﬁﬂ Alarm type: Absolute "I [~ Updal

Almost Fulk 4500

Almost Emply: 1000 I~ Doty e
Emply: 500 Desdband: |

___,..—-'"'""“-\—._ - e ——

A %STATE in the Alarm message displays the
string values for the selected alarm string
set.

B String index 2 is selected.

C Alarm limit fields correspond to the selected

string index values.

String Value Alarm Limit
Too Full Too Full
Almost Full Almost Full
Almost Empty Almost
Empty
Empty Empty
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CIMPLICITY AMY Control Properties |

CountLayost | DateFomat | Fonts | !
O Fieids | Butons | Projects | SowD
1 Severnly Position Left
1 AlamiD j 4'
BJ1 Class Pasition Bight |
BJ1 State
[J1 Message Fow e I
E 1 Date _I Row Down
Mode _,
@ Static Modiy.. |
" Dgnamic \
|
3 Message is selected as

a field in an Alarm Viewer

v ALARMS.cim

File View Help
S &Nt | DE® |
10 Apr 25 16:20
Severity] Alarm ID |class | state | me
50 H105 NORTH ALARM Too Full H105. CALL SUPER N.
oo H106 HORTH ALARM Almost Full 4500 N106.
oo H107 HORTH ALARM Almost Empty 500 107
P50 Hi09 HORTH ALARM Empty CALL SUPER HORTH SHIFT 2.
250 H115 NORTH ALARM Err 450
| Boeton i,.. NI S
configuration.

The Alarm Viewer displays the alarm string
values for every point that includes %sTATE in
the alarm message.

This example shows configurations for the Alarm String 2 index severity displaysin the Alarm
Viewer.

1 | An alarm severity is entered for each string value in the Alarm String Index dialog box.

x|

Alsm stingindex: [2 = \l’,

i Sining values
Alsm bighe  [Too Ful Seveity [250 =
‘Warming high:  [&dmost Full Seveity: |200
Warminglow. ~[Amost Emply Seveiity [200 =
Alsmlow:  [Empty Seveity: [250 =]
Mormiak [NORMAL Seveiity [0 |

oK | Cancel |

String value Severity

Too Full 250
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Almost Full 200
Almost Empty 200
Empty 250
NORMAL 0

The selected string index is 2.

Point Properties - N125

Genesal | Vitual | View | Limits | Conversion Alam Inhmﬂm]ﬁhmﬂﬁ

2
\_)dm

Alarm message: [CALL SUPER SHIFT 2

2

The alarm limits fields correspond to the string index 2 values.

The fields inherently include the severity levels defined for the alarm string set.

N P [ ol
- Alaim crteria ‘
Momipe  [owne =]
™ Delay alam

String value Alarm limit
Too Full Too Full
Almost Full Almost Full

Almost Empty

Almost Empty

Empty

Empty

Class and Severity are selected as fields in an Alarm Viewer configuration.

CIMPLICITY AMY Control Properties |

Countlapout |  DateFomat | Fonte |
\E" Fields Butons |  Projects | Sot/D
1 Seveity ‘ Posiion Left
g1 AlamiD - |
BJ 1 Class ‘ Pmltmﬂlght
BJ1 State —
BJ 1 Message o Lip
S =| _rowpom |
Mode
(+ Static Modify... |

" Dynamic \

——
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4 | The Alarm Viewer displays the class and severity.

< ALARMS.cim

Fi= View Help
(&%t 1 @EM |
10 Apr 221748

Severity | larm 1D | Class | state |Message

250 Hi05 NORTH ALBRM Too Full

i) DG HORTH ALARH Hmast Ful

00 MA07 NORTH ALARM Hrmost Em

50 M08 NORTH ALBRM Empty  ©,

P50 H115 NORTH ALARM Empty 4

200 MAZ0 NORTH ALARM Hmost Full

PROCESS_TEMPERATURE  HI HORMAL  Process Te
PROCESS_VISCOSITY H NORMAL  Frocess W
ain) TAMKZ HIGH ALBRM TANKZ iz .
100 TAMK_LEVEL HIGH ALBRM Storage t=2
Fok | Feset | Diefete |
nanle | Hetun | Helrr I Sdem Sxank I i

«l

For Help, press F1
Class NORTH
Severity Value corresponds to each level.
Severity value Corresponds to
275 HiHi and LoLo
200 Hi and Lo

@ Note: Foreground and background colors for each alarm correspond to the alarm class configuration.




Chapter 5. Alarm Printer Configuration

About Alarm Printer Configuration

Y ou can configure a seria or parallel printer in CIMPLICITY software that prints alarms and/or
events as they occur. Y ou may also configure an alarm printer to write to afile, rather thanto a
device. Y ou may configure alocal or network printer as the alarm printer. If your project includes the
Host Redundancy option, you may configure a redundant alarm printer.

D) Important: Before you start, make sure that the printer is not configured in Windows.

Alarm Printer configuration.

Alarm Printer Configuration

The Alarm Printer dialog box enables you to define the device, and the types of alarms handled by it.
Y ou can configure local and network printers.

|=/ Note: You can also configure redundant alarm printers if your project supports the Host
Redundancy option.

When you are finished defining the alarm printer properties, click OK to close the Alarm Printer
dialog and create the new alarm printer, or click Cancel to close the property sheet without creating
the new alarm printer.

Step 1 | Open an Alarm Printer dialog box.

w
=
@
=}
N

Configure General Alarm Printer Properties

Configure Alarm Printer Layout Properties

Configure Alarm Printer Date/Time Format

%3
@
D

(page
57)

Step 5 | Continue for Serial, Redundant or Network Printers
age
8

“F
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Sep 1. Open an Alarm Printer Dialog Box

Step 1. Open an Alarm Printer Dialog Box

Option Add an alarm printer.
1.1 (page

8

Option Modify an existing alarm printer.

Option 1.1. Add an Alarm Printer

CIMPLICITY provides several methods to open anew Alarm Printer dialog box.

1. Select Project > Alarms > Alarm Printer in the Workbench |eft pane.

2. Do one of the following:

= ™
fi’{; ProfCIMP.gef - CIMPLICITY Workbench (= [ © i
?: File | Edit Computer Project Wiew Tools Help
STEELT
B Objects -
B Qasses
- Points
-8 Alarms

50 Alarm Setups -
£ Alarmn Classes
q Alarm Strings

X
E’ Alarm OPC Chent
) Alarm Blocking

v t. Alarm Translator

o[ ) Seript Engine

#-[ ) Equipment
#-[ ) Security -
|Records Re trieved : 1
" o
A Click File > New > Object on the Workbench menu bar.
B Click the New Object button on the Workbench toolbar.
C In the Workbench left pane, double click Alarm Printer.
D In the Workbench right pane:
a. Right-click any alarm printer.
b. Select New on the Popup menu.
E Press Ctrl+N on the keyboard.

The New Alarm Log Printer dialog box opens when you use any method.
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3. Enter the name of the new alarm printer, or the name of the file you want to write alarmsto in

the Namefield.
Y ou may enter amaximum of 11 characters.

MNew Alarm Leg Printer ﬁ

Nam! ALMPRINTER

4. Click OK.

The system verifies that the alarm printer name does not already exist, and that no invalid characters
have been used.

If the alarm printer name you entered isvalid, the Alarm Printer dialog box for the new alarm printer
opens.

Option 1.2. Open the Dialog Box for an Existing Alarm Printer

CIMPLICITY provides several methods to open an existing Alarm Printer dialog box.

1. Select Project>Alarms>Alarm Printer in the Workbench |eft pane.
2. Select an alarm printer in the Workbench right pane.

3. Do one of the following:
(T ProfCIMP.gef - CIMPLICITY Workbench (= [ E fi

IEyEﬂt Computer  Project  View Tools Help

1ROl E S
W Objects
B Classes
- Paints
-8 Alarms
w40 Alarm Setups
£ Alamn Classes
4 Alarm Strings
oe
& Alarm OPC Client
ﬂj Alarm Blocking
0 t_ Alarm Translator
#-[ ) Script Engine
w7 Equipment

&V

ey

#-[ ) Security -
|Records Retrieved: 1

%

A | Click Edit>Properties on the Workbench menu bar.
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B | Click the Properties button on the Workbench toolbar.

C | In the Workbench left pane:
a. Right-click Alarm Printer.
b. Select Properties on the Popup menu.

D | In the Workbench right pane, double click an alarm printer.

E | Press Alt+Enter on the keyboard.

An Alarm Printer dialog box associated with the selected alarm string opens when you use any
method.

Sep 2. Configure General Alarm Printer Properties

1. Enter specification using the following check boxes.
x
General | Layout | Date/Time Format |

[~ Logevents
¥ Log alarms

Alarm logging optiong

¥ Generated alarms [~ &l alam classes

[ Acknowledged alams  Alam class: IHIGH ﬂj

[~ Eeset alams
[ Deleted alarms

Dutput: ILF'T1

Ok, I Cancel Apply Help |

Check box Description
Log Events Check to log events to the printer.
Log Alarms Check if you want to log alarms to the printer.

|5/ Note: If you clear this check box, the Alarm logging are dimmed.

Alarm Logging | These options are available only when you select the Log alarms check box. Use these fields to

Options specify the types of alarms, and alarms classes that will be printed on this alarm printer:
Generated Check to log messages when alarms are generated.
alarms

Acknowledged | Check to log messages when alarms are acknowledged.
alarms
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Check box Description

Reset alarms | Check to log messages when alarms are reset.

Deleted Check to log messages when alarms are deleted.
alarms

(1) Important: You must either check All alarm classes or select an Alarm Class.

All alarm | Check to log messages for all alarm classes. When you do, the Alarm Class field will be dimmed.

classes
Alarm This field is available when you uncheck the All alarm classes check box. If you want log alarms for a
Class particular Alarm Class, enter that class name in this field. You can also:

« Display the Select Alarm Class browser and use it to select the Alarm Class.

« Click the Popp Menu button J to create a new Alarm Class, edit the current Alarm Class, or
browse for an Alarm Class.

2. Enter the device name for the alarm printer in the Output field. Y ou can do any of the
following:
* Enter the name of alocal port on the project's computer (e.g. LPT1 or COM 1) where you
have attached the alarm printer.

|=/ Note: If you are connecting to serial port COM 10 and above, the format is\\.
\COM<n>,

* Enter afile name to write dlarmsto afile. If you wish, you may also enter a period
followed by athree character file extension (e.g. alar msifil).

If you do not enter afile extension, none is automatically provided. Thefileis placed in the
project directory (not in the project's log directory) .

Example
If aproject nameis systest, thefileis placed in the systest folder:

I:\testplans\systest
« Enter the path for a network printer (e.g. \\M_005ad4\d5prn1).

|5/ Note: If the printer is connected locally on your computer, use the local port name
instead of the network path.

* Enter the path for afile on a network disk (e.g. \\ntO01\pr oj 1\alar ms).

0 Tip: You can associate more than one alarm printer with a network printer or fileon a
network disk. If you use a network printer or file, clear the Print header field in the Layout tab
of the Alarm Printer dialog box.
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Sep 3. Configure Alarm Printer Layout Properties

The Layout tab of the Alarm Printer dialog box enables you to determine whether a header should be
printed at the top of a page.

Alarm Printer - AMLP_MASTER _ALMPRI il

General Layout | Date/Timme Formatl

—Page zetup
V¥ Frint header

Page length:  |EE _:l
Avalue of 80 to forces

Page width: IBU _lj * the printer ta print an

- Bedundancy

[¥ | Redundant alarm prifiting

ok I Cancel | e ] Help

Specifications include:

Field Description
Print Check to print a header at the top of each page. If you have more than one alarm printer process sending
Headers messages to the same printer or file, uncheck this check box. When you uncheck the check box, the Page

length field is disabled.

Page Enter the number of lines per page that can be printed. The number must be an integer between 1 and
Length 999.

Page Enter the number of characters that can be printed on a line. The number must be an integer between 80
Width and 157.

(1) Important: If the printer is configured as 80 characters wide then AMLP will print on two lines
regardless of the actual width of the printer.

Redundant | This field is enabled if your project has the Host Redundancy option.
Alarm
Printing » Check for both the Active and Standby computers to print alarms.
(%gg » Uncheck for only the Active computer to print alarms.

59
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Sep 4. Configure Alarm Printer Date/Time Format

Use the Date/Time Format tab on the Alarm Printer dialog box to choose how the alarm printer will
print the date and time.

Alarm Printer - AMLP_MASTER _ALMPR il

Generall Layout Date/Time Format |

— Page header date
Sample: 03/10/02
Faormat;  |mm./dd

mmm dd -
mdds ey

mmdd

d-rrnim-yy LI

—&larm datedtime

Sample: 20:53:03

Format: |[HHHH:MM:55
HHHH: kM -
HHHH:tMM:55
HHHH:MM:S5.TTT
HH:}M:55 A LI

ak I Cancel | Anply | Help

Y ou can define the following:

Header Date Select the format you want to use to print the date on the alarm printer
page header. This field is not available if you are not printing a page
header. A sample for the format you choose displays in the Sample field
in this box. You may select one of the formats from the list, or construct
your own format.

Alarm Date/Time Select the format you want to use to print the date and time of each alarm.
A sample for the format you choose displays in the Sample field in this

box. You may select one of the formats from the list, or construct your own
format.

To construct month/day/year formats, use the following information.

m Numeric month with no leading zero.
mm Numeric month with leading zero.
mmm Short text month.

mmmm Long Text month.

d Numeric day with no leading zero.
dd Numeric day with leading zero.

ddd Short text day of the week.
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dddd Long text day of the week.

y Last two digits of year. For digits 00 through 09, only the last digit is displayed.
yy Last two digits of year. For digits 00 through 09, both digits are displayed.
yyyy All four digits of year

If you enter dddd dd mmmm yyyy, the sample date will be Saturday 05M ar ch 1994.
Y ou may use spaces, dashes, slashes or any other delimiter of your choice to separate the date fields.

To construct time formats, use the following information:

H Hours based on a twelve-hour clock with no leading zero.
HH Hours based on a twelve-hour clock with leading zero.
HHH Hours based on a 24-hour clock with no leading zero.
HHHH Hours based on a 24-hour clock with leading zero.

M Minutes with no leading zero.

MM Minutes with leading zero.

S Seconds with no leading zero.

SS Seconds with leading zero.

T Hundredths of seconds with no leading zero.

TT Hundredths of seconds with leading zeros.

P, A, p, or a | AM/PM indicator.

If you enter HHHH:MM:SS:TT p, the sample time will be 13:05:06:08PM.

Y ou may use colons, spaces or any other delimiter of your choice to separate the time fields.

Sep 5. Continue for Serial, Redundant or Network Printers

Step 5. Continue for Serial, Redundant or Network Printers

Option Continue for serial printers.

5.1 (page
59)

Option Continue for redundant alarm printers.

5.2 (page
59)

Option Continue for network printers.
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Option 5.1. Continue for Serial Alarm Printers

If you are configuring a serial printer, its printer baud rate, parity, and data length will have to be set
each time your system is rebooted. Y ou can do this by creating afile called cimp_port.bat in the
top-level directory on the disk where your project is located. The file will be called by the Alarm
Printer program when it initiates printing on the printer. The file contains:

@cho of f
nmode <port> baud=<rate> parity=<set> dat a=<n> st op=<np

Where

<port> | Is the serial port to which the printer is connected.

<rate> | Is the baud rate of the printer.

<set> | Is the parity used by the printer.

<n> Is the number of data bits.

<m> Is the number of stop bits.

Example

If you have a printer on COM 1: port that communicates at 9600 baud, no parity, 8 data bits and 1
stop bit, the file would look like this:

@cho of f
nmode COML: baud=9600 parity=n data=8 stop=1

If you have more than one serial printer, you will need one mode line per printer.

To create amode linefile:

1. Open a Notepad window.

2. Enter the printer configuration information according to the above template.

3. Savethefile called cimp_port.bat in the top-level directory on the disk where your project is
located.

Option 5.2. Continue for Redundant Alarm Printers

In aredundant configuration, both the active and standby computer have the same configuration.
When you perform a Configuration Update, the configuration data for the project on the active
computer is copied to the project on the standby computer.

The information you enter in the Redundant alarm printing and Output fields determine where
alarmswill be printed.
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Configuration for the following computer setupsis as follows:

1. For aredundant configuration where each computer has alocal line printer (LPT1) configured.

The primary computer is COMP1 and the secondary computer is COMP2.

CORP1 COMP2

« If you enter LPT1 in the Output field and check Redundant alarm printing, the active
project on COMP1 sends alarm messages to LPT1 on COMPL and the standby project
on COMP2 sends alarm messages that it generates while in standby mode to LPT1 on
COMP2.

When the project on COM P2 becomes the active project, it continues to send alarm printer
messagesto LPT1 on COMP2.

* If you enter LPT1 in the Output field and uncheck Redundant alarm printing, the active
project on COMP1 sends alarmsto LPT1 on COMPL. The standby project on COMP2
sends no alarms until it becomes the active project.

When the project on COMP2 becomes the active project, it sends alarm messagesto LPT1
on COMP2.

2. For aredundant configuration with a network line printer \\ABC\NET 1). The primary
computer is COMPL1 and the secondary computer is COMP2.

COMP1 COMP2

WABCIMETT

« If you enter \ABC\NET 1 in the Output field and check Redundant alarm printing,
the active project on COMP1 sends alarm messages to \ABC\NET 1 and the standby
project on COM P2 sends alarm messages that it generates while in standby mode to \ABC
\NET 1.This may result in duplicate messages.

If you select this option, disable the Print header field.

« If you enter \ABC\NET1 in the Output field and uncheck Redundant alarmprinting,
the active project on COMPL sends alarms to the network device. The standby project on
COMP2 sends no alarms until it becomes the main project.

When the project on COMP2 becomes the main project, it sends alarm messagesto WABC
\NET1.
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|5/ Note: Check Redundant alarm printing on the Layout tab in the Alarm Printer dialog box
if you want both the active and standby computers to print alarms.

Option 5.3. Continue for Network Alarm Printers

When you print directly to a network printer the Alarm Page functionality does not print alarm
messages as they happen, by default. Instead, it waits until thereisafull page of alarmsto send to the
printer.

To print the current set of unprinted alarms:

1. Click Tools> Command Prompt on the Workbench menu bar.
A DOS window opensin the CIMPLICITY project directory.

2. Enter amlp_flush.exe.

The alarms will be printed.

|5/ Note: You can also initiate amlp_flush.exe from scripts within the CIMPLICITY environment.
Thiswill trigger printing whenever the specified conditions (for example an alarm going off) are met.

Alarm Printer Global Parameters

1. The Alarm Line Printer program (AMLP) assumes that there is no restriction for the size of the
alarm message queue. If the output deviceis disabled, a virtual memory overflow can result.
You canusethe AMLP_MAX_QUEUE global parameter to restrict the size of the alarm

message queue.

2. The Alarm Line Printer program (AMLP) assumes that the time to be printed when an alarmis
acknowledged or deleted is the time the alarm was generated.
You canusethe AMLP_USE_GEN_TIME globa parameter to select whether you want the
generation time or the action (acknowledge or delete) time to be printed.



Chapter 6. CIMPLICITY Language Mapper

About CIMPLICITY Language Mapping

CIMPLICITY Language mapping can speed up configuration and offer language and text string
options during runtime when you have Alarm Viewers and/or CimView screens that:

 Will be viewed in different languages during runtime.
* Require only text string modification to be used for different situations.

© Tip: CIMPLICITY Language Mapping also provides an efficient method for using the same
screen in different locations when it will require different text strings for the same messages, e.g. Call
the North Tank supervisor or Call the South Tank Supervisor instead of Call the Tank Supervisor.
Text strings for each screen version can be mapped as a different language.

The following steps demonstrate CIMPLICITY language mapping configuration and runtime use.

Step 1 (page 63) Review alarm messages that are
available for translation.

Step 2 (page 68) Make CimEdit text available for
translation.

Step 3 (page 86) Translate keys into other languages
or English strings.

Step 4 (page 95) Work with keys in the CIMPLICITY
Language Mapper.

Step 5 (page 100) Print a translation file configuration.

Step 6 (page 102) Configure translation options for
runtime.

CIMPLICITY Language Mapper Window Overview

The CIMPLICITY Language Mapper window is the central location for viewing the translation
filesand is where you trand ate the keys (selected strings) in the trandlation files. It also offers other
administrative tools for maintaining the files.
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\1 TANKTRANSLATE.CLM - CIMPLICITY Language Mapper .:J.g.lil
\2;& EdR Transistions View Help
IDEE s BRE | S T
Key D | Tank_s 6 FRANCE | crine | aepan =|
ATTENTION ATTENTION ATTENTION a3 P 1
CALL FLOW MANAGER CALL TANK S .. APPELEZ LEDIR.. &FRRER EnOIF—2+ —J
CALL TANK SUPERWI,., CALL TANK_S APPELEZ LE SU., HIAREER B A==
CHINESE CHINESE CHINGIS miE = @
CLOSE Valve In. CALL.. CLOSE SOUTH... FERMEZ LAVAL.. HiEHEMN. 8F. EVH. J=L73
Closed Closed Fermé MaE ML=
ENGLISH EMGLISH ANGLAIS =H nE
FRENCH FRENCH FRAMCAIS i I
i alarm stete, callman. . Falamm stale, ¢ Sifétst dalame, . MREHUESE & 2 SEEEY, T3-
.‘ulpn.mE‘SE JAPANESE JAPOMAIS a# BT | . i
4 pady [ | #

1 | Title bar displays the active translation file name.

2 | Menu bar
Mewe Chri+M
Open... Ctri+ O
Save Ctri+ S
Sawe As
Prirt... Ctri«P
Prirt Preview
P —
Exit
3 | Toolbar
DEH s BX 5 2
ATB"C— D E"F~G—H™—I

4 | Status bar

5 | Primary strings that are available for translation

6 | Translated strings

Sep 1. Review Alarm Messages that are Available for
Trandlation

Sep 1. Review Alarm Messages and Strings that are Available for
Trandlation

The CIMPLICITY Language Mapper automatically makes all of a project's alarm messages available
for trand ation.



Alarms and Messages | 6 - CIMPLICITY Language Mapper | 64

Step 1.1 | Open the CIMPLICITY Language Mapper Window to View Existing Alarms

Step 1.2 | Make new point alarms available for translation.

Step 1.3 | Make a new alarm string available for translation

Sep 1.1. Open the CIMPLICITY Language Mapper Window

* Open the CIMPLICITY Language Mapper window.
* CIMPLICITY Language Mapper window just opened.

Open the CIMPLICITY Language Mapper window

1. Select Project > Alarms > Alarm Tranglator in the Workbench left pane.
2. Select Alarm Trandlator in the Workbench right pane.

3. Do any of the following:

—_— = b
1] ProfCIMP.gef - CIMPUCITY Workbench (o] ) ]
I_Fa"tJ- Edit | Computer Praject View Tools Help
B 2
=) Praject - 1
o8y Screans | L Alarm Transistor o
& -
G i_ Alarm Setups
' Alarm Classes B
4 Alarm Strings &
®  Alarm Printer t
a Alarmm QP Client :
Yy Alarm Blocking :
_C)t Alarm Translator e ]
- Senpt Engine =,
(7] ¥ P
+-| ) Equipmient - J* =
Feady

A | Click Edit>Properties on the Workbench menu bar.

B | Click the Properties button on the Workbench toolbar.

C | In the Workbench left pane:
a. Right-click Alarm Translator.
b. Select Properties on the Popup menu.

D | In the Workbench right pane, double-click Alarm Translator.
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| E | Press Alt+Enter on the keyboard.

CIMPLICITY Language Mapper window just opened

The CIMPLICITY Language Mapper window opens displaying the project's default file,
AlarmTrandation.clm.

q-n AlarmTranslation.clm - CIMPLICITY Language Mapper @M
il ranslations View Help
DEE +t2Rx & T

Key -
4|

¥l %2

21 %2 %3 %455

1 %2 exceed: X3 and is in 4.

%1 failed delvery of file %2,

¥1is $5TATE. Level is 22 %3,

Zlis %2 X3 %4,

2lisgx2-%3

%1 is %2, %3 in queus,

#1lis %2 %3 COOLNORTH: %4 LEVELRNORTH i 25
#1is %2 Heatis X3

%1is %2 Heatis %3 %4

e X2 Leveliz 33 %4

%1 is X2, Level is 33 %4,

1 %2 Rate is X3 %4,

Zis X2 Tempis %3 %4,

i X2 Temp. is %3

i

FlisinX2, L
a1 SYLE T DL EE AR LT Y
4 | i r
Feady -
L A

The following are automatically entered as keysin AlarmTranslation.clm:

— —».

" ProfCIMP.gef - CIMPUCITY Waorkkench el
File Edi  Computer Project Wiew Tools Hep
e s FPHEAaSARK|EEWER|e | O &5 1
= [ Project - "Namn ID Mswaagd -
W)y Soren: 1 I—
Py e i co_stant_romearn ;vmvmsammmwﬁ, .
B Claoes The configured Basic SiringSpace s %s,This
i) ¢ Points B s _cunce ey Is Exhausied e
- o [Ea E TARK_TRGOER TAHK, Trigger is % HO
a1l Alarm Setups HEAT_SOUTHRmgion(s Machire504 SOUTHRegondd MachinsfiE0d in s 40 s BA
A Alsern Classs HEAT_SOUTHRngRondd MachirestSlr} SCUTHRsgiondtd Mach nisA Ry BA
Alarm Sirings HEAT_SOUTHRmgion(l_MschirsES0} SOUTHRegendd Mac nisd R HE
a Alarm Printer HEAT_SOUTHRegonr S0UTHRegiendl nieAd Bl BA
B Alarmn OPC 1 404 CLEE o Cvetire Eveel = s o
. FL:HII o ."\. et W TER ot Dol B 5
' Al Blocking ~ e b ol
2 t Adgev Trandloter @ e piod B .‘:wﬂ s Termaruted on s Process name e
w7 Saript Enging SALARM_FANLM Prirt %3 has T == W%
&[0 Equipment BOLEAN OPEN VALVE! Taz
3 Secuty - GETALITOARFLY Mot appded. BA -
] m " i m g
| Recovdn Ratriewed 1111 e

Point alarm messages

System alarm messages

Alarm strings

@EIO oe} @ED
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|5/ Note: The alarm manager uses % to substitute strings into the alarm message. Thisis changed
inakeyto %1,%2, ... %n sothat afixed order of substitution parameters can be passed but the
actual order they appear in the message can be dictated by the location of the substitution.

Thisalows for different orders that are dependant on the needs for a specific language.

1> CAUTION: Do not change the name or location of the AlarmTrandation.cim file. If you do,
beforeit isrestored, the CIMPLICITY Language Mapper will not be able to find the trand ations.
The next time you open the CIMPLICITY Language Mapper window, a new AlarmTranslation.clm
will be automatically created and your translation configuration will be lost.

Sep 1.2. Make New Point Alarm Messages Available for Translation

Point alarm messages that were created after the last project configuration update will be
automatically entered into the AlarmTranslation.clm file when the next project configuration update
is performed.

1. Create anew point or select an existing point that does not have an alarm.
2. Open the Point Properties dialog box.
3. Select the Alarm tab.

4. Enter an alarm message and configure the alarm.

El
Germesi | Device Als |

Drediniticn

Alarm message: | Flow oud of iange ;]

k)

et

Hite 50000

Hi 45000

L (=00

Lola 4500

Advanced 3>
[ ] cwed | ah | web |

5. Close the Point Properties dialog box.
6. Make sure project configuration is updated.

7. Open the CIMPLICITY Language Mapper window.
The default AlarmTrandlation.clm fileis loaded.



Alarms and Messages | 6 - CIMPLICITY Language Mapper | 67

The message you entered in the Alarm message field in the Point Properties dialog box displaysin
=101 x]

File Edit Translations Wwiew Help
DeHiBEe® 3|7
K.ey I ﬂ

Ewent: %1 New: %2 0ld: %3

Ewent: %1 Point: %2 Value: %3
Failing ower to redundant device %1
Flova out of range

GEM 1 UPD %2 AWGE LOG TIME %3

; J
HiHi
Lo

the Key list, B e, !

Sep 1.3. Make a New Alarm String Available for Translation

Alarm strings that were created after the last project configuration update will be automatically
entered into the AlarmTranglation.clm file when the next project configuration update is performed.

1. Create anew alarm string set (page 42).
x|

Alarm ghring index: |2 _I:

— Stiing walues

Alaim high: IW Severity: m
"waining high: W Severity: Iﬂ
Warning lows IW Sty Iﬂ
Alarm lowr: W Severity: m
Mormal: W Severity: m

Ok, I Cancel |

2. Perform a project configuration update.

3. Open the CIMPLICITY Language Mapper window.
The default AlarmTrandation.clm file is loaded.
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The string values you entered in the String values fields in the Alarm String Index dialog box
=101 x]

File Edit Translations View Help

DEHEeE|S| 2

Key | Tank_s | FRance =]
HiHi

Level High

Lesvel Low

Lewvel Too High ‘

Lewvel Too Low J

Lo
Lolo
Log file almost full

Logging failure on data.. i
1| | 3

displaysin the Key list. Fead 4

Sep 2. Make CimEdit Text Available for Translation

Sep 2. Make CimEdit Text Available for Tranglation

Y ou add text to CimEdit trandlation files differently from how text is added to Alarm trandlation
files.

Alarm messages are automatically entered into an automatically created trandation file.

First, CimEdit text needs to be selected; second a trandation file has to be created or opened through
the Ambient Properties tab in the Properties - Screen dialog box for the text to be entered into the
file.

This step shows the logical sequence for selecting the text, then adding it to atrandlation file.

Step 2.1 | Select text strings on CimEdit Screens.

Step 2.2 | Automatically enter CimEdit text strings into a translation file.

Sep 2.1. Select Text Srings on CimEdit Screens

Step 2.1. Select Text Strings on CimEdit Screens
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(1) Important: When you design your CimEdit screen make sure that you allow enough space to
accommodate all selected languages for each text string.

For example, amessage that will display isTANK LEVEL ISTOO HIGH.

Space required for different languages varies, asfollows:

Language Text String

Screen Original | TANK LEVEL IS TOO HIGH

French LE NIVEAU DE RESERVOIR EST TROP ELEVE

Chinese Bt

Japanese BHHHRHH I

TANK_S TANK_S LEVEL IS TOO HIGH

Text string tranglation options are as follows.

Option Plain text
2.1.1 (page

69)

Option Text buttons
2.1.2 (page

72)

Option Animated text

2.1.3 (page
74)

Option Expressions
2.1.4 (page
75)

Option Execution condition messages
2.1.5 (page
77)

Option Advanced procedure messages
2.1.6 (page
78)

Option Popup menu items

2.1.7 (page
79)

Option 2.1.1. Plain Text Available for Trandation

1. Place or select atext object that is on a CimEdit screen.

2. Open the text's Properties - Object dialog box.
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3. Select the Text tab.

The following options make the text on the button available for trandation.

| Properties - Object &]

fatan A ISllingL TANE LEVEL
Geomet
Tem ! Anchol pasition: 12 pt 16675 pt
ext
conal B I == Hoiz abgnment Vet alignment
— . / @ L=t @ Top

c I | Translate Certes Center
e D I Mudire Right Botom
Fotation/Fil
Color Animation o I
Tramsparency ety vk

Expression :I »
Ewveril
Scripd Trarubste seaull vk
Narabies
Mot
Procedurnes
[T3 Carcel Aol Help

rect 67, 103, 91, 126 (page 71)
rect 67, 63, 91, 84 (page 70)
rect 67, 83, 91, 103 (page 71)
rect 67, 18, 91, 39 (page 70)

A String
(page
70)
B Font
(page
70)
C Translate
(page
71)
D Multiline
(page
71)
A | String

Text that will display on the CimView screen and can be translated into selected languages.
B | Font

Opens the Font dialog box to select the font, style and size for this string in the CimEdit/
CimView screen.
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i.Frn.' HH-\
Fonk For shyle: Sz | 1
Arial Unicode M5 Boid 1
Auial Uricocs = | [Regan T . =
[} Batang Itshe 12
() Batanglhe CET I (14 [
T BlscklettedsE BT Bold Inshc 16 |
) Book Artigus 18
0 Bookean Did Style 20
0 Bookshelf Spmbel 7 = 2 -
I Emects Sarrgle
Sakmout
U AaBbYyZz

Semgh
WWeclen -

Thhis lonk siyke i miated for the display. The closest matching siver
will be wsed for prnfing,

(D) Important: Select afont that will accommodate the characters for the translated languages.
For example, Arial Unicode MSis avery complete Unicode font.

C | Translate

Checked makes this string available for tranglation.

Default | Checked

D | Multiline

Multilineis checked by default when you create a new text entry.
Options are:

Clear Multiline

Enter text in the String field.

Check Multiline

Do the following.

Stiing: Multiine text. Hit button to Edit ).
Anchor position: 12t T T
) Hoiiz LB :

[ Fort.. | S L:v‘“ R 2
f,,:u{\Tran.s.lals Center
ll\.__J/Mulhhna Fight - -

Click the Text Box button to the right of the String field.

Enter the text in the Text Box.

4. Click Apply or OK.
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|=/ Note: If you want to emit this text selection (or selections) to a CimEdit translation file
before you make other text selections, go to Step 2.2. Otherwise, continue with the Step 2.1
options.

Thetext string is available to be emitted to the trandation file (page 82).

Option 2.1.2. Text Buttons Available for Transation

1. Place or select atext button object that is on a CimEdit screen.
2. Open the text's Properties - Object dialog box.
3. Select Text Button.
The following options make the text on the button available for translation.

| Properies - Object Eﬂj]

Calor _ﬁJStling: Valve In

Geometry

Test Buiton B L Fork... EI Auto size ﬂ | Translate

P ' _E | (ke

Display viskas
Mevement Esgressiorn 5 »
Scabng
FotatienFl Trarlate peaull valee
Color Animation
Tramsparency
Evaity
Serigt Busten eskor T
Wariables & Ciod srarmspe lest
ahenat Cink sramste button lace
Pracedures

(1.3 Carcel Heip

rect 150, 65, 173, 81 (page 73)
rect 231, 45, 254, 67 (page 73)
rect 149, 45, 172, 61 (page 73)
rect 64, 43, 87, 65 (page 73)
rect 63, 19, 86, 41 (page 73)

A String
(page

73)

B Font
(page

73)

C Auto size
(page

73)




@E\U

Translate

@g\l‘l‘l

Multiline

>

String

Stri

=
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ng that will be available for translation

B

Font

Opens the Font dialog box and select the font, style and size for this string in the CimEdit/

CimView screen.

Fonk For shyle:
Al Unicode M5 Boid
|tgd-'e-:rl_1.':r-:t‘-r%._' ~| [Regder
[} Batang Itshe

) Batanglhe Eald

B BlackleteS5 BT Bold nakc

Fest

() Book Artiqus
() Bookenan Olid Style
() Bookshelf Symbel 7~

[ Effect;

Fbeodt
Uradadies:

Thhis lonk siyke i miated for the display. The closest matching siver

vl ey wzed for pmtng.

AaBbYyZz

|=/ Note: Select afont that will accommodate the characters for the translated languages. For
example, Arial Unicode MSis avery complete Unicode font.

Cc

Auto size

It is recommended that you leave Auto size clear.

When checked, the button automatically resizes to fit the text length.

This can create ajagged affect if different languages are used on the CimView screen.

Give the button an exact length that will be able to fit the characters for any of the selected
languages.

D

Translate

Default | Checked

E

Multiline

Checked makes the text string available for translation.
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Multiline is checked by default when you create a new text entry.
Options are:

Clear Multiline

Enter text in the String field.

Check Multiline

Do the following.

String: Mudtiine text. Hit button to E dit 11...]
[ Fort.. | L]Auto size B Text Box ==
[ Muliiine —
2

Closn Carcal

1 | Click the Text Box button to the right of the String field.

2 | Enter the text in the Text Box.

The text entered as the button label is available to be emitted to the selected translation file (page
82).

Option 2.1.3. Animated Text Available for Trandation

1. Create or select atext object; the object will display animated text during runtime.
2. Open the Properties - Object dialog box.
3. Open the Expression List Attribute Animation dialog box.

The following options make animated text available for tranglation.



Alarms and Messages | 6 - CIMPLICITY Language Mapper | 75

ﬂ
Expression | Line| Fill | Test | Font | Biink | Biink Line
TANKLEVEL G, n'a  [TANKLEVELISTOOHGH  ArialUnicode MS B No  nia
TAMKLEVEL G.. r/a [eemTANK LEVEL IS HGH Arial Unicode MS B, No
TAMHLEVEL G... /s [ Tank Level is nosmal Arisl Unicods MS B... Mo
TAMKLEVEL L. ra [T an LEVEL 15 LOW Avrial Unicode MS 6., No
TAMKLEVELL... rs  [TANCLEVELIS TOOLOW  Asial Unicods MS B... No
- Detais
Expression: [ TANKLEVEL GE 50000 Bl [ oo |
e | Ely = | 2| coneel |
F Fit [Soud =] [lr=e =l
I Tet [ Trandate [TAMK LEVEL IS TOD HIGH J l;" / e
I Fonk  [AnslUnicodeMs x| [Bold =l = ]
[~ Bink Birik Heter (7 | v New I
r it | Al i 7] || owas |
I~ BkF | d v| Delets
Option Description
Text Translate
String
Font Selections are

 Font
* Type
* Size

Note: If you make the text available for translation
make sure that the selected font accommodates
the languages in which the string will display. Arial
UNICODE MS can display all languages.

|5) Note: If you want to omit this text selection (or selections) to a CimEdit translation file
before you make other text selections, go to Step 2.2. Otherwise, continue with the Step 2.1

options.

The text that is checked for trandlation is available to be emitted to the selected trandation file. The
text for each expression will display on asingle linein the trandlation file (page 82).

Option 2.1.4. Expressions Available for Tranglation

Option 2.1.4. Expressions Available for Trandation

Option 2.1.4.1
(page 76)

Expression literals

Option 2.1.4.2
(page 76)

Enumeration point values
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Option 2.1.4.1. Expression Literals

1. Place or select atext or text button object that is on a CimEdit screen.
2. Open the text's Properties - Object dialog box.

3. Select one the following depending on the selected object.

Option Tab

Text Text

Text button Text button

4. Enter an expression that contains string literalsin the Expression field.

Example

| F (TANKLEVEL GT 55000) Then "CLOSE Valve In. CALL MANAGER " Else "If
alarmstate, call nanager."

5. Check Trandate result value.

|5/ Note: The default is clear.

Properties - Object

¢ Sting: ATTEMTION

Lol
~ Anchot position: 18p 205pt
Geometry
= i - Hodiz, abigriment Wel, aligriment
—— - @ Left @ Top
. . | Transiate Certet Centes

. ukiire Right Botiom
Seakng
FotatienFa Dicplay value
Cotoranimation. || Expiesgion IF [TANKLEVEL GT 55000 [ [>]
Taampareny Display formst: l[imal [ -

Eveiiti h

¥ Tranclate result value
Scripd

Narabies

Mot

Procesunes

(i3 Carcel Help

Thetext strings are available to be emitted to the selected trandation file. Each string, surrounded by
double-quotes, will be placed on asingle line in the trandation file (page 82).

Option 2.1.4.2. Enumeration Point Values

When you emit text (page 80) for a CimEdit screen al values that have been configured for point
enumerationare automatically entered in the selected trandation file.
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Example

An enumeration set named FLOW is configured to be available for selected pipe points.

Text values are:
x
Genesal |
Description: JP'pe pracedurnes
Value | Test | Setpoint Alowec
0 PIPE: DPEM Tiue
1 PIPE: OPEN 3/4 Tiue
2 PIPE: MAINTAIN Tiue
3 PIPE: CLOSE TO 174 Tiue
1 PIPE: CLOSE \ A
New ||| Boperiss || Deste |

|ux|ma|m]m«o

* PIPE: OPEN

* PIPE: OPEN 3/4

* PIPE: MAINTAIN

* PIPE: CLOSE TO /4
* PIPE: CLOSE

When text is emitted to a selected trandlation file (page 82) the FLOW text values are emitted to
that file.

Option 2.1.5. Execution Condition Messages

Open an Execution Condition dialog box for a:

* Text/text button object
« Slider action

The following options make an execution condition text message available for tranglation.

— Execution condition
Egpession:  |IPIPEFLOW GE 50000 0R (PIPE S| 3|
¥ Display message when dizabled
d‘, Message: ITank flovs is narmal _I

B,
L= ¥ Translate message

Cloze I Cancel Help |
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A | Message String that will be available for translation.

B | Translate message | Checked makes the text string available for translation.

The text entered as the execution condition message is available to be emitted to the selected
trandation file (page 82).

Option 2.1.6. Advanced Procedure Messages Available for Trandation

1. Select the screen or any object that is on a CimEdit screen.

2. Open the screen or object's Properties dialog box.

3. Select Procedures.

4. Open the Procedure Information dialog box for an existing or new procedure.
5. Select the Advanced tab.

6. Check the accompanying Transate... checkbox for text message entries that should be
available for translation, as follows.

Note: The default is checked.

x|
Actione Advanced |
Description: |U:>-enr'close Vahee In =]

™ Halt on emor [# Confim 2l
- Messages

Confirmation: Iljperng or closing Vahve In.
A ¥ Transhate confim message

Success: [ave in was opened or closed
B | Translate success message

Faibue: [\ shve in state did not change
C /¥ Translate falure message

D |Exscution condition
Espression:  [(TANKLEVEL GE 45000AND VAL B >
[ Display message when disabled

| T T

Meszage: I\Iehe state was not changed. _I
¥ Translate message
0k | camest | o | Hep |
Field Check

A | Success | Translate success message

B | Failure Translate failure message




Field

Check

C | Message | Translate message

D | Execution condition
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Thetext strings that are entered in checked message fields is available to be emitted to the translation
file. Each message will display on asinglelinein the trandation file (page 82).

Option 2.1.7. Popup Menu Items Available for Trandlation

These items are available for trandlation:

« Standard Popup menu items

+ Customized Popup menu items

Sandard Popup Menu ltems

CimEdit automatically sends standard Popup menu items to the tranglation file when text is emitted.

Items include:

* Full Screen

* Help

 Menu

* Properties

* Point View

* Point Control Panel
* Quick Trends

Customized Popup Menu ltems

1. Select the screen or any object that is on a CimEdit screen.

2. Open the screen or object's Properties dialog box.

3. Select Menu.

The following options make the text on the Popup menu available for trandation:
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Properties - Screen

[ | Menu Procedure,/Script Paramete
MORTH TANE TANEMORTH [Procedure)

Caolors
Geomeatry
Geners!
Evenis
ambient Praperties
Wanables
Procedunl
‘ " b
Scripd

. Merus test A NORTH TANK
@’ | Translate Merw Test
Action: TAMKNDRTH [Piocedus) = -.?',
Ok Cancel Aol Help

A | String that will be available for translation.

B | Checked makes the text string available
for translation.

Thetext string that is entered in the Menu text field is available to be emitted to the trandation file
(page 82).

Sep 2.2. Automatically Enter CimEdit Text Sringsinto a Map File

Step 2.2. Automatically Enter CimEdit Text Strings into a Trandlation File

Step 2.2.1 | Emit text into a new file.

jpage
80)

Step 2.2.2 | Emit text into an existing file.
(page
83)

Step 2.2.1. Emit Text into aNew File

Follow this procedure if you are starting a Language Mapping file for your CimEdit screens or want
to create afile exclusively for the screen you are working on.

1. Right-click the CimEdit screen to open the Properties- Screen dialog box.
2. Select the Ambient Properties tab.

3. Do thefollowing:
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[ Properties - Screen é
Cotory Fomcokr [l Wedeies =]
Geometny Backcokr ||| Windowr =]

General
Fort
Evenis

ambient Properties || T2t Translation

 Vacabte Map File: C:\Program Fies\Proficy\Profic A ..
Frocedures Eﬂ Fh ] _B]El'ﬂi. TM ]
Seript
Mbenus [
ok [ Cowe | [ Aok |[ Hep

rect 249, 120, 267, 141 (page 81)
rect 293, 98, 319, 119 (page 81)

A | Map File

Enter the path and name of anew file that you want to have created.

© Tip: TheBrowser button to the right of the Map File field will help you specify the name
and exact location.

a. Click the Browser button to the right of the Map File field.

A Pick aCIMPLICITY Language Map file browser opens.

b. Find the folder in which the file should be created.
c. Enter thefilename in the File namefield.

d. Click Open.
2

Look it | ‘3 TRANSLATE =] « B B

-
Cldata
B dsrreiTranelation. cln

Flename:  [TANKTisnlate.cin <] o]

Fiex of iype: [ Language Map fles [~ cin] =] Caneel |/
%

B | Emit Text

Click Emit Text.

Result:
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a. CIMPLICITY Language Mapper creates the specified trandation <filename>.clm in the

CECEO——
Fle Edt Wew Favortes Tools Help \
Queewrcn Y, 13 B @ T X - ) Geek -
Address | ] gram Files\GE FanuciProficy CIMPLICITY\projects\TRANSLATE
Folders o Mame l
== TRANSLATE a Qdarm_heb

7 alarm_help [Jarc
(0 data Cllock
] lock Cleg
g Cenaster
1 master Clscreens
} .:I SCreens :]scr'pts |
2] seripts B :tarmTranslation.cm I'.
(1 publishSubseribeDelvery 1 BETANKTRANSLATE.CLM |
. 3 ren (] TRANSLATE gef
selected location. (o \

b. CIMPLICITY Language Mapper exports the selected CimEdit text into the selected

TANKETRANSLATE.CLM - CIMPLICITY Language
fle E@ Trsnsiotions Mew Help
Dedl ) »ex|& 2
Key |

7 JaMenn
\?.(&Pmﬂﬂ'ﬁas
TTENTION
= ‘::::Id more waker
CALL FLOW MANAGER
CALL TANK SUPERVISOR
CHINESE
CLOSE Valve In, CALL MANAGER.
Clased
ENGLISH
FRENCH
4 i sisrmn state, cal EANAGET.
JAPAMESE
LEVEL
MAIN PLANT
T MORTH TANK
Cpen
Open Tank Vashve
6 Opening or closing Vahe In
\‘PIPE: CLOSE
PIPE: CLOSE TO 144
PIPE: MAINTAIN
PIPE: OPEN
PIPE: OFEN 34
Poirk view
Poirt Corfrol Panel
Quick Trends:
1 TANKLEVEL
TANE LEVEL IS HIGH
TAMK LEVEL IS LOW
3 TANK LEVEL IS TOO HIGH
11'»« LEVEL IS TOO LOW

TANK LEVEL STATUS

=101 %]

{ =

3 Tank Level iz normal

\"‘TWS&MOW
Mahve In =
Wahee In state did not change.
Wahee In was opened or closed -
\14I | L|J
trandation file. Fesdr il
1 Plain text

(page
69)




2 Text buttons

(page

72)

3 Animated text

(page

74)

4 Expressions

(page

75)

5 Execution condition messages
(page

77)

6 Advanced procedure messages
(page

78)

7 Popup menu items

(page

79)
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© Tip: If you have several screenswith unique static text performance may be improved
if you use several trandation files among your screensinstead of just one.

Step 2.2.2. Emit Text into an Existing File

Use this procedure if you want to continue working in an existing tranglation file in order to share it
with two or more of your CimEdit screens.

This enables sharing of common strings and makes tranglation for all screens the easiest to maintain.

1. Right-click the CimEdit screen to open the Properties- Screen dialog box.

2. Select Ambient Properties.

3.

Do one of the following:

Properties - Screen =X
Cotory Fomcokr [l Wedeies =]
f'umljlr Backcokr ||| Windowr =]

Fort
Evenis

Ambient Froperties Text Translation

Vacisises Map File: C:\Program Files\Proficy\Proficy [ [...|
Frocedu EditFle | | EmitTest
Serigd - " B
et

K. Cancel Appls Helps

* Type in path and trandation filename
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Test Tianslaton
Map Fie: (A) C:\Program Files\GE Fanuc\Froli ()

[ EdiFie | B) EmtTen

A | Enter the path and name of an existing file in the Map File field.

B | Click Emit Text.

» Find and select atrandation file

Teut Trarelation

Map File:
[ EdeFie | [ Emt

a. Click the Browser button to the right of the Map Filefield.

A Pick aCIMPLICITY Language Map file browser opens.

b. Select the file you want to use.
c. Click Open.

Pick a CIMPLICITY Language Map file 2
Look in: | ) TRANSLATE i el e s =
) alarm_help () screens
[ arc () scripts
ydata Bl atsrmTransistion. cim
lock TAMETRAMNSLATE.CLM
log
) master
Filepame:  [TANKTRANSLATE CLM gpen |
Files of type: [ Language Map fies (*.cim) | Cancel |

The select path and name display in the Map Filefield.

d. Click Emit Text.
« Emit text without entering a path

Test Trarelation
Map File: C

[ EdtFie | [ _EmtTen

R

a. Click Emit Text without entering a path and name in the Map File field.

Pick aCIMPLICITY Language Map file when the browser opens.

b. Select the file you want to use.
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The select path and name display in the Map Filefield.
c. Click Emit Text.

The text strings on the CimEdit screen that are checked for translation are created as keysin the
selected trandlation file.

If the key isalready in thefile, it is not overwritten. Thisis particularly important because the
existing key may already have associated translated strings.

-Iaix]
Fila Edt Trandlstions Wiew Help
DS rRw | &
Key | Tank_s | FRance | crina | Jepan =
CLOSE Valve In. CALL MANS,
Chiped Chaad Fsmivk = -
¥ siorm stote, coll manager.
LEVEL A
NORTH TANE J
Open Opeén Ouredr] [ =] B
Open Tank Valve O Tark_S vl Ounrez L Vishos De Réz. LR Aanddbitews
Qpening or closing Valve In
Poind Siiew Poark Vo Wue D Poird sl oy L
Point Cortrol Pared Port Control Panel  Pannesu De Commande R oy Pl ] | S5
Gk Trends Crack Treaas Tandanoss Rapedas E£EAT HLEE
TAMNK LEVEL
TANE LEWEL IS HIGH TAM S LEVEL LE MIVEAL DE RESERY. e e FADAYSTHES
TANK LEVEL IS LOW TA j LEVEL LE NIVEAU DE RESERV. PR P Y ESTNES
TAME LEWEL IS TOD HIGH TANK_S LEVEL LE NIVEAL DE RESERY. ThEE R AN IYSTHESLD
TANK LEVEL IS TOO LOW TANK_Z LEVEL LE NIVEAU DE RESERY. RN HONDSYSTHES L
TANK LEVEL STATUS TANK_S LEVEL STATUT DE NIVEAL DE..  qiege-faag O
Tark Level iz noemesl Tank:_5 Lenvw ke Le rirvead) de réservor 8. PR RO OO Y ST N -
4| L |
Ready [ | &
A | New keys from text strings in current CimEdit screen that are not already in the translation file.
B | Keys from text strings from a previous CimEdit screen, already translated.

Note:

* You can select the default AlarmTranslation.clm. However, if you anticipate that there will be
several strings, or unique strings it may be more efficient to use a different trandation file for
your CimEdit/CimView screens. If you create an AMV Control on a CImEdit/CimView screen,
you can copy strings, such as headings, buttons, from other CimEdit screens. Y ou can also copy
keys and trandlations from one tranglation file to another.

« If the source screen for alinked object has a trandation file configured it will use that file at
runtime, instead of the file defined in the destination screen. If both screens use the samefile,
thisis not an issue.
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Sep 3. Trandate Keys into other Languages or other
English Strings

Sep 3. Trandate Keys into other Languages or other English Srings

Step 3.1 | Open the CIMPLICITY Language Mapper window.

Step 3.2 | Select a translation file.

Step 3.3 | Select a font.

Step 3.4 | Select languages or other English strings.

Step 3.5 | Translate keys that should display in selected languages.

(1) Important: Alarm messages are loaded only when the Alarm Manager Resident Process
(AMRP) starts. Therefore any configuration changes, e.g. a new translation, made after the AMRP
start up will not show up in the Alarm Viewer. Y ou will have to stop the AMRP and restart it for
changes to take affect.

Sep 3.1. Open the CIMPLICITY Language Mapper Window

Do one of the following:

* Open the CIMPLICITY Language Mapper Window through the Workbench (page 64).

This method automatically opens the default AlarmTranglation.clm file.
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I:LH AlarmTranslation.clm - CIMPLCITY Language Mapper (= | B |t

lnl‘m Translations  View Halp

DM 2w & ¢

Key -
#1

X x2

H1 X2 X3 %45

%1 %2 enceeds %3 and is in %4,

%1 lailed delivery of file %2

%1 is $STATE. Levelis %2 %3,

2lis 222324

2l %2-%3

21 s B2, 23 in queus.

%11 %2 %3 COOLMORTH: %4 LEVELRMORTH iz %5
%1is %2 Heatis %3

%11 %2 Heat iz %3 %4,

%1 e X2 Levelis X3 %4

%1 s %2, Levelis %3 %4,

%1is %2 Rate is %3 %4,

#1is %2 Tempis %3 %4

1 is %2, Temp. is 53,

m

1 ki %2 -
Bl Mo rms e A an® mmie e A e
o L] L}
Feady é|
L o

* Click Edit File on the Ambient Properties tab in CimEdit's Properties - Screen dialog box.

This method will open a selected *.cim file.

Properties - Soreen

elars Fose cokor Window lest -
Geometry
[Back color i Yindow -
General p
Fort.

Events

[A-mnw-] Text Translation

r— Map File: C:\Progiam Files\GE FanuciProfi [
oo Edifie | [ EmtTet |
Soripd .
Bebenas

[ Corcel Aoghy Help

Sep 3.2. Slect a Trandation File

Do any of the following:

* Use the default trandation file.

* Create anew file.

» Open an existing trandation file.
« Save the open file as another file.
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Use the default trandation file

When you open the CIMPLICITY Language Mapper window, the default trandation file,

alarmtransglation.clm, is loaded.

AlarmTranslation.clm - CIMPLICITY

=0l ]

failed delivery of file %2,

%1 of the redundant pair iz down

Comm enor or denamic dizable, device: %1
Event %1 Action %2 ignored

Failing over to redundant device 31

| GENSELLIPD 2 4G LOG TIME %3

Thefileisavailable for editing translation keys and specifications.

Create a new file

Do one of the following.

* Click the New button E on the CIMPLICITY Language Mapper window toolbar.
* Click File>New on the CIMPLICITY Language Mapper window menu

untitled - CIMPLICITY Language Mappe

=101 x|

_Be jt  Translations View Help
DEE|=e%|& 2
| Key |

bar, Rexdr Z

Result: A new untitled file opens ready for translation configuration.

(1) Important: If you are configuring a host redundant system, make sure the file islocated in the
same place on both computers or use a static path for the filename.

If you do not do this and the directory structures are not the same on both computers, the tranglation

file will not be found by CimView.
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Open an existing tranglation file

1. Do one of the follwing.

* Click the Open button on the CIMPLICITY Language Mapper window toolbar.
* Click File>Open on the CIMPLICITY Language Mapper window menu bar.
An Open dialog box opens.

2. Select the *.cIm file that you want to open.

3. Click Open.

20
Look je [ £ TRANSLATE x| « B c¥ E-
| alarm_help () screens
|_arc ) seripts
ydata .Na(mTrmslatim_clm
Jlock TANKTRANSLATE. CLM
_Dlog
) masher
Filepame:  [TANKTRANSLATE.CLM Open |
Files of lype: |Lang.,tage Map [".clm) =l Canicel |/

e

The selected file displaysin the CIMPLICITY Language Mapper window.

Save the open file as another file

1. Open the file you want to save as another file.

2. Click File>Save as on the CIMPLICITY Language Mapper window menu bar.
A Save as dialog box opens.

3. Enter afile name in the folder where you want the file to be located.

20
Savejn | ) TRANSLATE x| = Bk E-
| alarm_help () screens
| arc () scripts
ldata .Na(mTrmslatim_clm
lock .TMKTRRNSLATE.CLM
_Dlog
) masher
Fiensme:  [TANKLEVEL chn @l Save I
Save az lype: |Lang.,tage Map (".clm) =l Canicel |/
e

4. Click the Save button.
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The CIMPLICITY Language Mapper window displays the new saved as

TANKLEYEL.clm - CIMPLICITY Languag

Eile Translations  wiew Help

=101 %]

=l e |87

F.ey I

%2 23 %4%5

failed delivery of file %2,
1 of the redundant pair iz do...
CALL TAMKE SUPERVISOR
Comm eror or dynamic dizable...
Ewent &1 Action %2 ignored

file. Lo

Sep 3.3. Slect a Font

1. Click Edit>Select Font on the CIMPLICITY Language Mapper window menu bar.

TAMNKTRANSLATE.CLM - CIMPLICITY

Edit Translations Yiew Help
D Select Font.. 4 ?

| Key Cut Chrl+3%
Quiick Copy Chrl+C
TAMK  Easte CErl4+-y
TANE  Delete Ctrl+D
TAN

TANK LEVEL 15 TOOC LOW
TANK LEVEL STATUS
Tank Lewel is normal

Tank in Morth Buiding
Trinnar SAmart Chisrt

Ready

=g x|

N | ﬂ

The Font dialog box opens.

2. Select afont that will accommodate all of the languages you plan to use.

@ Important: If you select afont that cannot be used in alanguage you select, the words will

not display correctly.

Any UNICODE font, e.g. Ariadl UNICODE MS, can be used for all languages.

_ 21

Font style: Sizer

|@m|a Unicode s < [Regular e [ ok ]

() @drial Uricode M5 | [Fegular 8 -

0 Lial liake 9 Cencel I

) Adial Black Bold 10

) Auial Manow Bold Itakc n

) Adial Unicode MS 12

() Book Antiqua
O Bookman Ok Side |

-Effects- | [~ Sample-
’L:;*— e —
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Arial UNICODE M Sfont selected

TANETRANSLATE.CLM - CIMPLICITY Language Mapper
File Edit Translstions View Help

DSH »ReX| & P

Key | Tanics | FRance | crina |vapan |
Open Open Ouivert ==} Eou §
Operi Tank: Valve Opan Tank_5 walve Ouvrez La Valve De Réz... SHOET Foddbnd
Opening or closing Yahve In, Opening or closing S0U...  Valve dowerture ou def.. SHEREKESEC BEvs /IHE!,
Pint S\iew Poink Views Ve De Poirt Er T By oLde
Pt Corfrol Panel Poirt Corfrol Pane! Pannesu De Commande .. eRERE By oL
QuickTrends GQuick Trends Tendances Rapides ERAE HOEE
TAME LEWEL SOUTH™ Ao YXLEVEL NIVEAUL B SERVOIR TR R C ﬂ,\M!é\\
TAMK LEVEL I5 HIGH TAMK 't EL IS HIGH  LE NIVEAbet RESERV w\-ﬂ’ HATAY S

A | English keys.

B | Romance languages display correctly.

C | Multi-byte Asian languages display correctly.

Times New Roman font selected

TANETRANSLATE.CLM - CIMPLICITY Language Mapper ]
File Edit Translstions View Help

[DSHE & 2REX| & T

Key | TaNE S | FRANCE | cHINA | 1APAN
Orpen Tank Valve Open Tank 5 valve Cryvrez La Walve De Riéser.. 000000 ooooooar
Opering or closing Valve In. Opening or closing S0UT...  Valve Sowrerture cude fox.,. 000000000  0O0DOOOOO
Point & Viewr Point View hee De Point ooo ooooog
Peint Central Panel Poind Central Panel Panmes De Commande .. 0000 ooooooo
Oick Trends Oraick Trends Tendwsces Rapides oooo oooo
TANK LEVEL SOUTH TANE LEVEL NIVEAU DE RESERVOIR oooo oooooo 1'
TANEK LEVEL I HIGH TAHI:_S'A"ELISHI:GH LEIIWE.!'E 'ERIfSERV... oooooo ooOooooaoy
TANEK LEVEL IS LOW TANE S_JELISLOW _ LENIVEA_.£RESERY.. 000000 ./ 0OODOOOOL
e S -

A | English keys.

B | Romance languages display correctly.

C | Multi-byte Asian languages do not display.

Sep 3.4. Select Languages or other English Strings

1. Click Trandlations>Language Editor... on the CIMPLICITY Language Mapper window menu
bar.
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TANKTRANSLATE.CLM - CIMPLICITY L3 - ||:||i|

File Edit Translations Yiew Help

DE @ k..
Transiation Editor, ..

[ Key  Language Edior. ]

Point S iew

Point Contral Panel

Guick Trends

TAMNK LEWEL IS LWl

TAME LEVEL 15 TOO HIGH!

T!ihll( ILFWEL 1% T 1 ol
4

LT I_L

Ready

The Language Editor window opens.

Language Editor x|

Mame | Locale ID |

Delete

(oo ]

%

2. Click Add.
The Add Language dialog box opens.

3. Make entries as follows.
i

A Language: ICHINA | Ok I
B Locale ID: IChineae (PRC) ([0x804) j Cancel |

A | Language | Enter a label that identifies the selected locale.

B | Local ID Select the language/dialect that the label identifies in the drop-down list.

4. Click OK.
Y our selection displays in the Language Editor list.

5. Repeat the procedure until al of the required languages are listed.
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Mame | Locale D |
TANK_S 409

FRANCE 40c

CHIMA 804 4
JAPAN 411

[ooe ]

Delete

6. Click Done.

The Language Editor window closes. The selected locales head columnsin the CIMPLICITY
Language Mapper window and are available for tranglation.

_iixi
File Edit Translations Wiew Help

DEE =R &)

Key | Tamk s | Framce | crime | aspan | <]
Point Contral Panel

Guick Trends

TAMK LEWEL

TAME LEVEL 1S HIGH

TAME LEVEL 15 L

TAME LEVEL 1S TOO HIGH

TAMK LEVEL 15 TOO L

TAMK LEWVEL STATUS
Tank Leweliz notmal

v

Sep 3.5. Trandate Keys that should Display in Selected Languages

1. Do one of the following:
* Double-click akey.

* Click Trandations> Trandlation Editor... on the CIMPLICITY Language Mapper menu

TANKETRANSLATE.CLM - CIMPLICITY Language P

File Edit Translations Wwiew Help

=10l ]

DE il | Add Mew Key...

Translation Editor, 4
Key

[ -l

FRANCE | CHINA | Japan

Language Editor...
TAMK LEWEL

TAME LEVEL 15 HIGH

TARE LEVEL 15 L
TAMK LEVEL 1S TOO HIGH
TAMK LEVEL 15 TOO Lo

bar Ready

[ I N .

=
[ M| 4

The Tranglation Editor window opens for the selected key.
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Selected languages (page 91) are available for trand ation.

2. Double-click alanguage.
A Trandlated Text Editor dialog box opens for the selected language.

3. Enter the string that you want to display when the text should display in the selected language.

|5/ Note:

* The text may display on a CimEdit/CimView screen or in the Alarm Viewer.
 The Text Editor accepts multi-line entries.

Il FRENCH (FR) - Translated Text Editor = n]ll
ATTENTION )
APPELEZ LE DIRECTEUR [FECOULEMENT
0K I Cancel
4. Click OK.

5. Repeat the procedure for all the languages you want to include in the tranglation.
The trandated strings display in the Trandation Editor window.

TronslationEditor x|
Key: |uu.|. FLOW MANAGER
Language | Transiation
TANK_S CALL TANK_S FLOW MGR
FREMCH (FR) ATTENTIONCIOAPPELEZ LE DIRECTEUR C'ECOL
CHINESE (PRC) &iFER
JAFANESE REnOT Y —ERUEEL
Ll | 1|
Done I Ed#t |

6. Close the Trand ation Editor window.

7. Continue tranglating all of the strings that should by displayed in multiple languages.

The strings display in the language columnsin the CIMPLICITY Language Mapper window.
At runtime, when the tranglation file is used, the string entered for the selected runtime language

displays.
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Sep 4. Work with Keysin a Trandation File

Sep 4. Work with Keysin a Trandation File

Option Add a new key manually.

4.1 (page
95)

Option Copy and paste keys.
4.2 (page

96)
Opt
43

ion Delete keys.
age

98)

Option 4.1. Add a New Key Manually to a Trandation File

1. Click Trandations> Add New Key... onthe CIMPLICITY Language Mapper window menu
bar.

TANKTRANSLATE.CLM - CIMPLICITY Language Map - 10| x|

File Edit Translations WYiew Help

W add Ne@ Kev._.. 4 |
Translation Editor. ..

[ Key  anguageEdor... FRANCE | CHINA | Japan | =]

TANK LEVEL

TANK LEVEL IS HIGH

TAMK LEVEL IS LOW =l

TAMK LEWEL IS5 TOO HIGH

TANK LEWEL 15 TOO LS LI

Ready [ |
The New Key dialog box opens.

2. Enter akey that you will want to trandlate.
hewkey x|

Cloge Tank Valwe when the alarm is in Warning High,
Wihen the alarm iz High High, call the supervisor.

| oK I Cancel

|5/ Note:

* Thiskey can be used for alarms and on CimEdit/CimView screens.
* The key can be multi-line.
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3. Click OK.
The key is added to the file that is open in the CIMPLICITY Language Mapper window.

TANKTRANSLATE.CLM - CIMPLICITY Language Mapper -0 x|

Fil= Edt Translations ¥ew Help
DEed 2R | & T
Key | Tamk s | FRancE | cHina |aspan | &

Valve Instate o ot changs,  SOUTH .. Lavalver,. @B, RO
Valve Inwas opened or closed, SOUTH .. Lavalve . &R, #7M.

Wabve Out Wahes it Vahes deh,., @810 &
Walve state did not change, SOUTH .. L'éstdel.. &M ROW.
Cioze Tank Walve when the ala... j
-
MNUM 5

Option 4.2. Copy and Paste Keysin a Trandation File

Option 4.2. Copy and Paste Keysin a Trandation File

Option Copy and paste a key from another translation file.
4.2.1 (page

Option Copy and paste a key in the same translation file

(1) Important: You can paste copied keys to a mapper file opened ina CIMPLICTY Language
Mapper window. However, pasting keys into a different program, e.g. Notepad, is not supported.

Option 4.2.1. Copy and Paste a Key from another Trandation File

1. Open the key's sourcefile.
2. Select one or more keys.

|5) Note: Hold down Shift for adjacent keys and Ctr| for scattered

AlarmTranslation.clm - CIMPLICITY Language Mapper - |I:I|£|
Fle Edt Translations View Help

DEM 2Ry 8 %

Key | Tamk_s | FRancE | chma  [aspan | 4]
L T AT W A
CALL FLOW MANAGER CALLTAMK_S. APPELEZLED.. 4IEURuRl IMeobic. =h
CALL TANK SUPERVISOR CALLTANK_S.. APPELEZLES. 4I¥Goal. HAOKI.. )
ORI T O T e
keys. Lo

3. Do one of the following.
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* Click the Copy button onthe CIMPLICITY Language Mapper window toolbar.
* Click Edit>Copy on the CIMPLICITY Language Mapper window menu bar.
* Press Ctrl|+C on the keyboard.

4. Open the key's target file.

TANKTRANSLATE.CLM - CIMPLICITY Language Mapper - ﬂlﬂ

D |¥'ﬁﬂl‘¥|§|?

Key | Tan_s | FRanCE | china | aapan |4l
Closed Closed Fermé EQ Ewou

If alarm stafe, call manager, if adarm stale, ¢ Silélal dalarme,.. BEERET . EEEER J
LEVEL LEVEL HIVEAL s Ay

HORTH TANK RESERVOIRD.. i B

. —

5. Do one of the following:

* Click the Paste button E onthe CIMPLICITY Language Mapper window toolbar.
* Click Edit>Paste on the CIMPLICITY Language Mapper window menu bar.
* Press Ctrl+V on the keyboard.

The key with any associated trandations is pasted into the target file.

TANETRANSLATE.CLM - CIMPLICITY Language Mapper o [=] S

= Edt Translations Wiew Help
(DS & 2Rw & 2

| papy
T

CALL FLOW MANMAGER CALL TAMK_S.. APPELEZ LEDI. 4rispns iRmcbt.

CALL TANK SUPERVISOR CALL TAMK_S5.. APPELEZLES..

Cloze Tank Vahve

i

Option 4.2.2. Copy and Paste aKey in the Same Trandation File

1. Select akey that you want to copy and paste.

TANETRANSLATE.CLM - CIMPLICITY Language Mapper =10] x|
Eile Translstions Yiew Help
DEH s BX &7
Key | Tank_s | France | cHins, [gapan | <]
......... SErHTH TANK———HREAHEERE— s o et
.‘r.a.ux LEVEL IS HIGH TANK_S LEVE.. LE NIVEAU aE m% m,\r\_w

Tank Level iz normal Tar'k S Leweli,.  Leniveau de ré,. mﬁ-ﬁﬂ %‘\(\_\t’...
TANK LEVEL IS TOO HIGH TAMNK_S LEVE... LE MIVEAL DE FEREHEE..  MonaY ll

Ready I e [

2. Do one of the following:

* Click the Copy button onthe CIMPLICITY Language Mapper window toolbar.
* Click Edit>Copy on the CIMPLICITY Language Mapper window menu bar.
* Press Ctrl|+C on the keyboard.
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3. Do one of the following:

* Click the Paste button E onthe CIMPLICITY Language Mapper window toolbar.

* Click Edit>Paste on the CIMPLICITY Language Mapper window menu bar.
* Press Ctrl+V on the keyboard.

The key with associated translations is pasted into the list with an _n tag to differentiate it from the

copied key. Y ou can copy and paste as many times as you want. The _n value corresponds to the
key's position in the copy/paste sequence.

TANETRANSLATE.CLM - CIMPLICITY Language Mapper

=10] |
Translations ‘iew Help
s BX & T
Key | Tanic_s | France [ crima  [usean | =]

R g TIER

TANK LEVEL I5 HIGH TANK_S LEVE

.. LE MIVEAU DE ...
TaNK LEVEL I3 HIGH_1 TANK_S LEVE LE MIVEAL DE RS MooOoY
Tank Level iz normal Tank 5 Leweli.,

. I.en'rusauderé..... el {’ﬁa\(\_\t’.:: ;I
Ready ' —

Option 4.3. Delete a Key ina Trandation File

1. Open the key's sourcefile.

2. Select one or more keysto delete (use the Ctrl or Shift keysto select more than oneline).

File Edit Translations Wiew Help

NEE s B% &7

Key | Tk s | FrancE |
Open Tank Valve Open Tank__S .. Ouvrez La valv.. &
OPEN vaLVE oUT ]
Opening gielosing Yalve In. Opening or clog...  Yalve douveru.. 1
Poird Sie Point Wiew Yue De Paint E

Point Contral Panel

Point Cortral P...  Panneau De Co...
Ready

3. Do one of the following:
Cut the selected lines

a. Either:

* Click the Cut button E on the CIMPLICITY Language Mapper window toolbar.
* Click Edit>Cut on the CIMPLICITY Language Mapper window menu bar.
A message displays asking you to confirm if you want to delete thefile.



b.

CIMPLICITY Language Mapper

@ Are wou sure that vou want bo delete the selected keys?

Yes Mo
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X

Click Yes.

TANKTRANSLATE.CLM - CIMPLICITY Language Mapper l

Eile Edit Translations Wiew Help
DEd f=2ex S| 2 t
Key S 2 [emk s | FrRancE | ¢

Open Tank WValve Open Tank__5 .. Ouvrez Lavalv... 1B
EOpening ot closing Valve In. Opening or clos. . Valve d'ouvertu. m
Poirt &0 Tew Poirt Wiew Yue De Paint lé
Pairt Cortrol Panel Point Cortrol P...  Panneau De Co...  ME
Quick Trends Quiick Trends Tendances Rap... ﬂi}

Ready

1

The selections are cut from the file.

2

If you change your mind you can paste them back.

Method 2: Delete the selected lines

a. Either:

* Click the Delete button E on the CIMPLICITY Language Mapper window toolbar.
* Click Edit>Delete on the CIMPLICITY Language Mapper window menu bar.
A message displays asking you to confirm if you want to delete thefile.

CIMPLICITY Language Mapper

@ Are you sure that vou want ko delete the selected keys?

b

Yes Mo

]

. Click Yes.
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TANKTRANSLATE.CLM - CIMPLICITY Language Mapper |

File Edit Translations Wiew Help |

D $=2RX (8| ?)

-
Key 2\ Tank_s | France | cf
Open Tank Valve Open Tank_S ... Ouvrez La Valv.. &
EOpening or clasing Valve In. Opening or clog...  Yalve douvertu... &
Point S\ Point Wiew Yue De Paint n
Point Contral Panel Point Cortrol P...  Panneau De Co.. 40
Cuick Trends Cuick Trends Tendances Rap... #

Ready \

1 | The selections are deleted from the file.

2 | You cannot paste them back.

4. Save the trandlation file.

The selected keys are del eted.

Sep 5. Print a Trandation File Configuration

Sep 5. Print a Trandlation File Configuration

Step 5.1 | Preview the printed file.
(page

Step 5.2 | Print the translation file configuration.

Sep 5.1. Preview the Printed File

1. Click File>Print Preview on the CIMPLICITY Language Mapper window menu bar.
A preview of the printed document opens in a Print Preview window.
|=/ Note: The preview will display either one or two pages, depending on the display the last
time the Print Preview window was closed.

2. The Print Preview window is as follows.
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Alarm Translation clm - CIMPLICITY Lanmuage Mapper
—
Print.. Hmdpaw| Pwrl’awl One Pags

TANKTronslote clm - CIMPLICITY Language

Pirk. | HestPage | FievPoce || =
TEpaoT
"Takk LEVEL IS HIGH
*LE NIVEAL DE RESERVDIR EST ELEVE™
" LAl L
TEREAT RS
"EL NIVEL DEL TANGUE ES ALTCF
*Tare LEVEL IS LOW
*LE NIVEAL DE RESERVOIR EST BAS
D Y7Ll
SR BT
“EL NIVEL DEL TANQUE ES BaCr
"TAMNK LEVEL |3 NORMAL®
"LE NIVEAL DE RESERVDIR EST NORMAL
S LAILAERTED"
AT RERE
"EL NIVEL DEL TANCLUE ES NCRMAL®
"TaMK LEVEL STATUS .
"STATUT DE MVEAL DE RESERVOIR®
Pages 2-3 R RFRRT
= TEER RN
*ESTADD LLAND DEL TANDUE *
"TaMK TEMP IS HIGH"

A | Title bar Displays the translation file that is being previewed.
B | Toolbar Print the document.
Print
Next Page Enabled when there is a next page to display.
Previous Page Enabled when there is a previous page to display.
One Page/Two One Page displays during a two-page display; two page displays during a one-page
Page display.
Zoom In Magnifies the preview to make the text legible; has a two-click magnification.
Zoom Out Returns the preview to display the entire page in the window.
Close Closes the Print Preview window.
C | Two-page display in Print Preview window.
D | Print preview zoomed in; The key displays with the translated strings listed underneath.

3. Close the window when you have finished using it.

|=) Note: If you need to change the printer setup, e.g. your setup is set to landscape orientation
and you want portrait, close the Print Preview window and click File>Print Setup on the
CIMPLICITY Language Mapper window menu bar.

The Print Setup dialog box will open for setup changes.
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Sep 5.2. Print the Trandation File Configuration

1. Click File>Print on the CIMPLICITY Language Mapper window menu bar.
The Print dialog box opens.
2. Optional: Make any changes to the print setup.

3. Print the document.

4. Close the Print dialog box.

Sep 6. Configure Translation Options for Runtime

Sep 6. Configure Trandation Options for Runtime

Step 6.1 | Configure translation options for CimView users.
(page
102)

Step 6.2 | Configure for Alarm Viewer control use.
(page
106)

Sep 6.1. Configure Trandation Options for CimView Users
Step 6.1. Configure Trandation Options for CimView Users

The CIMPLICITY Language Mapper provides you with an Object Model. Y ou can use the objects,
properties and methods to create scripts that determine translation options.

A simple way to enable CimView users to change languages or English text strings during runtimeis
to create a button for each language you want to substitute.

Step 6.1.1 | Configure buttons to change languages or English strings.

gpage
102)

Step 6.1.2 | Test your translations in CimView.
(page
104)

Step 6.1.1. Configure Buttons to Change Languages or English Strings
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1. Open a CimEdit screen that has been configured for translation.

2. Place a button on the screen.

g 2 ) " T o - Comilit

ey
— TANK LEVEL LIV —_—
ap -
)l'

ke In I Vibvw Dt

ATTENTION

TANK LEVEL STATUS ¥

3. Open the button's Properties - Object dialog box.

4. Label the button (page 72) to notify a user what language or English string the CimView
text will change to.

|5) Note: Check Translate if you want the button label to be emitted to the translation file.

[ Properties - Obzect e |
cotons Shing: FRENCH [
Seametn ' I Font.. | | Auito size [¥] Translate
Test Button i Mudtiine
General Display value

Mbzvement Esprassion =~
Scabng

Botation/Fil Transiste send vabo

Color Animation

Tramsparency

Everiti
Script Buion color DW—.
@ Color arimste et
Codor arimate button face

5. Create a MouseUp event:
a. Select the Events tab.
b. Select aMouseUp event.
c. Click the Popup button to the right of the Action field to open an Edit Script window.

d. Create a new script as the action for the mouse up event as follows.

Sub OnMouseUp(x As Long, y As Long, flags As Long)
Ci mCGet Screen. Appl i cation. Language = "String Description"
End Sub



Alarms and Messages | 6 - CIMPLICITY Language Mapper | 104

Where

The"string Description" isthe selected language, entered exactly asit isidentified in
the CIMPLICITY Language Mapper window.

If the entry is not exactly the same, the default language will display instead of the selected
language.
1ol

Fil=  Edit Translationz Wiew Help

DEE sBRX &7

ey | Tk s | FrancE -
&Help &Help Albjde =
Ahenu [ [

&Properties Properties Proprigtés
ATTERTION ATTERTION ATTERTION

=0l x|

File Edit WYew Tools Help

a Sub OnMouseUp{x As Long, Yy As Long, flags W5 Long) -
CimGetScreen.Application.Language = "FRANCE"

2 cimGetScreen.Refresh

4 || End Sub

3[3 -

]| R _>I_I

For Help, press F1 n 7Cal 42 [1dle  [Com

e. Compile the script and close the Edit Script window.

6. Close the text button's Properties dialog box.
7. Continue to create buttons until you have created as many as the screen should have.

0 Tip: If you are configuring a screen with buttons to change languages, add a button that
enables the operator to re-select the default language after another language is selected.

Example

If English isthe default language, add an English button. Y ou do not need to create a column in
the trandation file. If there is no entry, the default language displays.

8. Optional: Emit the text labels (page 80) on the text buttons and translate them in the
trandation file selected for the screen.

Step 6.1.2. Test your Screen Tranglationsin CimView

Click the Runtime button J on the CimEdit toolbar.



& Tank.cim® - CimEdit =101 x|
Fie Edt Mew Fomet Tools Frame  Help

DSHE L@« | & BE® .|

TAMNK LEVEL LEVEL
ENGLISH

FRENCH |

Viahe In Vialve Qut | TANK S |

ATTENTION
TANE LEVEL STATUS

Starts CimiView with the current state of the screen. 264, 2

Results
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» The CimView screen displaysin the default language.

M

TAMNE LEVEL 35000

_l

‘Walve Out I TAME &

If alarm state. call manager.

Tank Level is normal

Far Help, press F1L -

* Entriesin the CIMPLICITY Language Mapper display for alanguage display when its button is

clicked.

..JDJ_I

35000
EANR EANzA I TANK §

HNEWERE HwWEn,
AERFRETH

For Help, press F1 v
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« Alternative text inthe CIMPLICITY Language Mapper for the default or any language,
displays when its button is clicked.

«u. Tank.cim

* Popup menu items display in the selected language when the Popup is opened, if they have been
trandated in the CIMPLICITY Language Mapper.

L5 Tankaim ~=Iofx|

File \iew Help
MI¥EAU DE RESERVOIR 35000
ANGLAIS |
FRANCAS
Meru
Piein Ecran
Valwe dedans Walve deh E

Wise De Point
Si Iétat d'alaime, appellent [T Pannesu De Commande De Point
Le nivean de réservoir est nom [ Tendonces Rapides

E& Propriétés

RESERVOIR DU NORD

Far Help, prass F1

Sep 6.2. Configure an Alarm Viewer Control for Trandglation
Step 6.2. Configure an Alarm Viewer Control for Translation

The CIMPLICITY Language Mapper provides you with an Object Model. Y ou can use the objects,
properties and methods to create scripts that determine translation options.

For example, asimple way to enable Alarm Viewer Control usersto change languages or English
text strings during runtime is to create a button for each language you want to substitute.
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Step 6.2.1
(page
107

Configure an Alarm Viewer control for translation.

Step 6.2.2
(page
108)

Test your Alarm Viewer Control translations in CimView.

Step 6.2.1. Configure an Alarm Viewer Control

1. Configure an Alarm Viewer Control on a CimEdit screen.

Configuration guidelinesinclude:

* Verifying that you make fields, such as M essage fields wide enough to accommodate the
languagesto display in the Alarm Viewer control.
* Selecting afont that will accommodate the selected languages.

A UNICODE font can be used for any language.

2. Do one of the following to place buttons on the screen that will enable users to select another

language or text string:

If you configured buttons you need for another CimEdit screen

Copy the buttons to this screen or place them as linked objects.

If you need to create new buttons

Follow the procedure described in the previous step (page 102) .

&, AMY.cim - CimEdit

File Ecit Miew Format Tools Frame Help

=10l %]

DEME| »2B- ~ 88 BE® .|

MAIN PLANT

| Message

k| Atam 1D

|Project hama  |State |

| v ] o]

0 Oct 1913:43 { P

'. EMGLISH | FRENCH | CHINESE I .n\Pme' TANK §

Starts CimView with the current state of the screen.

3. Do one of the following to make sure the button labels and other text strings that should be

translated are trans ated:

If you are sharing atrandlation file that already has the translations
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Y ou do not have to do anything.

If you are using atrandlation file that does not have the keys and translations

a. Emit (page 80) the text to thefile.
b. Enter the trand ations (page 93).

Y ou are now ready to test your screen during runtime.

Step 6.2.2. Test you Alarm Viewer Control Translationsin CimView

1. Click the Runtime button "= | on the CimEdit toolbar.
The Alarm Viewer control opens in the default language.

o, AMY.cim =10] x|
MAIN PLANT
k| Atam ID | Message |Project Mame | State |
P TAMEFLOW CALL FLOWY MAMAGER TRAMSLATE  ALARM
TAMEZ CALL TAMKZ MAMAGER TRAMSLATE  ALARM
N TAMKY CALL TAMK1 MANAGER TRANSLATE  ALARM
. FIPEFLOW Flow cut of range TRAMSLATE  ALARM
FIFET CHECK FIPE1 VALVES TRANSLATE  ALARM
KaLM TURM OFF KILM1 TRANSLATE  ALARM
& Ot 132020 ‘ Rifresh | Togghe I Ak | Rleset | Delpte |
ENGLISH l FRENCH | - JAPANESE
For Help, press F1 [ | .z

2. Click language buttons to view the text changes, based on text that is translated in CimEdit's
selected trandation file.

Click aforeign language button.

Thetext that istranslated in the CIMPLICITY Language Mapper replaces the text that currently
displays on the screen.

Examples

Japanese trandation
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=10l x|
FELSHEN

| 4ck| Akam 1D | Message |Project Mame  |State |
P TAMKFLOW FENDTR—57 —2HEE L TRANSLATE  ALARM
] TAMKZ BT TR — WY LT TRANSLATE  ALARM
TAMKA R 2] ADTE—U —E HrigpEL TRAMSLATE  ALARM
FIPEFLONA SEhE Y CES ECT @S TRAMSLATE  ALaRM
FIFE1 W opeagLaEL TRAMSLATE  ALARM
KILN4 Turm off the fumace 1 TRANSLATE  ALARM

£ 0ct 192020 I“"""I Tﬁﬂlli‘lgném
T I FESS IE TAMK S I

For Help, press F1 [ Iz

French trandation

=101 x|
USINE PRINCIPALE

| 4ck| Akam 1D | Message |Project Mame  |State |
M TAMKFLOW APPELEZ LE DIRECTEUR, D'ECOULEMENT  TRANSLATE  ALARM
] TAMKZ APPELEZ LE DIRECTEUR, TANKZ TRANSLATE  AL&RM
TAMKA APPELEZ LE DIRECTEUR TANK1 TRAMSLATE  ALARM
FIPEFLOWY ECOULEMENT PAS DANS LA GAMME TRAMSLATE  ALARM
FIPE1 WERIFIEZ LES WALVES PIPE1 TRAMSLATE  ALARM
KILA ARRETEZ KILMN1 TRAMSLATE ALARM

& Oct 192020 IMﬁ‘Tﬁﬂlli‘l Reset[ De‘.‘m|




Chapter 7. Historical Alarm Viewer Control

About the Historical Alarm Viewer Control
The Historical Alarm Viewer enables a user to view either Database L ogger or Historian historical
data.

During a session, a user can:

* Review logged alarm data through CimView in an easy-to-read table format and
« Print one or more pages of the display at any time during a session.

The user will view logged data that passes specifications including filters, time frames and several
condition types.

Y ou, an applications engineer, can simply place the control on a CimEdit screen and follow the next
steps to customize it.

) Important: Viewers displaying aHistorical Alarm Viewer that is pulling logged point and/or
alarm datafrom the SQL Server must have the same SQL driver version installed that is being used
on the CIMPLICITY Server. If the SQL driver isadifferent version the datawill not display.

Historical Alarm Viewer Control Configuration

Historical Alarm Viewer Control Configuration

Step Number Description

Step 1 (page Place an Historical Alarm Viewer (HAV) control on a CimEdit screen.
111)

Step 2 (page Open the CIMPLICITY Historical Alarm Viewer Properties dialog box.
114)

Step 3 (page Enter general specifications for the HAV control.
114)

Step 4 (page Configure connection options for the CIMPLICITY Historical Alarm Viewer.
117)

Step 5 (page Configure the SQL display.
120)
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Step Number Description

Step 6 (page Select column justification.
130)

Step 7 (page Configure row styles.
131)

Step 8 (page Specify runtime configuration capability.
137)

CIMPLICITY Configuration Object Model and DCOM

When off-node projects are selected on the Connection tab, requests are made to determine which
tables the remote project has available by using the CIMPLICITY configuration Object Model
(CimServer).

Ci nBer ver uses DCOM based communications architecture. Therefore, it may be necessary to
ensure that DCOM is properly configured on the project’s node to alow access to the Object Model.

DCOM configuration and Windows security are complex technical topics and beyond the scope of
this document. For an introduction to DCOM security configuration, see Configuring the GagePort
Mitutoyo OPC server DCOM (About DCOM Security) in the CIMPLICITY documentation. For
more advanced DCOM configuration issues, please refer to Microsoft documentation.

Sep 1. Place an Historical Alarm Viewer Control on a CimEdit Screen
Step 1. Place an Historical Alarm Viewer Control on a CimEdit Screen

Tasks to place an Historical Alarm Viewer Control on a CimEdit screen include:

Step 1.1 | Insert an Historical Alarm Viewer Control on a CimEdit Screen

(page
111)

Step 1.2 | Resize a New Alarm Viewer OCX Control.

(page
113)

(1) Important: Put CimEdit in 100% zoom mode before you begin configuring or editing the
Historical Alarm Viewer control.

Step 1.1. Insert an HAV Control on a CimEdit Screen
Use the following buttons to insert an Historical Alarm Viewer control on a CimEdit screen:

» Historical Alarm Viewer button
* OLE button
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OLE Button

Historical Alarm Viewer Button

Click Historical Alarm Viewer in the Drawing>Objects group on the CimEdit Ribbon bar.

zjﬁ OLE . AlaTE Vidwer
5= Trend "Wl Historical Alarm Viewer
¥ SPC L. Proficy Portal [

A Historical Alarm Viewer control is placed on the CimEdit screen. The top left corner islocated at
the top left corner of the screen.

OLE Button

1. Click OLE in the Drawing>Objects group on the CimEdit Ribbon bar.

Hl OLE . Alarm Viewer
S Trend "l Historical Alarm Viewer
X SPC . Proficy Portal

2. An ActiveX Placement cursor displays on the CimEdit screen.

-

3. Place the ActiveX Placement cursor where you want the top left corner of the control to be
located.

4. An Insert Object dialog box opens.

Insert Object |

ActiveX | Object | From fie |

[ @8 Chait Client Server Contiol =]
B CIMPLICITY AMY Coriiol
! CIMPLICITY Document Delivery Viewer
3B CIMPLICITY HDAViewsr Editor Cortrol
CIMPLICITY Historical Alaim Viewes
CIMPLICITY Recipe Cantrol
B CIMPUICITY SFT Contiol
&I CIMPLICITY Trend Contrel
A CIMPLICITY 3 Plot Contrel _|:|
L3

| |

o ] oo | o |

5. Double-click the CIMPLICITY Trend Control.
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A new Historical Alarm Viewer control is placed on your CimEdit

] [ -
Start Dafte-Time: Erd Date-Time:

190007 31 oo o Bz

] [

screen. = = =

Step 1.2. Resize the Historical Alarm Viewer Control

Y ou can perform a quick resize or a precise resize to resize the Historical Alarm Viewer Control.

Quick Resize Procedures

Grab one of the object's handles and move it to enlarge or reduce the HAV Control.

Precise Resize Procedure

1. Select the Historic Alarm Viewer control.

2. Do one of the following.
* Right-click the Historical Alarm Viewer Control; select Properties on the Popup menu.
* Click the Propertiesin the Home>Properties group on the CimEdit menu bar.
The Properties - Object dialog box opens.

3. Select Geometry.

4. Enter the following:
X

Calors [~ Position ]

Geomen | | Top: 320 pt widh:  [375pt

et [1pt  Height [190pt

Movemerd

Sealing ' 1 .
Frotation

RotationTd . ,—

Colge Aramaticn r—

Teandpasency e

Events

Savipt

WVariables

Menus

Procedianes

Corfrol Properiies
C ot ] coed | e | Wb |
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Field Enter

Top Number of points starting from the bottom of the screen where the HAV Control top is located.

Width | Width of the object in points.

Left Number of points starting from the left of the screen where the left side of the HAV Control is located.

Height | Height of the object in points.

The Historical Alarm Viewer Control enlarges/ reduces and moves to the size you specify.

|5/ Note: Hold the right-button down and drag the object to where you want it positioned on the
CimEdit/CimView screen.

Sep 2. Open the CIMPLICITY Historical Alarm Viewer Properties
Dialog Box

1. Select the Historical Alarm Viewer control.
2. Do one of the following:
* Click the right-mouse button, and then select CIMPLICITY Historical Alarm Viewer
Object > Properties on the Popup menu.
* Click Edit > CIMPLICITY Historical Alarm Viewer Object > Properties on the
CimEdit menu bar.
* Press Alt+E+O+R on the keyboard.

The CIMPLICITY Historical Alarm Viewer Properties dialog box opens when you use any
[CIMPLICITY Historical Alarm Viewer Properties x|

General | Connection | SOL | Cohumns | Row Styies | Runtime |
Caglion:

|
[T Use Ambient Properties
[ Show Tookar

[V Show DatelMime Pickers

ak I Cancel Apply Help

method

Sep 3. Enter General Soecifications for the HAV

Enter and select the following on the General tab in the CIMPLICITY Historical Alarm Viewer
Properties dialog box.



CIMPLICITY Historical Alarm ¥iewer Properties

Eeﬂ!fé'ltonnectiun] SOL | Coumns | Row Styles | Runtime |

1 Caption:
heﬁE&HAV

\2_/ [ Use smbient Properties

3 [ Show Toolbar
L

4 [ Show DatelTime Pickers
S’

[ ok ] coce |

| __Heb

rect 0, 49, 366, 93 (page 115)
rect 1, 91, 157, 122 (page 115)
rect 1, 120, 157, 145 (page 115)
rect 0, 143, 156, 168 (page 116)

1 Caption

(page

115)

2 Use ambient properties.
(page

115

3 Show toolbar.

(page

115

4 Show Date/Time Pickers.
(page

116)

5 Font guideline.

(page

116

1 | Caption
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The caption is atitle that will identify the control during runtime.

|=/ Note: If the caption includes an ampersand, Windows will not display the ampersand. Use a
double ampersand to get a single ampersand to display. & & will display as & in the runtime title.

N

Use Ambient Properties

Check Use Ambient Propertiesto use the CimEdit ambient properties for the Historical Alarm
Viewer.

3

Show Toolbar

Check Show Toolbar to display the following toolbar during runtime.
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)
2

(=
(=
(o
(=)

A Sort a selected column in ascending order.

B Sort a selected column in descending order.

C Add a filter to the view based on a selected cell.
D Remove the additional filters.

|5/ Note: Filters applied during runtime are in addition to any filters configured on the SQL tab
inthe CIMPLICITY Historical Alarm Viewer Properties dialog box. The UF button removes the
runtime filters only.

4 | Show Date/Time Pickers

Check Show Date/Time Pickersto display a Start Date-Time and End Date-Time.

A user can select the starting and ending time of the logged data that the CIMPLICITY Historical
Alarm Viewer will display.

If the user clicks the down arrow to the right of each field a calendar will open to aid in making the

Tes
Start Date-Time: End Date-Tirme:
[5 n7ros 5 738 pr =] [osszooe s 17ss e =1 SYEHSE

timestamp | zeq 4 I October 2008 >|

AMBAZ006 1:20:38 FM SITY
S S2006 1:20:26 M SITY
SAB2006 1:20:25 FM 214 225 236 i? 258 289 ?;‘IJ SITY
DM S2006 1:20:25 PM e a0 1 42 43 14 RATL

HMES2008 1:20:19 FM 15 48 A7 4% 19 20 #
SHE2006 12019 PM 5 w3 ond 2R ¥ 2T 28
HMES2008 1:20:14 FM

GHB/Z008 1:20:14 FM %:nd 3_1%;_2005 v
9A15/2006 12000 FM e s

selection. i TR

|5/ Note: You can specify the amount of time the Historical Alarm Viewer will display at one time.
This specification is on the SQL tab in the CIMPLICITY Historical Alarm Viewer Properties dialog

box.

The runtime Historical Alarm Viewer control will display the options that you selected and
configured.

5 | Font Guideline

If an alarm message that needs to use non-Western characters (e.g. Cyrillic, Chinese) displays ??7??
instead of the message, the following procedure may correct the issue.

1. Right-click the Historical Alarm Viewer control.
2. Select Properties on the Popup menu.
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The Properties - Object dialog box opens.

3. Select Control Properties.
4. Click the Open button to the right of the Font field.

The Font dialog box opens.

5. Select afont that includes the characters for the required language.
6. Select the language in the script drop-down list.

7. Close the Font dialog box.

8. Close the Properties - Object dialog box.

|5/ Note: If this procedure does not resolve the issue, other factors might be affecting font display
on your system. Consult Microsoft documentation al so.

This procedure appliesto values/text from SQL Server. Cyrillic and other non-western characters are
not available for datafrom Historian.

Sep 4. Configure Connection Options for the CIMPLICITY Historical
Alarm Viewer

The Connection tab in the Historical Alarm Viewer Properties dialog box provides several
connection selections. The selections you make on this tab determine what fields you can select to
display during runtime.

Enter and select the following on the Connection tab in the CIMPLICITY Historical Alarm Viewer
Properties dialog box.

CIMPLICITY Historical Alarm Viewer Properties x|

Genersl Connection | SQL | Columns | Row Stles | Runtime |
CIMPLICITY Project to connect to: |
1 joweoemo =] ewercTr PR SR
[enonie> =

Connection String:
2 :Provider-SQLOLEDG:User ID=sa;PasswordsMyPasswor ... I

Table to View:
3 ALARM_LOG j
Refresh Rate:

[ ok ] Cancel |  Apph | Hep

rect 4, 170, 170, 209 (page 120)
rect 4, 133, 186, 172 (page 118)
rect 186, 121, 513, 160 (page 118)
rect 0, 59, 196, 98 (page 118)
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1 CIMPLICITY Project to connect to.
(page

118)

2 Connection String.

(page

118)

3 Table to View.

(page

118

4 Refresh Rate

(page

120

1 | CIMPLICITY Project to connect to

Optionsinclude:

<none> A Connection String (page 118) field displays in the dialog box for you to specify the connection.

<default Display data logged to Historian.

historian>

<local> Selects the local project in which the HAV is configured. The HAV displays all of the data from that project's
Historian server, not just the data logged from the selected project.

Project Enables you to select any project running in the network, including any projects running on the local

name computer. The HAV displays all of the data from the selected project's Historian server, not just the data

logged from the selected project.”

2 | Connection String

A Connection String field displays when <none> is selected in the CIMPLICITY Project to
connect to field.

Click the button ] to the right of the Connection String field to open a Data Link Properties dialog
box and configure the connection.

(1) Important: When you select this option the password will display in the field; any user who has
access to the Historical Alarm Viewer control configuration will know what the password is.

Choosing other options sets the data link properties, but hides the information.

3 | Table to View

Options depend on

» Which of the following or if both are enabled.
o Database L ogger
o Historian
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» Thevalue you selected inthe CIMPLICITY Project to connect to field.

Options include the following.

Enabled | Options Selections
Database <none> Based on connection string.
Logger only

<default

historian> | |5/ Note: Table to View options are available for a default Historian (page 119)
connection even if Historian is not enabled. However, The Historical Alarm Viewer will not
display data until the Historian is enabled.

<local> ALARM_LOG
DATA_LOG
EM_LOG

EVENT_LOG

<Project ALARM_LOG
name>
DATA_LOG
EM_LOG

EVENT_LOG

Historian <none> Based on connection string.
only

<default IhAlarms
historian>
ihArchives
ihCalculationDependencies
ihCollectors

ihComments

ihMessages
ihQuerySettings
ihRawData

ihTags

ihTrend

<local> Historian Alarms
Historian Data

|5 Note: ALARM_LOG is also listed. If you select it a message will report that is cannot
be found. You can select it; however, the Historical Alarm Viewer will not display data until
the Database Logger is enable.
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Enabled | Options Selections
<Project Historian Alarms
name>
Historian Data
|5 Note: ALARM_LOG is also listed. If you select it a message will report that is cannot
be found. You can select it; however, the Historical Alarm Viewer will not display data until
the Database Logger is enable.
Database All of the above options are available when both the Database Logger and Historian are enabled in the
Logger and | Project Properties dialog box.
Historian
4 | Refresh Rate

How frequently the screen should refresh.

Therateisin seconds.

Example
Enter The screen:
0 Never refreshes.
5 Refreshes every 5 seconds
10 Refreshes every 10 seconds.

Sep 5. Configure the SQL Display

Step 5. Configure the SQL Display

Once you have selected the connection the Historical Alarm Viewer will make, you can more
specifically select what data will be displayed.

1. Select the SQL tab.

2. Enter specifications that determine what data will be displayed and highlighted.

Steps to configure the SQL display include:

121)

Step 5.1 | Make general specifications.

(page

122

Step 5.2 | Select the fields that will display in the HAV.
(page
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Select data filters.

Specify the sort order.

The Status box at the bottom of the tab displays your selections. During runtime these selections will

be implemented.

SELECT *FROM ALARM_LOG WHERE "timestamp's=1 tz '2002-01-16
12:55:04%

Step 5.1. Make General Specifications

General specifications on the Historical Alarm Viewer Properties dialog box SQL tab apply to all

Genesal | Connection SOL | Columns | Fiow Styles | Runtime |
A Record Limd (0 = No Limi)

5000
B ¥ Enabls Most Recent Time: Amount:  Time Uinits:
Shionw most recent i'| ID&";‘I:S] ﬂ
Select Fields_. | More Filters... | Sort... |

x|

C SELECT * FROM “ALARM_LOG* WHERE "timestamp®>={ t5 '2007.08-19
15:56:36') ORDER BY "timestamp® DESC

IDKIC@mdlApp{y Help

connection selections.

A | Record Limit

Maximum number of recordsin the Record Limit field.

If the log contains more records than the maximum number of records, the HAV deals with the first

records up to the limit.

The filter and the sort specified through the SQL tab influence the records that are initially used.

Default | 5000

Enable Most Recent

Do one of the following.

» Clear Enable M ost Recent

The Time Amount and Time Unitsfields are disabled.
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The logged data that displays starts when the Historical Alarm Viewer Control is opened.
+ Check Enable Most Recent

The Time Amount and Time Unitsfields are enabled.

Enter the time span for the Historical Alarm Viewer display as follows.

Time Amount | Number of selected units, e.g. 5 (seconds).

Time Units Choose:

o Seconds
o Minutes
> Hours

o Days

(@]

Copy/paste text in the status box

|=/ Note: You can copy the datain the Status box.

Do one of the following to select the text.

* Click the right-mouse button over the text; select Select all on the Popup menu.
« Click the right-mouse button over selected text; select Copy on the Popup menu.

Y ou can paste the selection the same way you paste a text selection in the Windows environment.

Step 5.2. Select the Fields that will Display in the HAV

© Tip: Check Show Toolbar (page 115) on the General tab so a runtime user can influence the
record selection by adding afilter and changing the record sort order.

Click Select Fields on the SQL tab in the Historical Alarm Viewer Properties dialog box.
The Select Fieldsto view dialog box opens.

Do one of the following.

jﬂ Select all fields in the table.
(page

122)

jﬂ Select some fields in the table
(page

123

1. Select al Fieldsin the table

Y ou can quickly select to display all of the columnsin the Historical Alarm Viewer, as follows.
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Select fields to view

1 ¥ Select al fiekds in the table

bl Field

hd|
ISELECT *
3
O I Cancel Help
Feature Description
1 | Select all fields in the | (Default) Check to select all of the fields at one time.
table.
2 | Available Fields The list of available fields is disabled; their static position in the Historical Alarm
Viewer cannot be changed.
3 | SQL Clause The seLEcT* clause includes all fields.

2. Select somefieldsin the table

|=/ Note: Thefields that are available (page 143) are based on selections on the Connection
tab's CIMPLICITY Project to connect to field and Table to View drop down list

Y ou can select the columns that will display in the Historical Alarm Viewer, as follows.

1 T | Sebect al fiskds in the table

Avaiable Fiekis:

W timestamp_utc

o bogged_bry

vl alarmn_clazz

o aloemm_idd

| generation_fime_ude

] time=tamg

[ sequence_number
FELuree

Creterence =|

S0 Clause:

T Stimestamp_ulc®, opped_by", “alarm_class", "alarm_jd",
4 ‘peneration_time_ulc®

|
o« | Cancel Help

2

Feature Description

1 | Select all fields | Clear to select individual fields.

in the table.
9 Tip: If you want to change the static position of the fields in the Historical Alarm
I

ewer, clear the checkbox and select the fields individually.
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Feature Description

2 | Available Fields | Check the fields that should display in the Historical Alarm Viewer.

3 | Up/Down To change the position of a field in the Historical alarm viewer.
buttons a. Select the field.
b. Click one of the buttons to do the following.

4 | SQL Clause (Read-only) The SELECT statement displays the selected fields in the order they will
display in the Historical Alarm Viewer.

Step 5.3. Select the Data Filters

Click MoreFilterson the SQL tab in the Historical Alarm Viewer Properties dialog box.

The Edit Filters dialog box opens.

The fields that display in the Fields dialog box are based on your Connection tab CIMPLICITY
Project to connect to and Tableto View selections.

The Edit Filters dialog box provides the tools to define all filters, as follows.

Fiids:
timestarg = Add Condition...
timestamp_uic
A fence_rumber
_id
alarmn_class
rezource |
Select reconds whers

timestamp_uic Between 282005 &00000 AM And 2

And (alaem_clazs = HGH Modity... I

- rezource = TANIKS)

B Remve I
[wo| o]
Il | i

SOL Clauze:

AHERE tmestamp_utc® BETWEEN {ts ‘2003-02-05 06:00:00°L AND s
c r02-10 18200357} AND (Cadarm_class"="HIGH OR “résource"='TANKS")

rect 0, 54, 29, 83 (page 125)
rect -1, 157, 38, 196 (page 128)
rect -2, 280, 45, 317 (page 129)

Add conditions.

Construct the SQL clause.

@ | ko>
E Lm/ E
® ®

=
N
(]
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C Review the SQL clause.
(page
129)

Add conditions.

A | Add conditions.

1. Select afield in the Files box.
|=/ Note: If you are going to construct statements such as AND, OR, select the fields for those
statements in the order they will be used.

2. Click Add Condition.

A Select Vaues dialog box opens with fields that relate to your selection.

3. Enter the value(s) against which datawill be evaluated and filtered.

Criteriatypes are as follows.

» Time criteria
» Alarm state criteria
» Other alarm criteria

Time Criteria

A Select Values dialog box provides the following options for fields that require date and time
specifications.

Data that meets the date and time specifications passes the filter.

Check Displays

One of the following: | Displays a single date and time field for the date that will be referenced.
* Less Than
+ Greater Than

L Eu@

i Betwesn

% Less Than

i Graaber Than

(gl 1" |

[iooszom = '

o | e | b |

Important: Do not use Equals with a time stamp.
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Check Displays
* Between Two date and time fields for the date/time range that will be referenced.
[seiect values 8
T Equalz
5 Batwesn
i~ Less Than
1~ Grealer Than
s Ml
2782009 °I
& 0000 AWM =
2 Q2009 'I
0000 PM l—|
* Null No time fields are required.
[seiect Vaiues
" Euelz
i~ Betwesn
" Less Than
i~ Grealer Than
% s bl

|=/ Note: Click the down arrow to the right of a date field to display a calendar.

;I January 2008 _'I

303 1 2 3 4 5
B 7 8 9 10 11 12
13 14 15 1B 17 18 19
20 @Iy 22 23 24 25 28
2F 28 029 30 N 1 2
3 4 5 B 7 8 9
T Today: 1/21/2008

Alarm State Criteria

Alarm State criteria are available for the Database Logger ALARM_LOG table.

Checked values pass thefilter.




v Acknowiedge
[ Delete

W] Generate

[ Mormsl

[ |Rese=t

| 0K I Canceil Help

Other alarm criteria

Other alarm criteriainclude:
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Datais evaluated alphanumerically. Data that meet the specifications passes the filter.

Check

Displays

« Equals

» Greater Than  Epeas
i~ Betwesn

" Less Than
1 Gresber Than
Ll 17 |

]

One of the following: | Displays a criterion field for the value that will be referenced.

+ Less Than

pon

»

coen_|

e |

» Between Two criteria fields for the value range that will be referenced.
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Check Displays

* Null No criteria fields are required.

" Eeasls

T Between
" Less Than
" Grealer Than

0% s bl

v
(o] _cmes | o |

The selected field is entered in the Select records where box.

Construct the SQL clause.

B | Construct the SQL clause.

By default, each field is added to the Select records where box as an AND criteria. The alarm will
have to fulfill that criteria and others on thelist.

Y ou can create statements to change how the list will be filtered.

1. Select afield in the Select records box.

2. Click any of the following to construct the SQL clause.

Button Name Button

Modify Madify... I
Remove — |

And AND
Or oR |
NOT MQT

Parentheses L| Ll

|=/ Note: You can copy the datain the Status box.




Review the SQL clause.

C

Review the SQL clause
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The SQL Clause that you create displays in the read-only SQL Clause box.

When you close the Edit Filters dialog box, the clause aso displays in the read-only box on the SQL
tab.

Step 5.4. Specify the Sort Order

Click Sort on the SQL tab in the Historical Alarm Viewer Properties dialog box.

The Select sort criterion dialog box opens.

The fields that display in the Sort by dialog box are based on your Connection tab CIMPLICITY
Project to connect to and Tableto View selections.

Select the runtime sorting priorities, as follows.

Sort by
v generation_time_uic ﬂ Ascancing
| timeztamp B <
| alarm_class S Descending
) alarm_id A ;

logged_try
reference
prev_state ll

SGL Clausec

sequence_number ™ |
[t i=-] [ C .

(ORDER BY "timestamp_utc” DESC, "generation_fime_4c®, timestamp®,
alorm_class”, "alarm k"

OH I Cancel Help
Sort .
N Feature Description
Criterion
A Sort by Check the fields that will be included in the criteria for sorting.
B Ascending/ | Check one to sort the fields: Ascending or Descending.
Descending
C Up/Down Moves a selected field up or down in the list. The sort begins with the first selected field in
the list; the next sort is the second selected field; sorts continue until the last selected field
is sorted.
D SQL (Read-only) The clause that defines the sorting priority displays.
Clause
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Sep 6. Select Column Justification

The default Historical Alarm Viewer column justification is right, the standard justification for
numbers. Y ou can change the default or re-select the defaullt.

1. Select the Columns tab.
X

General | Connection | SOL  Cohurns | Fow Styles | Runtime |

{+ General Justification (8.5, numbers right, text laft)
 Leit Justification

™ Right Justification
.ﬁ-

Ok | Concel | Apph | Hep |

2. Choose among the following justification options:

Option Description
General Justification Numbers are right; text is left
Left Justification Numbers and text are left.
Right Justification Numbers and text are right.

Genera Justification

RIETEY
File ‘iew Help
Start Dabe-Time: End Date-Time:
1172008 21831 P x| [1nseoos 2aem em x| BY %]
alarm_id  |slarm_cl [resource | sequen|prev_state generation_time| |
B |COOLIMT  |COOL TANHS TR 1HBR200E 1:45:05 PM
[ [FEATIO1 |HEAT  HEATNG | 38|N 171872005 1:44:51 PM
HEAT 301 HEAT HE&TNG A _35 I 1H 82008 1:44:31 PM
LEVELT201 [TAMKL |TANKS 34N ATABR008 12221:22 PM
HEATBOT |HEAT |HEATING 33N 111872008 12:21:22 PM

A | Textis left justified

B | Numbers are right justified.

Left Justification
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RIETEY
File ‘iew Help
Start Dabe-Time: End Date-Time:
10172008 2:3028 P x| [1nseoos 2:a0zsem x| BY %]
slarm_jd  [skarm_class [resource sequencprev _|generation_time [«
P |COOLIM COoL TANKS ar R 1A G008 1:45:05 PM
= HEAT?ON HEAT HEATING 36 R _1.-‘18:‘2008 1:44:51 PM
HEAT 301 HEAT HEATING s Rk AAGR2005 1:44:31 PM
LEVELT20M |TAMKL TANKS 34 N AAGR003 1221:22 PM
HEATBO1  |HEAT HEATING 3 N |1A820081221:22 PM
i

Right Justification
o/

File ‘View Help
Start Date-Time: End Date-Time:

10172008 2:3839 P x| [1neroos 2:3e3eem x| B} %)

alarm_idl| alarm_class|  resource| sequenc|prev_s generation_time| = |
»| coolsoi COOL|  TAMKS 37 | 1716/2008 1:45.05 FM
HEAT7O1 HEAT| HEATING 36 M| 1782008 1:44:51 PM
HEAT301 HEAT|  HEATING| 35 M| 17182008 1:44:31 PM
[ | LEvELTz01 TANKL TANKS | 34 N[ 1182008122122 FM
HEATSM HEAT HEATING 33 M TMER0DS 122122 PM

e aens et ueaa - METTT Y EETE TN

Sep 7. Configure Row Styles
Step. 7 Configure Row Styles

The default display for rowsis as follows.

If Use Ambient Properties on the General tab: | Rows Display using:

Not checked System colors

Checked Using the Ambient colors

If you want rows that meet certain conditions to display differently, you can select the Row Styles
tab.

Configuration steps are as follows:

Step 7.1 | Add/remove rows styles.

Configure Row Style 1 and Row Style 2.

%2}
QD (D
P~

N

-
[8]
]

Configure addition row styles.

(<2
QD D
® I~

W

=

35
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Step 7.1. Add/Remove Row Styles

* Add arow style
* Remove arow style

Add a Row Style

1. Click the Add Style button.
An additional Row Style set is added to the list.

2. Continue to add as many styles as you think you need to highlight different runtime conditions.

Assoon asarow styleisadded, its colors (page 133) can be selected and conditions (page
135) defined for runtime display.

CIMPLICITY Historical Alarm Viewer Properties x|

General | Connection| SOL | Cokmne  Row Stles | Runtime |

Fow Style 1 | Add Style I
Foreground Color
Background Color
Coraiitions

Fowr Style 2 -+
Foreground Color
Background Color
Conitions

oK, I Cancel Help

Remove a Row Style

1. Select the Row Style <n> line for the row style you want to remove.

The button becomes a Remove Style button.

2. Click Remove Style.



CIMPLICITY Historical Alarm Viewer Properties

General | Connection| SGL | Cokmns Row Stes | Runtime |

Background Color ;l Remove Style

Conditions
Row Style 2
Foreground Color
Background Calor
Condtions

Foreground Color
Backaground Color
Confitions

Help

The style is removed.

CIMPLICITY Historical Alarm Viewer Properties

General | Connection| SGL | Cokmns Row Stes | Runtime |

Row Style 1 | Add Syle

Foreground Color
Backiround Calor
Conditions

Fow Style 2
Foreground Color
Backoround Color
Contiftions

I Ok, I Eamdl Anply ] Help
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Step 7.2. Configure Row Style Foreground and Background Colors

A Select the foreground color for a Row Style.

(page

133)

2] Select the background color for a Row Style.
e

134

1. Select the Foreground Color for a Row Style
a. Select Foreground Color under a Row Style

A color sguare displays to the right of the Row Style box.



Alarms and Messages | 7 - Historical Alarm Viewer Control | 134

x4
General | Connection| SGL | Cokmns Row Stes | Runtime |
Fow Style 1

Foreground Color

Hafkoround Color Select Foreground Color

[ ok | coce | s | Hew

b. Right-click the Square.

An Advanced Color Palette opens.
c. Select the foreground (font) color.

flllur
Smodm:
ErCRErERE
HMrMrEFEN N
ENFENENNEN
EMEAEEEEN
EEEEEENN
T .

Custom colors:
ol )|
Hus:[160  Red[Z5
.. e o
Defire Custon Colare 53 I ColoriSold Lun:lﬁ‘ B.JDCIE‘

ok | conce | Add to Custom Colors |
d. Click OK.

The color that displaysin the Select Foreground Color is the font color for that row style.

|Seiect Foreground Colnrl

2. Select the Background Color for a Row Style

Select Background Color and repeat the process above to specify the background color for the
selected Row Style.
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CIMPLICITY Historical Alarm Yiewer Properties ll

General | Connection| SGL | Cokmns Row Stes | Runtime |

Row Style 1
Foreground Color

Select Background Color

Step 7.3. Select Conditions for Row Styles

* Row style condition configuration.
* Guidelinesfor row styles.
* Row style condition example.

Row Syle Condition Configuration

Y ou can highlight selected conditions in the Historical Alarm Viewer by assigning them colors, as
follows.

1. Select Conditions under a Row Style.
An Add Condition button displays.

2. Click Add Condition.
x|

General | Connection| SOL | Cokmne  Row Stles | Runtime |

Row Style 1 Add Condition |
Foreground Color
Background Color T

[ ok | cance | ooy Help
A Select Fields browser opens.

3. Select a condition.
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Select Fields...

OPCGuality
Samplinghode
Direction
MNurnberOfSamples
IntervalMiliseconds
Calculstiordode

FiterTag —
Filterbdode

FiterComparisonhode

Fiter'Value d

OKICmc,al| Hq:l

4. Click OK.
The condition displaysin the Row Style tree.

5. Do the following:
X

General | Connection| SGL | Cokmns Row Stes | Runtime |

Fowar Style 1 Remove Condition |
Foreground Color
Background Calor Enter Value

) Conwtions B [17500

EIKIEamd bpplyJHabl

A | Select the condition. An Enter Value field displays on the Row Styles tab.

B | Enter a value in the Enter Value field

6. Repeat this procedure for Row Style 2 if you want to display a second customized row style.

During runtime rows that meet the specified conditions displays the row style for that condition.

Guidedlines for row styles

« Available conditions depend on your CIMPLICITY Project to connect to and Tableto View
selections on the Historical Alarm Viewer Properties Connection tab.

* Y ou can add more than one condition to arow style. Thelist of conditions will beincluded in an
AND clause. Runtime values will have to meet all criteriato display the row style.

» When you select a condition, a Remove Condition button displays; click Remove Condition to
remove the selected condition from the list.
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« If avalue meets all the conditions for more than one row style, the last row style with conditions
that are met is applied to the row.

Row Syle Condition Example

* Row Style 1 and Row Style 2 each have 1 condition

Style | Condition | Foreground | Background | Value

Row Style 1 | value White Red 17500

Row Style 2 | tagname White Blue LEVELT101

» The dlarm HEAT101 meets the condition for both row styles.
» Therow for HEAT101 displays the Row Style 2

[Gravam =loix|

File Wiew Help
= TARSERE - =)

ProiCiP HAY

| VE2E008 S1T.00 AM 32123

SERVER! WPROFCIMPLEVELT20M .VALUE |1/21/2008 10026:03 M 18500

| SERVERT VPROFCIMPLEVELT201 VALLE [1/21/2008 11.00.03 PM 16500 [100

SERVERT WPROFCIMPLEYEL T201 WALUE | 1/21 /2005 4,05:03 BM [16500 [100
|| SERVER!.WPROFCIMPLEVELT20H VALUE | f21/2008 1004303 AM 16500 1o -
T L L|_I
Styl e For Help, press F1 I . - 7

Sep 8. Fpecify Runtime Configuration Capability

The Runtime tab contains viewer options that you can enable for runtime.
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CIMPLICITY Historical Alarm Viewer Properties x|

General | Connection | SOL | Columns | Row Siples Runtime |
A | Enale Export
B |V Enabie Field Selection
C | Enable Fiter Selection
D |¥ Enable Sort Selection
Ell? Enable Printing

[k ] Cancel | Apply Help

rect -1, 54, 116, 76 (page 138)
rect O, 75, 117, 97 (page 139)
rect 1, 101, 143, 123 (page 140)
rect -2, 124, 140, 146 (page 141)
rect -3, 144, 139, 166 (page 142)

Enable Export

Enable Field Selection

Enable Filter Selection

Enable Sort Selection

Enable Printing

m| RS0 | R0 | R | Re >
B"|EE7|BE"|BE” kB
D @D D (0] D

-

42

Enable Export

>

Enable Export

Runtime users can save the Historical Alarm Viewer screen as a .txt or .csv file.

1. Right-click the CIMPLICITY Historical Alarm Viewer in the toolbar area.

2. Select Export on the Popup menu.
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Laravam =10l
Fle ‘iew Help
[t Dato. Time: Trod Dt Fima: 1
1n72m8 30x16PM =] [1 mB700n 3maisPm v Refresh
sl [ataeen_chass frosomce  [seauer o Auto Refresh
[HEAT 381 HEAT HEATHIG
LEVELT201 TN TAmS [ }Export
HEATEI HEAT HEATHIG Print
MEATSS1 HEAT HEATHIG
HEAT 31 HEAT HEATIIIG [ Selact Fields. ..
L
Select Filkers...
Select Sorting...

A Save Asdialog box opens.
3. Save the Historical Alarm Viewer report asa.csv or .txt file.

|5) Note: Thefileis saved by default as a .txt file. If you want to save it asa.csv file, enter the
full name with the extension in the File name field.

Savein: [ ProiCIMP

My Documents

»

- File: nusme: HEVHEAT cov |
-

My Network  JIELIELL T Fbircov) |
Places

<

Thereport is saved in the format you specify and can be opened in a..txt or .csv application.

Enable Field Selection

B | Enable Field Selection

1. Right-click the CIMPLICITY Historical Alarm Viewer in the toolbar area.

2. Select Select Fields on the Popup menu.
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P =
Fle Wiew Help
[t Dato. Time: Trod Dt Fima: 1
1n72m8 30x16PM =] [1 mB700n 3maisPm v Refresh
v Auko Refresh
[HEAT 381 HEAT HEATHIG
LEVELTIo1 TAmEL TAIKS [ Expart
HEATEI (HEAT HEATIIG | Pri
HEATS01 HEAT HEATIIG | i rint
HEAT 301 HEAT HEATHIG b_semct Fields...
L

Select Filkers, ..
Select Sorting...

A Select fields to view dialog box opens. Fields can be added, removed, moved to the left or right on
the screen.

[T Select ol fiskds in the labis

Available Fiekis:

S0 Clause:

[SELECT "plarm_id", “slarm_class®, “resource”, “sequence_number™,
[Mordy_s{abe”, “pariration_lme"

Enable Filter Selection

C | Enable Filter Selection

1. Right-click the CIMPLICITY Historical Alarm Viewer in the toolbar area.

2. Select Select Filters on the Popup menu.

P =
Fle Wiew Help
[t Dato. Time: Trod Dt Fima: 1
1n72m8 30x16PM =] [1 mB700n 3maisPm v Refresh
v Auko Refresh
[HEAT 381 HEAT HEATHIG
LEVEL 1291 TAMEL TAIKES | Export
HEATEI (HEAT HEATIIG | Pri
HEATS01 HEAT HEATIIG | rint
HEAT 301 HEAT HEATIIG Select Fields, ..
L

| Select Filkers...
Select Sorting...

An Edit Filters dialog box opens.

The SQL clause can be modified to change the criteriafor which alarms display in the Historical
Alarm Viewer.



HERE “ganeration_fime™ DETVWEEN (s 200801 -17 001345} AND fiz
[008-01-1T 12 1945 ) AND Calarm_class™=HOH OR Tesource™=TANKE)

[T ] o | we |

time starg: =] AddCondton
ttgeraif_furtser
Co]
s clacs
resoirce
et =
Selesct raconds whare
perwnton e Bvtvenen A 008 132 1540 AM A
(ured (slarm_chens = HGH Wity
O riciinrcy = TAMKS)
[
[ =
[ o] |l
O, st
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|5) Note: Review arequired SQL query if the Historian i hRawDat a table is selected.

Enable Sort Selection

D | Enable Sort Selection

1. Right-click the CIMPLICITY Historical Alarm Viewer in the toolbar area.

2. Select Select Sorting on the Popup menu.

=181
Fle Wiew Hel
[t Date Tene Ervd Date- Tiena: 1
1470 Jaaie M 7| |1 Aezeee 1akisrm 7] Refresh

[stum_class [resomee  [seauer o Auto Refresh
HEAT HEATHIG
[TAWKL  TAIWS Export
HEAT HEATIG :
HEAT HEATIIG Print
Ll Select Fields. .,

I Select Sarting. ..

Select Filkers...

A Select sort criterion dialog box opens.

The current priorities for sorting the list can be changed.
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Select sort criterion

Sort by:

[ generation_time -

[ timestamp " Ascending
[ alarm_clazs " Descending
[ alarm_id

[ sequance_number |
[Tresource v
[logged_try |
[referance Dawn

[ prev_state =

SO Clause:

QRDER BY “generation_time® DESC, “timestamp® DESC, “alarm_class®,
“alarm_id*

| 0K I Cancel Help

Enable Printing

E | Enable Printing

1. Right-click the CIMPLICITY Historical Alarm Viewer in the toolbar area.

2. Select Print on the Popup menu.
PN o=

Fle ‘iew Help
[art ato-Time: Tl Dt Time: 1
1n72m8 30x16PM =] [1 mB700n 3maisPm v Refresh
[staren chans [rasomca  [sequer o Auto Refresh
HEAT HEATHIG
[rama s [ Export
e pr
HEAT REA T Select Fields. ..
Select Filkers. .
Select Sorting...

A Page Setup dialog box opens.

3. Select print criteriathat reflect your Historical Alarm Viewer size and printer specifications.
2%

Papsi

Size:

Soarce: [ 2wt Setect =|
Diieristion 1 [ Maging [nchez)

" Porat Ledt: 1 Right |1
 Lanedicaps Tege |1 Botton: |1

(T N

4. Click OK.
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A Print Preview window opens.

N o=l
Fils Vi
BIQOCQRARAM -k 2 Aot | OB
alanm_id alam _class resource numbser prev_stale generation fime 3
LEVELT204 TABNKL TAHKS Ll AASZ00E X505 PM
HEATENM HEAT HEATING a5 N 12008 3315 PM
HEATTS HEAT HEATING M N 17008 33015 PM
HEATSN HEAT HEA TG 43N TRZ008 XS FM
HEAT 30 HEAT HEATING 4% M 1132008 X315 FM
HEAT 301 HEAT HEATHIG sl AR08 X315 PM
HEATING 1182008 X315 PM
CO0L3M CooL TANKS »N 12008 3315 PM
COOL1# COM TAHKS L AASZO0E X305 PM
COO0L3™M coo TANKS R 1ME2008 1:4505 PFM
HEATTI HEAT HEATING 36N 1M T008 12451 PM | |
HEAT36 HEAT HEA TG ¥ N TARZN08 14831 FM
LEVELT2H THNKL TAHKS HH 11182008 123127 FM
HEATEN HEAT HEATING 3N 132008 12:132 PM
HEATS01 HEAT HEATIIG | 0 182008 12:71:22 PM
HEAT 30 HEAT HEATING H N 192008 127137 FM
HEAT 2 HEAT HEATHIG p L] 1R 008 123137 PM
HEATING z 152008 12:21:32 PM
CO0L3M CooL TANKS oL 1132008 12:7137 PM
COOL1e1 COML TANKS mm TSR 1M PM |
4 | k f—l

5. Click the Print button on the Preview window toolbar when you are ready to print one or more
pages.
A Print dialog box opens.

6. Click Print to print a selected page range.

Technical Reference: Historical Alarm Viewer

Technical Reference: Historical Alarm Viewer

The Historical Alarm Viewer provides several options for displaying data during runtime.

Fieldsthat are available are based on your CIMPLICITY Project to connect to and Tableto View
selections on the Historical Alarm Viewer Properties Connection tab.

(page
143)

1 Default Historian tables and field options

2 <Local> or <Project Name> tables and field options
(page
154)

1. Default Historian Tables and Field Options

1. Default Historian Tables and Field Options
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Table views that are available when you select Default Historian inthe CIMPLICITY Project to
connect to on the Historical Alarm Viewer Properties dialog box Connection tab, are asfollows.

Each table view providesrelated fields.

=
-

Default Historian\ihAlarms fields

D

[
%

—
N}

Default Historian\ihArchives fields

=
z‘;m‘
&)
D

[
w

Default Historian\ihCalculationDependencies fields

[]

[==Y
L@m"

—
~

Default Historian\ihCollectors fields

D

[N
5%

=
o

Default Historian\ihComments fields

-
[o}]

Default Historian\ihMessages fields

D

[N
@m"

-
~

Default Historian\ihQuery fields

BE
Ca
o)

-
[ee]

Default Historian\ihRawData fields

D

(==Y
@m"

—
©

Default Historian\ihTags fields

i ‘
=
IS

o)

=
[N
o

Default Historian\ihTrend fields

-
QD
D

52

1.1. Default Historian\ihAlarms Fields

The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihAlarms are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.



Criteria Type

Fields

Time

StartTime

EndTime
AckTime

Timestamp

Other

AlarmID

ItemID
Source

DataSource
Tagname

AlarmType
EventCategory

Condition
SubCondition

Message
Acked

Severity

Actor

Quiality
RowCount

1.2. Default Historian\ihArchives Fields
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Thefollowing fields (for display and sorting) and filter criteria are available when <default
Historian> and ihArchives are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.

Criteria Type

Fields

Time

StartTime
EndTime

LastBackup
LastModified
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Criteria Type Fields

Other ArchiveName

ArchiveStatus

FileName

IsCurrent
IsReadOnly

FileSizeCurrentDisk
FileSizeCurrent

FileSizeTarget
LastBackupUser

LastModifiedUser
TimeZone

DaylightSavingTime

RowCount

1.3. Default Historian\ihCal cul ationDependencies Fields

The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihCal cul ationDependencies are sel ected on the Connection tab in the Historical
Alarm Viewer Properties dialog box.

Criteria Type Fields

Other Tagname
DependentTagname
RowCount

1.4. Default Historian\ihCollectors Fields

The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihCollectors are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.

Criteria Type Fields

Time LastModified
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Criteria Type

Fields

Other

CollectorName

CollectorDescription

Comment

ComputerName

Status

CollectorType
MinimumDiskFreeBufferSize

MaximumMemoryBufferSize

ShouldAdjustTime
ShouldQueueWrites

CanBrowseSource
CanSourceTimestamp

StatusOutputAddress
RateOutputAddress

HeartbeatOutputAddress

ColllectorGenerall

CollectorGeneral2

CollectorGeneral3

CollectorGeneral4
CollectorGeneral5

LastModifiedUser
SourceTimelnLocalTime

CollectionDelay
DefaultTagPrefix

DefaultCollectioninterval
DefaultCollectionType

DefaultTimeStampType
DefaultLoadBalancing

DefaultCollectorCompression

DefaultCollectorCompressionDeadband

DefaultCollectorCompressionTimeout

DefaultCollectorAbsoluteDeadbanding

DefaultCollectorAbsoluteDeadband
DisableOnTheFlyTagChanges

DefaultSpikeLogic
DefaultSpikeMultiplier

DefaultSpikelnterval
RedundancyEnabled

PrincipalCollector
IsActiveRedundantCollector

FailoverOnCollectorStatus
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1.5. Default Historian\ihComments Fields

The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihComments are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.

Criteria Type Fields

Time Timestamp

StoredOnTimeStamp
CommentTimeStamp

Other Tagname

SuppliedUsername

Username

Comment

DataTypeHint

SamplingMode
Direction

NumberofSamples
IntervalMilliseconds

CalculationMode
FilterTab

FilterMode

FilterComparisonMode

FilterValue
TimeZone
DaylightSavingTime
RowCount

1.6. Default Historian\ihM essages Fields

The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihM essages are sel ected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.

Criteria Type Fields

Time TimeStamp




Criteria Type

Fields

Other

Topic

Username

MessageNumber

MessageString
TimeZone

DaylightSavingTime

RowCount

1.7. Default Historian\ihQuerySettings Fields
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Thefollowing fields (for display and sorting) and filter criteria are available when <default
Historian> and ihQuerySettings are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.

Criteria Type

Fields

Time

StartTime

EndTime

Other

SamplingMode

Direction

NumberOfSamples

IntervalMilliseconds
CalculationMode

FilterTag
FilterMode

FilterComparisonMode
FilterValue

TimeZone
DaylightSavingTime

RowCount

1.8. Default Historian/ihRawData Fields

The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihRawData are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.
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Criteria Type Fields
Time TimeStamp
Other Tagname
Value
Quality

OPCQualityValid
OPCQuality

SamplingMode
Direction

NumberOfSamples
IntervalMilliseconds

CalculationMode
FilterTag

FilterMode

FilterComparisonMode

FilterValue

TimeZone

DaylightSavingTime

RowCount

f\gﬁlm.portant: If you choose the i hRawDat a table, modify the Query (Datafilters) to the
ollowing.

SELECT * FROM "i hRawDat a" WHERE "ti nest anp" >=' <Dat e><Ti ne>' and
("Sanplingvbde"=""'""interpolated '') ORDER BY "ti nestanp" DESC

Example
SELECT * FROM "i hRawDat a" WHERE "ti mest anp">=' 2008- 05-17 20: 01: 09' and
("Sanplingbde"=""'""interpolated '') ORDER BY "ti nestanp" DESC

1.9. Default Historian\ihTags Fields

The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihTags are selected on the Connection tab in the Historical Alarm Viewer Properties
dialog box.

Criteria Type Fields

Time LastModified
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Criteria Type

Fields

Other

Tagname

Description
EngUnits

Comment

DataType

FixedStringLength
CollectorName

SourceAddress
CollectionType

Collectioninterval
CollectionOffset

LoadBalancing
SpikeLogic

SpikeLogicOverride
TimeStampType

HiEngineeringUnits

LoEngineeringUnits

InputScaling
HiScale

LoScale

CollectorCompression CollectorDeadbandPercentRange

ArchiveCompression
ArchiveDeadbandPercentRange

CollectorGenerall
CollectorGeneral2

CollectorGeneral3
CollectorGeneral4

CollectorGeneral5
ReadSecurityGroup

WriteSecurityGroup
AdministratorSecurityGroup

Calculation
LastModifiedUser

CollectorType
StoreMilliseconds

UTCBias
AverageCollectionTime

CollectionDisabled
CollectorCompressionTimeout

ArchiveCompressionTimeout

TimeZone
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1.10. Default Historian/ihTrend Fields

The following fields (for display and sorting) and filter criteria are available when <default
Historian> and ihTrend are selected on the Connection tab in the Historical Alarm Viewer Properties
dialog box.

Criteria Type Fields

Time TimeStamp
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Criteria Type Fields

Other SamplingMode
Direction
NumberOfSamples

IntervalMilliseconds

CalculationMode

FilterTag
FilterMode

FilterComparisonMode
FilterValue

TimeZone
DaylightSavingTime
RowCount
TagID.Value
TagID.Quality
TaglD.Tagname

TaglID.Description
TaglD.EngUnits

TaglD.Comment
TagID.DataType

TagID.FixedStringLength
TaglD.CollectorName

TaglD.SourceAddress
TaglD.CollectionType

TaglD.Collectioninterval
TaglID.CollectionOffset

TagID.LoadBalancing
TagID.SpikeLogic
TagID.SpikeLogicOverride
TagID.TimeStampType
TaglID.HiEngineeringUnits
TagID.LoEngineeringUnits

TaglID.InputScaling
TagID.HiScale

TaglD.LoScale
TagID.CollectorCompression

TaglD.CollectorDeadbandPercentRange
TaglD.ArchiveCompression

TagID.ArchiveDeadbandPercentRange
TaglID.CollectorGenerall

TaglID.CollectorGeneral2
TaglID.CollectorGeneral3
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2. <Local> or <Project Name> Tables and Field Options
2. <Local> or <Project Name> Tables and Field Options

Table views that are available when you select <local> or a project nameinthe CIMPLICITY
Project to connect to on the Historical Alarm Viewer Properties dialog box Connection tab, are as
follows.

Each table view providesrelated fields.

2.1 < Local> or <Project Name>\ALARM_LOG fields

g8
o
)

N
N

< Local> or <Project Name>\DATA_LOG fields

o |
N o
@D

n
w

< Local> or <Project Name>\EM_LOG fields

o
Q
(e}
D

,_\A
a1
Al S|
5

N
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gm"

< Local> or <Project Name>\EVENT_LOG fields

[]

N
o

< Local> or <Project Name>\Historian alarms fields

g ‘
o R
1)

D

N
o}

< Local> or <Project Name>\Historian data fields

58
[
[©)

57

2.1.< Local> or <Project Name>\ALARM_LOG Fields

The following fields (for display and sorting) and filter criteria are available when <local> or
<Project Name> and ALARM_LOG are selected on the Connection tab in the Historical Alarm
Viewer Properties dialog box.

Criteria Type Fields

Time timestamp

timestamp_utc

generation_time

generation_time_utc




Criteria Type Fields

Alarm State prev_state
log_action
final_state

Other sequence_number

alarm_id

alarm_class

resource
logged_by
reference

prev_state

log_action
alarm_message
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2.2.< Local> or <Project Name>\DATA_LOG Fields

The following fields (for display and sorting) and filter criteria are available when <l ocal > or
<Pr oj ect Name> and DATA LOG are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.

Criteria Type

Fields

Time

timestamp

Other

point_id

_VAL

2.3.< Local> or <Project Name>\EM_LOG Fields

The following fields (for display and sorting) and filter criteria are available when <l ocal > or
<Proj ect Name> and EM_L OG are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.

Criteria Type

Fields

Time

timestamp
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Criteria Type Fields

Other sequence_number
time

event_type

event_source

action_type

action_target

2.4.< Local> or <Project Name>\EVENT_LOG Fields

The following fields (for display and sorting) and filter criteria are available when <l ocal > or
<Pr oj ect Name> and EVENT_LOG are selected on the Connection tab in the Historical Alarm Viewer
Properties dialog box.

Criteria Type Fields

Time timestamp

generation_time

Other sequence_number

alarm_id

alarm_class

resource

logged_by

reference

alarm_message

2.5. <Local> or <Project Name>\Historian Alarms Fields

The following fields (for display and sorting) and filter criteria are available when <l ocal > or
<Proj ect Nanme> and Hi stori an Al ar ns are selected on the Connection tab in the Historical
Alarm Viewer Properties dialog box.

Criteria Type Fields

Time StartTime

EndTime
ActTime

Timestamp




Criteria Type

Fields

Other

AlarmID

ItemID

Source

DataSource

Tagname

AlarmType
EventCategory

Condition
SubCondition

Message
Acked

Severity
Actor

Quality
RowCount
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2.6. <Local> or <Project Name>\Historian Data Fields

The following fields (for display and sorting) and filter criteria are available when <local> or
<Project Name> and Historian Data are selected on the Connection tab in the Historical Alarm
Viewer Properties dialog box.

Criteria Type

Fields

Time

TimeStamp
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Criteria Type Fields
Other Tagname
Value
Quality

OPCQualityValid
OPCQuality
SamplingMode
Direction

NumberOfSamples

IntervalMilliseconds

CalculationMode
FilterTag

FilterMode
FilterComparisonMode

FilterValue
TimeZone
DaylightSavingTime

RowCount




Chapter 8. OPC Alarm and Event Server and
Client

About the OPC Alarm and Event Server and Client

» OPC Alarm and Event Server and Client Overview
* OPC Alarm and Event Server and Client Steps

OPC Alarm and Event Server and Client Overview
CIMPLICITY provides you with an OPC Alarm and Event (A & E) Server and Client.

|=/ Note: The CIMPLICITY OPC Alarm and Event Server and Client are most commonly used to
send data to and receive data from non-CIMPLICITY OPC Alarm and Event Clients and Servers.

The server and client interaction occurs basically as follows.

OPC A & E Server
OPC A & E Clients 1 > 3 > OPC A & E Sources
L R

e — e —

2-2700

1 | OPC Alarm and Event Client (clients) starts and starts the OPC Alarm and Event Server (OPC servers), if it is not
already running.

2 | Server requests data from the Alarm Managers in all connected source projects.

@ Note: Source projects are selected in the server configuration and need to be running in order to be
connected.

3 | Alarm Managers send data to the server.

4 | Server sends alarm data to its clients.

5 | Clients display the data in the Alarm Viewer and notify the server if alarms are acknowledged..

6 | Server transmits the information to the source projects.

3-6 continues with data being passed back and forth through the OPC Alarm and Event Server.

OPC Alarm and Event Server and Client Steps
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Configure the OPC Alarm and Event Server.

= 2]
5T
® o

Configure the OPC Alarm and Event Client.

t Use the OPC Alarm and Event Client and Server at runtime.

(page
183

9]
D
w

&

© Tip: CIMPLICITY also provides the powerful CIMPLICITY Enterprise functionality to send
and receive alarm and point data between CIMPLICITY projects.

Alarm Categories for an OPC Alarm and Event Server

These are the categories of CIMPLICITY alarm messages that passed as OPC alarm messages.

Category Used for

Level Non-Boolean point alarms

Text messages come from the alarm strings definition used by the alarm.

Discrete Boolean point alarms

Text messages come from the alarm strings definition used by the alarm.

System All non-point alarms

Non-point alarms have a configurable severity. This severity is used by the OPC server as the sub-
condition Syst emseverity.

=/ Note: Existing non-point alarms have a default severity of 100.

=

Configure the OPC Alarm and Event Server and Client

Configure the OPC Alarm and Event Server and Client

Configure the OPC Alarm and Event Server.

= wn
(o)} —
o |
'_"O
o |-

)
o |3
® o

Configure the OPC Alarm and Event Client.

-
(o]
~
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Step 3 | Use the OPC Alarm and Event Client and Server at runtime.

(page
183)

Sep 1. Configure the OPC Alarm and Event Server

Step 1. Configure the OPC Alarm and Event Server

Following are steps for configuring the OPC Alarm and Event Server.

Step 1.1 | Open the OPC Alarm and Event Server Window.

Step 1.2 | Configure projects.
(page
162)

Step 1.3 | Apply the changes to the OPC Alarm and Event Server.

Step 1.4 | Configure the OPC Alarm and Event Server sampling rate.

Step 1.5 | Select trace options.

Step 1.6 | Close the OPC Alarm and Event Server.

Step 1.1. Open the OPC Alarm and Event Server Window

1. Click Start on the Windows task bar.

2. Select (All) Programs>HMI SCADA - CIMPLICITY version>A&E OPC Server.

[ azE OPC Server
8 Alz Sound Manager
| Alaim Viewer
2 Allen-Bradiey DF-1 Setup Utilty
2] BCEw
Evoadcast Graphics Forms Editor
[E Eroadcast Text Forms Editor
%y CimEdt
(3 CIMPLICITY Help
M. CIMPLICITY Options
[Z] Cimiview
il =

The OPC Alarm and Event Server window opens.
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i

File Settings Trace Help

Statistic | value [
Sample Period {ms) 1000
Murn Event Server Ohjects ul

Murn Subscriptions u]
Murn Browser Objects u]
Mum Events Generated i}
M Clienk Mokifications i}
Murn Events Last Sample Period 0

Step 1.2. Configure Projects

Sep 1.2. Configure Projects

Step 1.2.1 | Open the Security dialog.

Step 1.2.2 | Add a project.

Step 1.2.1. Open the Security Dialog

1. Click Settings on the OPC Alarm and Event Server window menu bar.

2. Select Configure Projects...

ﬁDPE Alarm and Event Server

File | Settings Trace Help

&= Configure Projects... _

Samf  Qpkions.., 1000

Iiim FYRRF ARFRF CIRIRCFS I

Mum Sabscriptions ]

Mum Browser Objects ]

Mum Events Generated ]
u]
u]

Mum Jient Mokifications
Mum Events Last Sample Period

The Security Dialog opens.
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=

1" Security Dialog =10 x|
0

il e

Diztadz
Buttons do the following:
Button Click to
OK Close the Security Dialog.
Cancel Close the Security Dialog and cancel your changes.
Add Add a new project to the OPC Alarm and Event Server.
Details Edit the configuration for an connected project.

Sep 1.2.2. Add a Project

1. Click Add in the Security Dialog.
A blank Project Properties dialog box opens.

2. Fill inthefields, asfollows.

Project Properties ﬂ

— Project Login
Project name : |C|MF'DEMU j
Uzer nare : IADMlNlSTHATUH

Pazzword : I xxxxx

Ok, I Cancel |

Field Description

Project name Project that will be connected to the OPC Alarm and Event Server.

E Note: Running projects are included in the drop-down list.
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Field Description

User name CIMPLICITY project user selected to access data on the OPC Alarm
and Event Server.

Password Password assigned to the user in the CIMPLICITY project.
Confirm password Repeat of entered password.
3. Click OK.
The OPC Alarm and Event Server will collect data from the configured project that displaysin
x
Projsct N | UserM o
ASUUHE:“ Anwmwz?mmﬁ W]
_Remore_|
Detals
1 | ﬂ

the list in the Security Dialog

4. Continue to add projects until all the projects that should be connected to this server are
connected.

Step 1.3. Apply the Changes to the OPC Alarm and Event Server

1. Click OK in the Security Dialog when you have completed adding projects to the OPC Alarm
and Event Server.

Project Mame | User Name
ASOURCE ADMINISTRATOR
*SOURCE ADMINISTRATOR

v
I

1| | 2]

* The Security Dialog closes.
» The OPC Alarm and Event Server window opens.
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i

File Settings Trace Help

Statistic | value [
Sample Period {ms) 1000
Murn Event Server Ohjects ul

Murn Subscriptions u]
Murn Browser Objects u]
Mum Events Generated i}
M Clienk Mokifications i}
Murn Events Last Sample Period 0

2. Click OK.
The message closes.

(1) Important: Thislistisfor Server projects only. Do not add the client project to the Security
dialog.

Step 1.4. Configure the OPC Alarm and Event Server Sampling Rate

1. Click Settings on the OPC Alarm and Event Server menu bar.

2. Select Options...

ﬁDPE Alarm and Event Server
File | Settimgs Trace Help

| Stat  Configure Projects...
Samg
Murn BEvent Server Bjecks
Murn Subscriptions

Murn Erowser Objects

Mum Events Genearated

M Clienk Matifications

Murn Events Last Sample Period

Qoo

1
I
1]
1]
1]
1]
1]

The OPC Server Options dialog box opens.

3. Configure the fields as follows.
i
Statistics zample period: |'| 0oo Millizeconds

Namezpace delimiter: Ia’

¥ Dizplay server window

ak I Cancel |

Field Description

Statistics sample period Number of milliseconds the server waits between samples
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Field Description

Namespace delimiter The character inserted in the fully qualified alarm name to

define a space between elements. Alarms that an OPC A & E
server collects must be configured on an OPC Client in order
for the values to display in the client's Alarm Viewer. The fully
qualified name is Source Proj ect/ Fact ory Resour ce/ Ref er ence
IDPAlarm I D

Display server window Do either of the following: Select the Display the Server check

box when it is started by the client, or clear the Hide the Server
check box when it is started by the client.

Step 1.5. Select Trace Options

1. Select Trace on the OPC Alarm and Event Server window menu bar.
The Trace menu displays.

2. Select options as follows.

¥ Mone
Cannect
Server
Subscription
Ewent
all

Set Trace File. ..

Enable COM Call Tracing

» Select one: None, Connect, Server, Subscription, Event, All
* Set Trace File...

+ Enable COM Call Tracing

Step 1.6. Close the OPC Alarm and Event Server

1. Click File on the OPC Alarm and Event Server menu.

2. Select Exit.

File Settings Trace Help
Request Clients to Disconnect

Murm Subscriptions

Murm Erowser Objects

Mum Events Generatec

Murn Client Mokifications

Murm Events Last Sampe Period

When you restart the Server the security configuration will be applied.
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Note: The connection to the OPC Alarm and Event Server is controlled using COM security.

Sep 2. Configure the OPC Alarm and Event Client

Step 2. Configure the OPC Alarm and Event Client

Alarms and events from OPC servers are created dynamically based on configuration for the
following alarms.

Alarm Dynamically creates

$OPC_MODEL_ALARM | Point alarms

$OPC_MODEL_EVENT | Events

You can:

» Modify the alarms to change the default behavior.

 View alarms that are collected by any connected OPC Alarm and Event Server in the
CIMPLICITY project's Alarm Viewer.

* Configure individual qualified source alarms on the client computer.

* Log alarmsto the Alarm log and events to the Event log.

9]
—
N
[E

Open an OPC A&E client dialog box.

=F

0]
=
@
©
N
N

Create a new connection to an OPC Alarm and Event Server.

-
2D o
D

ST

tep 2.3 | (Optional) Modify source alarms logging and deletion requirements for the client display.
e
76

Step 2.4 | (Optional) Configure source alarms on the client computer.
(page
179)

Step 2.1. Open an OPC A&E Client Dialog Box

Sep 2.1. Open an OPC A& E Client Dialog Box

Option Open a new OPC A&E Client dialog box.

2.1.1 (page
168)
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Option Open an existing OPC A&E Client dialog box.
2.1.2 (page
169)

Option 2.1.1. Open a New OPC A&E Client Dialog Box

CIMPLICITY provides several methods to open anew OPC A& E Client dialog box.

1. Select Project > Alarms> Alarm OPC Client in the Workbench left pane.

2. Do the following.

(¥ PROFNAV.gef - CIMPLICITY Warkbench ESEET =)
ys.le Edit Computer Project View Tools Help

Bl & 2|25
= Project -
oy Soresns
"ﬁ Objects
B Classes
rs g Paints
= ﬂ Alarris
+ 'E- Alarm Setups
i- Alarm Classes
4 Alarm Strings
® Alarm Printer

il

(- Alarm OPC Client =
Jﬂy Alarm Blocking :
o Alarm Translator -
-7 Seript Engine ;ﬂ
#1171 Equipment -« 1+ [ ' &
_hcardslkulmmlﬂ
A Click File>New on the Workbench menu bar.
B Click the New Object button on the Workbench toolbar.
C In the Workbench left pane, double click Alarm OPC Client.
D
In the Workbench right pane:
a. Right-click any OPC Client.
b. Select New on the Popup menu.
E Press Ctrl+N on the keyboard.

A New OPC A&E Client dialog box opens when you use any method.

3. Enter aname in the New OPC A&E Client dialog box.
x|

g |CLIENTN oK. |
Cancel |

The name will be used as the reference id for alarms gathered by the client.
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4. Click OK.

The OPC A&E Client dialog box opens.

Option 2.1.2. Open an Existing OPC A& E Dialog Box

CIMPLICITY provides severa methods to open an existing OPC A& E dialog box.

1. Select Project > Alarms > Alarm OPC Client in the Workbench |eft pane.
2. Select an OPC A& E client configuration in the Workbench right pane.

3. Do the following.

¥ PROFNAV.gef - CIMPLICITY Warkbench (o ) e
[ I AJ Edin | Computer  Project Misw Tools Help
058 E 5
™ Project -
jec T
o 5y Scresns .
"ﬁ Objects =
l'..-| Claszes &
* g Paints A
= ﬂ Alarms -
o Alarm Setups
'E- Alarm Classes =
4 Alarm Strings &
® Alarm Printer h
SN Aarm OPC Gl |
™y Alarm Elocking “:
o Alarm Translator -
-7 Seript Engine ;ﬂ
#1-1 Equipment N P ' &
|Records Estrieved : 1
A Click Edit>Properties on the Workbench menu bar.
B Click the Properties button on the Workbench toolbar.
C In the Workbench left pane:
a. Right-click Alarm OPC Client.
b. Select Properties on the Popup menu.
D In the Workbench right pane, double click an OPC A&E client configuration.
E Press Alt+Enter on the keyboard.

The selected OPC A&E Client dialog box opens when you use any method.

Step 2.2. Select the Client Alarm Viewer Display Criteria

Sep 2.2. Sdect the Client Alarm Viewer Display Criteria
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[EnY
S o
D

Step 2.2.1 | Create a new connection to an OPC Alarm and Event Server.

(2
QD D
® o

N

N

-

71

Filter alarms that display in the A & E OPC client Alarm Viewer.

172

(page
172)

Step 2.2.3 | Change attribute display in the Alarm Viewer message field.

Sep 2.2.1. Create a New Connection to an OPC Alarm and Event Server

1. Fill inthefieldsin the OPC A&E Client dialog box as follows.

OPC ARE Client - AMOPC_MASTER _NCLIENT x|

SabctSarwI

Server: |[CIMPLICITY HMLAES w1

4

Node: |

Resource ID; |OPCAE [ ﬂj Filter.

Message:

Refresh

Fields...

CIMPLICITY HMILAE Svi. 1 CIMPLICITY HM| A

T O O
rect 19, 52, 226, 79 (page 170)

rect 13, 86,

211, 113 (page 171)

rect 14, 116, 212, 143 (page 171)
rect 213, 116, 289, 143 (page 171)
rect 13, 143, 211, 170 (page 171)
rect 211, 143, 287, 170 (page 171)
rect 216, 86, 292, 113 (page 171)

Option

Description

Server

The OPC Alarm and Event Server that this client connects to. The server can be selected by double-
clicking one of the configured OPC Alarm and Event Servers that display in the Server list in the
bottom half of the OPC A&E Client dialog box.
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Option Description

Node The computer name on which the server is located.

@ Note:
« If the OPC Alarm and Event Server is on the local computer, the Node field can be blank.

» One client can connect to one OPC Server. If you have multiple OPC Servers, create multiple
OPC clients.

Resource | Factory resource the OPC Alarm and Event Server will use to collect alarm data.
ID

Filter Opens the OPC Filter window (page 171) to select alarm filter criteria.

Message | Attribute entries configure the alarm message that displays for the source alarms.

Fields Opens the OPC Fields browser (page 172) to list the attributes that can be selected for the
Message field.

Refresh Refreshes the display.

2. Click OK.

The OPC A&E Client dialog closes.

Alarms from projects that are configured for the OPC Alarm and Event Server will display in the
client's Alarm Viewer.

When thereis no filter all of the alarms generated on the source and client computers display in the
Alarm Viewer.

[Gorcacam =T
Fle Yiew Help

F &8t 1 | @O

Alarm I [Message [Ctass [Subcondti|State  Tack ]
JASOURCEIPCAT 5 "AMIKSIATANKS CALL THE ATANKS SUPERT  $5YE Lo ALARM M
ISOURCEROPCA, __/ANKESATANKE CaALL THE ATANKG SUPER!  35YS  Lolo ALARM M
NHILMZ CALL NKILNZ SUPER! HIGH  HHi ALARM N
PLIMPH B CALL NPUMP1 SUPER! HGH  HI ALARM N
PLMP3 A CALL NFUMP3 SUPERI HGH Lole  ALARM N
SOURCEIOPCAR 7 ANH4HTAMNKY CALL XTAMK4 SUPER! FENE H ALERM M
SDURCEDPcUmsmmrnG CALL XTANKS SUPER! FSYS HI ALARM N

7 Sep 28 17:09 Togge | Setw | FRetiesn | e |
For Help, press F1 [ v

A | Alarms from a source project.

B | Alarms from a client project

C | Alarms from a source project.

Sep 2.2.2. Filter Alarms that Display in the A & E OPC Client Alarm Viewer

1. Click the Filter button - |in the OPC A&E Client dialog box.
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The OPC Filter window opens.

2. Select the following.

i
Areas and Sources: Categaries: ok I
= [JA ASOURCE [¥|Level
AFA ¥SOURCE (¥0PC_SERVER_ERROA Cancel
= [0A OPCAE
5 FA RN
®KILM1
w004 KEILN2
@ FA KTANK]
2 FlA RTaNE2
s HTANK2 - Event Type-
w-LTA XTANK3 ¥ Simple
¥ Condition
¥ Tracking
— Severity Range
Low: |1 5'
High [1000 _%'
Select Al | Clear A1
Window .
Description
area

Areas and | Are created dynamically as the alarms are generated. If the alarms have not been generated then
Sources they will not show in the list of areas and sources. If there are no selections, all alarms display in
the Alarm Viewer. You can select sources or areas for which you want to receive alarms.

A

S

Categories | Check which categories to receive. If there are no selections all categories will display.

Event Type | Types of alarms and events the should display: Simple, Condition, Tracking.

Severity Lowest and highest limits in the severity range (page 42) in which displayed alarms fall.
Range

Y our selections determine which alarms will display in the Alarm Viewer control.

Sep 2.2.3. Change the Display in the Alarm Viewer Message Field

Y ou can enhance or change the information that displays in the source projects message field.

1. Make sure that dynamic configuration is turned on in the client project, if the project is running.

2. Do any of the following:
« Add an attribute.
« Add text.
+ Add text and attributes.
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* Leave the M essage field blank.

(1) Important: You can make multiple entriesin the M essage field. If you do |eave spaces
between each selection, the spaces will display during runtime. However, the maximum alarm
message length is 73 characters, including the point ID (and spaces). If the message is longer,
the message will be truncated after 73 characters.

Add an attribute

The following attributes are available for the OPC Alarm and Event Client use.

« Category
+ Condition

* Message
» Subcondition

When you enter an attribute in the M essage field, make sure the attribute is enclosed in <>, e.g.
<Category>

© Tip: Click the Fields button _Fes |y open the OPC Fields browser and select an attribute.

Values for the selected attributes will display in the message field during
07C A& Client - AMOPC_MASTER_NCLIENT x|

Select Server |

Server. [CMPLICITY HMIAES vi.1

Node: | Refresh |
HasomlD:lUF‘C‘iE éjj Filer... I

Message:d/lﬁubcnndition) <Meszage Fields...

+u, OPCAE.cim

File Wiew Help

|E a1 BE®

Alarm D |Message
SOURCEOPCAEXTANKAMTANKS Lolo  CALL XTANK4 SUPER!
SOURCE/OPCAE/XTANK2/MTANKZ 2 Lo CALL XTANK2 SUPER!

8 SOURCE/OPCAEIATAMK2IATANKZ=" Hi  CALL THE ATAMNK2 SUPER!
M SOURCEIOPCAEATANKTIATAMNKI HHi  CALL THE ATAMNK1 SUPER!

CLEENTS CALL NCLIENT3 SUPER!

CLIENT2 2, CALL NCLIENT2 SUPER!

. B STt s e e
runtime. 24 i

1 | Fields and spaces configured for the OPC Alarm and Event Server alarm messages.

2 | OPC Alarm and Event Server alarm fields and spaces display in the runtime Message column.

3 | Alarm messages display for Client alarms during runtime.
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Add text
Y ou can enter any text in the M essage field.

The entered text will display in the alarm’'s Message field during
|

Select Server |

Server [EIMF‘L]CITY.HMIAESW.I

MNode: [ Refresh |
ResoucelD:lDME é]j Filter... |

Has%l.& &E OPC ALARMI Fields... |
e s oecatm

CIMFU File Wiew Help
o = &8 t..1|‘

Alarm D |Message
SOURCEMOPCAEMTANKAMTANKA A & E OPC ALARM
SOURCE/OPCAEMTANK2MTANKS o A & E OPC ALARM!

8 SOURCEIOPCAEIMTANKZIATANK I A & E OPC ALARM

A SOURCEMOPCAEATANK ATANKA A & E OPC ALARM

CLIEMTS CALL MCLIEMTS SUPER!

CLIEMTZ2 3 CALL MCLIEMT2 SUPER!

. CLIEM S caLL NCLIENTY SURER!
runtime. —— ——

1 | Actual text that will display as the OPC Alarm and Event Server alarm message.

2 | Actual text that displays as the OPC Alarm and Event Server alarm message during runtime

Note: The number of spaces between the text and sub-condition value correspond to the number of spaces
entered in the Message field during configuration.

3 | Alarm messages display for Client alarms during runtime.

Add text and attributes

Y ou can enter text and one or more attributes in the M essage field.
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The entered text and values for the attributes display in the alarm's Message field during

OPC A&E Client - AMOPC_MASTER _NCLIENT

runtime.

Select Server |

Server [EIMPL]EITY.HMIAESW.I

Mode: | Refresh

HasmlD:lDPCAE ﬂi] Filter... |
Message\l/lNlFHlHI! <Subcondition Fields. . |

x|

«u DPCAE.cim

CIM File View Help

S &Kt | BE®

Alarm ID | Message

L SOURCE/OPCAEATANKZIATANKZ SHUTDCWR IF HIHE - Hi
WSOURCE/OPCAEATANKTIATANKT 2 SHUTDOWGN IF HIHIE  HiHi
SOURCEIOPCAEMXTAMKAMTANKS =" SHUTDOWM IF HHI Lol
SOURCEOPCAEMNTAMKZITANKZ SHUTDOWM IF HIHE - Lo

CLIEMT3 CALL MCLIEMT3 SUPER!

CLIEMTZ2 3 CALL NCLIENT2 SUPER!

CLIEMTT ~ CALL MCLIEMTY SUPER!
L™ e

1 | Actual text and sub-condition whose value will display as the OPC Alarm and Event Server alarm message.

2 | Actual text and sub-condition value that display as the OPC Alarm and Event Server alarm message during runtime

Note: The number of spaces between the text and the sub-condition value correspond to the number of
spaces entered in the Message field during configuration.

3 | Alarm messages display for Client alarms during runtime.

Leave the field blank

Entry in the Message field is optional. It can be left blank.
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The original message entered for the alarm
x|

Select Server |

Server [EIMF'LII]TY.HMIAESW.I

MNode: [ Refresh |
Hesmoel[):lw ﬁﬂ Filter... |

Hss%l Fields... I

File Wiew Help

Sel
Clh

e LA LA =1El=

Alarm D | Message
SOURCEIOPCAEMTAMNKAMT ANK S CALL XTAMNK4 SUPER!
SOURCEIOPCAEMT ANKZMT ANK 2 \E,;CALL HTANKZ SUPER!

WSOURCEMOPCAEMATANKZIATANK2 = CALL THE ATANK2 SUPER!

S OURCE/DPCAEATAMKT IATANK CALL THE ATANKT SUPER!

CLIENT3 CALL NCLIEMT3 SUPER!

CLIENT2 3 CALL NCLIENTZ2 SUPER!

i CLIEMT1 UCALL MCLIEMT1 SUPER!
displays. e —

1 | The Client has no configuration to override the original message for Server alarms.

2 | Alarm messages configured in the Server projects display for the Server alarms during runtime

3 | Alarm messages display for Client alarms during runtime.

Step 2.3. Modify Source Alarms Default Logging and Deletion Requirements for the Client

Display

Alarms and events from OPC servers are created dynamically based on the following alarmsin the

client computer Alarms folder.

Alarm Dynamically creates
$OPC_MODEL_ALARM | Point alarms
$OPC_MODEL_EVENT | Events
T CLIENT.of - CIMBLICITY Wrkbench [ESNIE
Fio Ek Computer Fropct View Took Help
&3 [HM
5 Project * | darm 1D Message ClassID Alam Type |
i a ;Chm & sLoa_pasee User 10 % dsabled, compu...  $575 SLOGIN_FABLL. . -
= ks =
B Classes & focw User: % Logged On §515 $MAC_EVENT e
ém | aﬂ("\(f.ﬂT Lrr: % Lo Cud 455 tMAC FYENT
[ ﬂ $OPC_MODEL_ALARM Yol $5VS $OPC The OPC mode, ..
+ Alsrm
g Mamienws | R $OPC_MODEL_EVENT  %s $5vs $0PC
Alorm Strings R Eoy2t Rt el B T T T e 3 S
Blarm Prinkes 1 shTe_i e _pow Hiode s detects Inkto %s ... HIGH $RTR e .. b
B s OPC Chert 1 socereomL Mok added BASIC o
% darm Blocking @ sooeoeommuL Mok added BASIC &
2 i Alsem Traslstor @ st aLarm s 4515 AMST ALIRM T =
| Script Engine = [ ¥ L |
Amady Sop
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Y ou can modify these alarms to change the default behavior for the source alarms.

1. Double-click either $OPC_MODEL_ALARMOr $OPC_MODEL_EVENT in the Alarms folder on the
client computer.
The Alarm Definition dialog box for the selected alarm opens.

2. Select the Alarm Definition tab.

3. Optional: Check one or more of the Alarm Logging options.

Alarm Definition - $0PC_MODEL_ALARM x|

Alarrn Definition | Alarmn Routing I Alarrn Options I

Description: IThe 0OPC model alarm
Alarm clazs: |$SYS ﬂ j
Alarmn type: |$DPC j

Help file: I Severity: I'I _l;'

Alam message; %
T

Alarm Logging
[T Generate [ Delete
[~ Acknowledge [~ Reset
J-E— - -
Alarm Option Description Default Value
$OPC_MODEL_ALARM | Alarm Alarms are logged to the Alarm log for checked All check boxes are
Logging options. clear.
$OPC_MODEL_EVENT | Alarm Event alarms are logged to the Event log for All check boxes are
Logging checked options. clear.

|=/ Note: Do not change the Alarm class and Alarm type.

4. Select the Alarm Options tab.

5. Optional: Change default options to your system requirements.
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Alarm Definition - $0PC_MODEL_EYENT ﬂ

Alarm Definition I &larm Fouting  Alarm Options |

A -Deletion requirements —
e

cC
¥ Acknowledge -
D

[~ Reset \T/

B - Automatic actions

N

Printer repeat: |<N0ne> 'I
Auto acknowledge: IImmediate 'I
Auto rezet; |<None> vl

[ Manual reset allowed

b airurn stacked: IEI

L etter Alarm Option Default Value

A $OPC_MODEL_ALARM | Deletion requirements
Acknowledge Checked
Reset Checked

B Automatic actions
Printer repeat <None>
Auto acknowledge <None>
Auto reset <None>

C Manual reset allowed | Clear

D Maximum stacked 0

A $OPC_MODEL_EVENT | Deletion requirements
Acknowledge Checked
Reset Clear

B Automatic actions
Printer repeat <None>
Auto acknowledge <Immediate>
Auto reset <None>

C Manual reset allowed | Clear

D Maximum stacked 0

(1) Important:
« If you change any of these requirements, e.g. check Manual reset allowed, you can delete
the Alarm from the client Alarm Viewer display. However, this action is not sent back
through the OPC server to the source project.
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« Change the default $OPC_MODEL_EVENT Auto acknowledge to <None> if you want
usersto view event alarmsin the client Alarm Viewer.

Step 2.4. Configure Source Alarms on the Client Computer

Sep 2.4. Configure Source Alarms on the Client Computer

Step 2.4.1 | Create source alarms on the client computer.

(page
179

Step 2.4.2 | Define source alarms on the client computer.
(page
180)

Sep 2.4.1. Create Source Alarms on the Client Computer

Y ou can also configure source alarms on the client computer if you know the following:
* Project names

* Factory resource IDs
» Alarm reference IDs

Note: A point alarm'sreference ID isthe point ID.

* Alarm IDs
This gives you more control over the alarm display.

1. Double-click Alarmsin the left pane of the client project Workbench.

T PROFCIMP - CIMPLICITY Workbentch ==
| File Edit Computer Project WView Took Help
Oh& (&5
=[] Project = | Alarm ID Clas = 5
t-3y Screens f cistion cox -
B Objects : =
N Classes B oisTance Back Regh.. BAT
- | | BoOISTANCE.To_Region... Bas &
= | 8 ceTauToaReLY BAE
SO0 Alarm Setups 8 HEAT FACTORYOL.MA... HEF
Alaren Classes 8 HEAT FACTORYOLW... HEZ <
Alarmn Strings 8 HEAT FACTORYIZ.MA... HEEZ| ©
Alarmn Priniter 8 HEAT.SOUTH.Region.... HEF— B
& alarm OPC Client 8 HEAT.SOUTH.Region.... HEF [
&) Alarm Blocking 8 HEAT.S0UTH.Region.... HEE &
o, Alarmn Translator 8 HEAT.50UTH.Region.... HEZ
t Script Engine @ HEATSyeem EAST.SE... BAS ™ W
| 7 Equipment - |4 m 1 :l'l
Records Retrieved : 1

A New Alarm dialog box opens.



Alarms and Messages | 8 - OPC Alarm and Event Server and Client | 180

2. Enter afully qualified name for a source project alarm that will be viewed in the client's Alarm
Viewer.

Proj ect/ Factory Resource |ID/ Reference ID/Alarm I D.

(1) Important: Thefully qualified alarm ID:
» Must be a maximum of 255 characters or less.
« Cannot contain the characters: $, | or start with @.

Example
SNORTH/AANDE/SN5/SN5

Newalarm x|

Alam |D: |F|EE.:"EIF'EAE;’><T#3«NK1 oK I
Cancel |

|=/ Note: If areference ID has not been specifically specified for the point it is the same as the
point ID.

The alarm can now be configured similar to alocal alarm.

Sep 2.4.2. Define Source Alarms on the Client Computer

1. Select the Alarm Definition tab in the Alarm Definition dialog box.
Options descriptions are:
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Alarm Definition - XSOURCE/OPCAE/XTANE1 /XT,

Alairn Defiration |AlamF|uu:m| Mamﬂph'msl

Desciiptior: [Alam XTANKY from XSOURCE

penson O ]

Alairn bype: lm

Hepfie [ sewiw [
Alairn message: Ik’,s ‘1

Alzirn Logging
¥ Generate [ Delete

[ Acknowledge [ Reset

rect 12, 45, 342, 75 (page 181)
rect 12, 72, 212, 102 (page 181)
rect 12, 124, 212, 150 (page 181)
rect 13, 100, 213, 126 (page 181)
rect 211, 123, 332, 149 (page 181)
rect 12, 148, 327, 174 (page 181)
rect 11, 174, 169, 229 (page 181)

Field Description

Description | Used to describe the alarm in the client project, e.g. in the Workbench right pane.

Alarm Colors for states in the class that are recognized by the OPC A & E configuration display in the
class Alarm Viewer.

=5 Note: The class name does not have to be the same as the class used on the OPC A& E
server.

Alarm type | $CIMBASIC is the required entry.

Help file (Optional) Name of a text file that users can display when they click the Help button in the Alarm
Viewer. You can enter a filename of up to 67 characters.

Severity A number the identifies the importance of the alarm; the higher the number, the more severe the
state. This enables you to prioritize alarms.

Alarm %s (lower case) is the required entry.

message

Alarm Alarms are recorded in the client project's Alarm log, based on the checked conditions.
Logging

2. Select the Alarm Routing tab.

3. Make sure the alarms are routed to the role for the A & E OPC server user.
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Alarm Definition - XEUUR[E.."UPEHEJ'XT“IMNI
Alaim Defirdion  Alarm Rouing | Alam Options |
Available roles

Configured roles for alsm

Help

4. Optional: Configure alarm options.

5. Click OK to close the Alarm Definition dialog box.

The qualified alarm displays the source alarm data that is recognized by the OPC Alarm and Event

configuration.

& OPCAE.cim

File View Help
S &%t 1 D®O |
Alarm D | Messane |state  |Ciass | Subconct Project Mame
o SOURCEIOPCAEIATANKIIATANKS  CALL THE ATANKI SUPERT  ALARM  $5vS HHi NCLENT
MSOURCEAPCAEMTANKINTANCS  CALL XTANKS SUPERI ALARM §SYS  HHi NCLENT
P SCURCEXPCAEMTANKZNTANKZ  CALL XTANK2 SUPER! ALARM MED  HHi NCLENT
e SCURCEXPCAEMTANKAKTANK]  CALL XTANK1 SUPER! ALARM  HIGH  HHi NCLENT
NHILMZ CALL NHILM2 SUPER ALARM  HIGH HiHi RCLENT
1 2 3
4 e A

rect 21, 63, 164, 159 (page 182)
rect 325, 54, 358, 150 (page 182)
rect 357, 55, 390, 151 (page 183)

1
the Client project.

Alarm IDs from Server projects display the same type of qualified name whether or not they have been defined in

Alarm type
Auto qualified Server alarms
Qualified Server alarms

Client alarms

The class assigned to the alarm ID in the client project is one of the following:
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The sub-condition that displays in the Sub-condition column reflects the alarm limits assigned in the alarm's source
project. The color assigned to the alarm ID (page 184) is based on the sub-condition for the assigned class and
the alarm state.

Alarm type
Auto qualified Server alarms
Qualified Server alarms

Client alarms

Sep 3. Use the OPC Alarm and Event Client and Server at Runtime

Step 3. Use the OPC Alarm and Event Client and Server at Runtime

Step 3.1 | Start the source and client projects.

<

Use the OPC Alarm and Event Client Alarm Viewer.

Review runtime statistics in the OPC Alarm and Event server window.

«
QD D
(Dpo

w

-
[ee]
o1

Step 3
age
86

.4 | Disconnect clients.

ﬁﬁ%

Step 3.1. Start the Source and Client Projects

1. Start the source project or projects.

ri‘?j SOURCE.gef - CIMPLICITY Warkbench lﬂ&]
Edit Computer Project Wiew Took Help
e oW S AWK E
3 Projet | Alarm I0 ERre
1 %;:;:s 8 HEAT SOUTHRegionD4_. 1
B Clacems 8 eveLTeast
+ ; Pois 18 LEVELTHORTH
LB 18 LEVELTSOUTH
4 Alarm Setups E| | 8 LeveLTwEST P
) Alarm Classes 8 LevEL_Reservor EASTT. I
Alarm Strings ﬂ LEVEL _Resaryor_MORT.. E
Alarm Prinker B LEVEL_Reservor_SOUT..
& Alsrm OPC Cherit 8 LEVEL_Reservor_WEST.,
) Alarm Blacking 18 mce_PROC_DOWN B
o Alsrm Tranststor 18 racki0i
#-[]) Seript Engine @ rackzol
- Equipment arvant B
+-[7) Security - FRNT F
Resdy

2. Start the client project.
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[W CLIENT - CIMPLICITY Workbench lilﬂléw

1 ER Computer Project View Toos Help |
e s hy WK EE. E
=13 Project ~ | Alsem D -y

3o 8o s
B Claseas 8 LeveLTERST
1 Boinks 8 LeveLTioRTH
1 18 LEvELTSOUTH
o 48 Aam setps |- | | T8 LEVELTWEST
Alarm Classes 1 LeveL _Reservor_EASTT. g
larm Strings 8 LeveL_Reservor_hoRT.. B
B Alarm Prinker 8 LEVEL_Ressrvoir_SOUT..
B alarm OPC Clert 8 LEvEL_Reservor_WEST.,
T Alarm Blacking 18 mcP_proC_Down E
+1- @, Alsrn Translstor 1 rackion
- 7) Seript Engine 1 packzni
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The OPC Alarm and Event Server window opens on the server computer, if it isnot already running.

OPC Alarm and E¥ent Server 10l =l

File Settings Trace Help

Statistic | value [
Sample Period {ms) S0000
Mum Event Server Cbjects 1

Mum Subscriptions 1
Tum Browser Cbjects i}
Mum Events Generated 3
Mum Client Motifications 3
Mum Events Last Sample Period 3

Step 3.2. Use the OPC Alarm and Event Client Alarm Viewer

Open an Alarm Viewer control or the stand alone Alarm Viewer on the client computer.

The display reflects your configuration and the alarm source.
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=g
Ele View Help

= &t 1| BEE

Alarm 1D | Mezsage |Class |Subconati State | Ac
BEOURCEOPCAEIATAMCIAT AN CLOSE THE ATAMKZ WALWE! HGH Lo ALARM N
LSOURCEADPCAEATANK JATANK CALL ATANKT MER for ASCURCE 1 WIED Lolo MORMAL N

SOURCEIPCAEMTANK2MNTANKZ CALL XTANKZ SUPER! MED H ALARM N
{SOURCEOPCAEMKTAMK K TANK CALL XTANK1 SUPER! HIGH  HHi ALARM N
{SOURCE/OPCAEMTANKIMTANKS CALL XTANKS SUPER! 2 | $5YS H MORMAL N

ISOURCEIOPCAEIAT ANKSMTANKS CALL THE ATANKS SUPER? $SYS  Lolo ALARM N
IHSOURCESSYSTEMATANKABDYN_CFG ALARM ATANKY changed by ADh ATOR(BJ.. $SYS System  ALARM N

SOURCESSYSTEMMKILMZSOYN_CFG  ALARM XKILMZ changed by ADME TOR(BY . $5YS System ALARM N
HPLIMF3 CALL NFUMP3 SUPER! HIGH Lo ALARM N
MPLINPY CALL NPUMP SUPER! 4 HGH H ALARM N
HILNZ CALL MrILNZ SUPERI HiGH  HHi ALARM N

rect 8, 78, 521, 124 (page 185)

rect 5, 182, 518, 221 (page 185)
rect 7, 159, 520, 184 (page 185)
rect 8, 124, 521, 160 (page 185)

Configured source: Alarm ID, Message, Class, Subcondition.
age

Source alarm: Alarm 1D, Message, Class, Subcondition.

Source event: Alarm ID, Message, Class, Subcondition.

NEE

Client alarm: Alarm ID, Message, Class, Subcondition.

Step 3.3. Review Runtime Statistics in the OPC Alarm and Event Server Window

The OPC Alarm and Event Server window (page 161) displays statistics to inform you of client/
source projects alarm activity.

OPC Alarm and Event 5erv i

File Settings Trace Help

Statistic | value [
Sample Period {ms) 1000

Murn Event Server Ohjects 2

Murn Subscriptions z

Murn Browser Objects u]

Mum Events Generated 30

M Clienk Mokifications &0

Murn Events Last Sample Period 19
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Statistic

Describes Number of:

Sample Period (ms)

Milliseconds the server takes to collect data. At the end of the period, the data is displayed
in the Client Alarm Viewers.

Num Event Server
Objects

Internal events and alarms currently supported by the server.

Num Subscriptions

Clients that are running and being sent data from the server.

Num Browser Objects

Clients browsing for information.

|5 Note: CIMPLICITY OPC Alarm and Event Server supports clients with browsing
functionality.

Num Events Generated

Changes of states; changes include alarms being activated and alarms acknowledged.

Num Client Notifications

Number of server to client notifications.

Num Events Last
Sample Period

Events the server collected during the specified sample period.
Example

The server collected 19 events during the last 1000 milliseconds, the length specified for the
server's sample period.

Step 3.4. Disconnect Clients

1. Click File on the OPC Alarm and Event Server window menu bar.

2. Select Request Clientsto Disconnect.

HZ0PC Alarm and Even

File Settings Trace Help

Exit:

Request Clients to Discannect PV
0

=101 ]

TIOm Event server LDJects
Mum Subscriptions

Tum Browser Cbjects
Mum Events Generated
Mum Client Motifications

Mum Events Last Sample Period

oo o oM

All clients connected to the OPC Alarm and Event Server are disconnected for the sample period.
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i

File Settings Trace Help

Statistic | value |
Sample Period {ms) 1000

Murn Event Server Ohjects

Mum Subscriptions @

Murn Browser Objects

Mum Events Generated

ul
M Clienk Mokifications i}
Murn Events Last Sample Period 0

At the end of the sampling period they are reconnected.

i

File Settings Trace Help

Statistic | value [
Sample Period {ms) 1000

Murn Event Server Ohjects

Murn Subscriptions @

Murn Browser Objects

Mum Events Generated

ul
M Clienk Mokifications i}
Murn Events Last Sample Period 0

OPC Alarm and Event Server Technical Notes

» Redundant environments.
+ DCOM configuration.
» OPC Alarm & Event server shortcut icon.

Redundant Environments

The OPC Alarm and Event Server should be run on athird computer in aredundant environment.
The OPC server will then fail over correctly

|=/ Note: If you try to configure an OPC Alarm and Event Server on the primary and secondary
computers, you will create a feedback loop that will fail.

DCOM Configuration

When you want the OPC Alarm and Event Clients to communicate with an off-node OPC Alarm and
Event Server, configure the same DCOM configuration for the OPC Alarm and Event Server and
OPCEnum as you do for the CIMPLICITY OPC Server.
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OPC Alarm & Event Server Shortcut Icon
Y ou can place a shortcut ic...to open the OPC Alarm & Event server.

When the OPC Alarm & Event server opensit:

* Reads project configuration at startup and populates the server configuration database.

* Setsits statusto OPCAE_STATUS NOCONFIG until al configuration information is
processed.

* Setsthe statusto OPCAE_STATUS RUNNING when it isready.

+ Updates its configuration as projects are added and removed and in addition processes dynamic
configuration notifications from the projects to keep its own configuration database up-to-date.

(1) Important: A&E OPC Clients should not use the A& E OPC Server while the statusiis
OPCAE_STATUS NOCONFIG.

Make sure the server statusis OPCAE_STATUS RUNNING before attempting to set afilter.
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